juicedata/juicefs
Documented errors, page 4 of 7. Back to juicedata/juicefs
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| ceph: can't put empty file | error_code | error | ceph, object-storage, upload, empty-file |
| delete dir stats | exception | error | go, kv, tikv, format, dirstats, transaction |
| expect 1 keys but got | panic | error | etcd, invariant, panic, transaction, juicefs |
| database :// is not empty | error_code | error | juicefs, metadata, load, etcd, tkv |
| get local ip | error_code | error | network, ip-resolution, distributed-sync |
| worker config is missing source or destination | exception | error | sync, cluster, validation, stdin |
| find more than one mount process for | console | error | cli, process, mount |
| failed to read segment | exception | error | backup-restore, protobuf, offset |
| format decrypt | console | critical | encryption, rsa, object-storage, config |
| invalid scheme , should be cifs:// or smb:// | validation | error | cifs, smb, url-validation, config |
| list chunk prefix | exception | error | go, object-storage, s3, gc, listing |
| decode | exception | error | json, metadata-dump, acl, decoding |
| failed to unmarshal footer | exception | error | protobuf, backup, corrupt-file, unmarshal |
| no entries found | exception | warning | windows, ldap, active-directory, empty-result |
| clean quotas | error_code | error | metadata, quota, repair, backend |
| failed to create plain backup | exception | error | filesystem, file-write, backup-restore |
| failed to write system info file | console | error | |
| Invalid endpoint | exception | error | object-storage, url, minio |
| scan slices | exception | error | gc, metadata, scan, redis, database |
| list should not return anything, but got | console | error | object-storage, objbench, list, prefix-filter |
| load setting | exception | error | cli, metadata, status, config |
| update table session2, delslices, dirstats, detachedNode… | exception | error | database, sql, schema-upgrade, legacy, session |
| error GET request | console | error | go, http, network, timeout |
| Fail to get location of bucket | exception | error | object-storage, baidu-bos, region-lookup, credentials |
| failed to get absolute path | console | error | cli, paths |
| option requires a value | exception | error | |
| printsid command is only supported on Windows | exception | error | windows, platform, cli, sid |
| commit upload | error_code | error | |
| incompatible hadoop version | exception | error | hadoop, reflection, compatibility |
| new GCM | exception | error | crypto, gcm, aes, config |
| binary mode doesn't take an errors argument | validation | error | python, valueerror, file-open, binary-mode |
| failed to write segment type | exception | error | io, backup, write-failed, disk-full |
| construct fileStatus failed | exception | error | java, hadoop, reflection, version-compat |
| first object size should be 0, but got | console | error | object-storage, list, size, filesystem |
| format is not inserted | exception | error | database, sql, insert, format, race |
| list should return 1 keys, but got | console | error | object-storage, objbench, list, pagination |
| not found local ip | error_code | error | network, ip-resolution, distributed-sync |
| object key escapes storage root | exception | error | |
| error decoding Base64 encoded data | exception | error | hdfs, kerberos, base64, environment-variable |
| Failed to create registry key | exception | error | windows, registry, winfsp, permissions |
| Failed to put | console | critical | object-storage, permissions, s3 |
| invalid dumped meta | exception | error | dump, json, internal-invariant |
| load | exception | error | load, dump, metadata, json |
| is not inside JuiceFS | console | error | cli, filesystem, mount-point, path-resolution |
| Unsupported ByteMultiple " + sMultiple | exception | error | java, cli, benchmark, argument-parsing |
| Invalid ACL: ACL has " + accessEntries.size() + " access… | validation | error | acl, java, limit-exceeded |
| invalid owner key | error_code | error | locking, metadata, key-format |
| StubLoader load failed | exception | critical | native-library, jvm, loading |
| The current trash will be emptied and future removed files… | console | warning | cli, trash, data-loss |
| write out of chunk boundary | exception | error | boundary, write, chunk |
| changelog is not enabled, use `juicefs config | console | error | cli, metadata, changelog |
| no available cache dir | error_code | error | |
| invalid tier id | error_code | error | azure, blob-storage, tiering, config |
| failed to read config | exception | error | umount, config, fuse, mountpoint |
| no mount command found for | console | error | cli, process, mount |
| Failed to open registry key | exception | error | windows, registry, winfsp, permissions |
| message is not supported | exception | warning | ipc, version-compatibility |
| are you connected to the network? | error_code | error | network, java-sdk, ip-address |
| bad response status | http | error | dragonfly, http, upload, network |
| mount point mismatch | console | error | |
| get slices of inode index error | exception | error | metadata, iteration, cache |
| invalid gc meta record size | exception | error | gc, external-sort, corruption, deserialization |
| encrypt_chunked: ciphertext | exception | error | crypto, internal-invariant, chunked-encryption |
| Failed to mount juicefs as system service | exception | error | windows, winfsp, service, process |
| jfsObjects.NewNSLock: the length of the objects parameter… | panic | error | gateway, s3, locking, panic |
| <combined output of failed umount command> | error_code | error | |
| endpoint should be a valid share name | validation | error | cifs, smb, endpoint, config |
| failed to exec command line | console | error | windows, wmic, exec, process-introspection |
| get | panic | error | etcd, network, grpc, transaction, juicefs |
| Source file " + normalizePath(src) + " is… | exception | error | java, hadoop, validation |
| unsupported driver | exception | error | |
| create multipart upload failed | console | error | object-storage, multipart-upload, benchmark |
| create table delegationToken | exception | error | database, sql, schema-migration, mysql, postgresql, sqlite |
| expect key , but got | panic | error | etcd, invariant, panic, transaction, juicefs |
| failed to parse PEM block containing the key | error_code | error | encryption, rsa, pem, key-parsing |
| fuse is not installed. Please install it first | exception | error | fuse, mount, missing-dependency, fusermount |
| get delegation token failed, return code | exception | error | |
| set total inodes | error_code | error | quota, counter, kv-store, write-failed |
| size of first key shold be 5, but got | console | error | object-storage, list, size, filesystem |
| claim delayed slice | exception | error | database, gc, sql, transaction |
| some errors occurred, please check the log of fsck | error_code | error | fsck, consistency, meta |
| listing failed, stop syncing, waiting for pending ones | exception | error | |
| segment is nil | exception | error | protobuf, backup, nil-value, invariant |
| multipart | exception | error | sync, multipart-upload, s3 |
| name is required | exception | error | hadoop, filesystem, configuration |
| dump dir failed | exception | error | |
| illegal value for parameter 'ranger-service': " +… | exception | error | ranger, configuration, validation |
| Only SuperUser can do setOwner Action, the current user is… | exception | error | |
| random, backward, skip are only valid under read | exception | error | java, cli, benchmark, argument-parsing |
| buffer is full | exception | warning | logging, syslog, buffer |
| create table dirStats | exception | error | database, schema-migration, ddl, stats |
| failed to find mount process | console | error | windows, wmic, process-not-found, process-introspection |
| scan global user group usage | error_code | error | quota, scan, metadata-backend |
ErrSkipped skipped | error_code | info | sync, special-files, skip |
| load meta format | exception | error | metadata, redis, format, initialization |
| mount | exception | error | |
| the downloaded content is incorrect | exception | error | |
| --tier should be between 0 and 3 | validation | error | cli, validation, tier, argument |
| begin upload | error_code | error | storj, upload, network |
| create meta sorter | exception | error | go, gc, external-sort, filesystem, config |