juicedata/juicefs

Documented errors, page 2 of 7. Back to juicedata/juicefs

Code / MessageTypeSeverityTags
restore command requires Administrator or elevated…
exception error windows, admin, privilege, trash, cli
get certificate error certFile
error_code error redis, tls, certificate, config
Mount command succeeded, but the mountpoint
exception error windows, winfsp, mount, timeout
Problem with kerberos authentication
exception error hdfs, kerberos, authentication, object-storage
failed to convert to
exception error io, backup-restore, network
(cancelled) upload block
exception warning upload, retry, cancellation, network
compact [ : ] error
console error metadata, compact, cli
drop table dirStats
exception error database, sql, metadata, format
invalid quota value
error_code error redis, quota, metadata, data-corruption
new sm4 GCM
exception error crypto, encryption, sm4, config
scan trash slices
exception error go, metadata, gc, redis, database
failed to write segment data
exception error io, write-failed, short-write, backup
invalid key , fail to parse id
exception warning go, redis, gc, key-format
new session
error_code error redis, session, network, write-failed
read ca cert file error path
error_code error tls, redis, file-read, configuration
expect mode %o but got %o
exception warning object-storage, permissions, chmod, benchmark
Failed to get current file path
exception error windows, winfsp, registry, filesystem
recovered from
exception error panic-recovery, internal-bug, load, corruption
The bucket " " doesn't look like a file path.
console warning cli, object-storage, validation
unexpected dragonfly object storage name
validation error dragonfly, object-storage, compatibility, metadata
Cannot load default config
exception error java, hadoop, configuration, environment
get counter
exception error go, redis, dump, counters
invalid unit
validation critical config, parsing, cli, units
skip special file for jfs
exception warning juicefs, special-file, s3-gateway, sync
failed to create message by type
exception error protobuf, backup, version-compatibility
Forbidden
http error http, webdav, permission-denied
list should return 2 keys, but got
console error object-storage, list, filesystem, benchmark
scan dir stats
exception error go, kv, tikv, etcd, format, dirstats
failed to put checkpoint
error_code error object-storage, checkpoint, network, write
handler not set
exception error nil-argument, go, vfs
invalid value for delayed slices
exception error metadata, corruption, kv-store, gc
failed to get the last three bytes: expect "llo", but got
exception error object-storage, range-read, benchmark
get
exception error object-storage, get, network, s3, download
list all blocks
exception error go, object-storage, s3, gc, listing
scan pending slices
exception error go, redis, gc, wrapped-error
currently, only one schema is supported in search_path
exception error go, postgres, configuration, schema
cannot decode encrypted private keys
exception error crypto, pem, pkcs8, key-parsing
create table setting, counter
exception error database, schema-migration, ddl, permissions
data checksum != expect
exception error disk-cache, checksum, corruption, chunk
failed to read footer: err
exception error protobuf, io, backup, corrupt-file, truncated-file
invalid hour number
validation error config, validation, cache
invalid type: %T
exception error type-mismatch, metadata, session, go
delete slice from chunk
error_code error redis, transaction, conflict, chunk, refcount
unexpected ETag: !=
exception error obs, huawei-cloud, etag, integrity
expect owner nobody but got
exception warning permissions, ownership, verification
failed to get absolute path of
exception error filesystem, path, environment
list chunk prefixes made no progress
console error
position is negative
exception error java, hadoop, pread, eof-exception, argument-validation
ldap_bind_sW failed
exception error windows, ldap, active-directory, authentication
inode slice
exception error go, vfs, error-wrapping, concurrency
parse url failed
exception error go, postgres, url-parsing, configuration
unusable ccache
exception error hdfs, kerberos, ccache, environment-variable
400 Bad Request
http error http, webdav, bad-request
clone failed
console error cli, fuse, metadata, errno
User can not be null
exception error
dest read
exception error sync, io, checksum, network
HGetAll
error_code error redis, network, locks
verify checksum failed
exception critical object-storage, checksum, data-corruption, crc32
not a JuiceFS mount point
exception error umount, mountpoint, cli
open database
error_code error foundationdb, connection, cluster-file
set API version
error_code error foundationdb, version-mismatch, metadata
ldap_initW failed
exception error windows, ldap, active-directory, network
stat
console error cli, filesystem, stat, path-resolution
create
exception error nfs, file-write, object-storage, io
failed to read footer
exception error backup-restore, protobuf, corruption
no quota for inode path
error_code error metadata, quota, resource-not-found
create object sorter
exception error gc, external-sort, filesystem, io
database is used by volume
exception error metadata, redis, backup-restore, conflict
failed to execute command
console error cli, debug, lsof, process
only root can restore files from trash
exception error root, permission, trash, cli, linux
failed to clean up sid
exception error session, cleanup, database, metadata
failed to get multipart upload file
console error object-storage, multipart-upload, read
secret was removed; please correct it with `config` command
exception error config, encryption, secret-removed
failed to load config
error_code error aws-sdk, config, credentials
list chunk prefix failed
exception error go, object-storage, nil-object, gc, driver-bug
marshal worker config
exception error sync, json, serialization, cluster
drop table userGroupQuota
exception error database, sql, metadata, quota
LdapConnect failed
exception error windows, ldap, active-directory, startup, network
the clone DST path should be at the same mount point as the…
console error cli, filesystem, mount-point, constraint
unrecognized error handling value
panic error java, jni, bridge, enum, panic
concurrent staging limit reached
error_code info cache, concurrency, backpressure
Invalid ACL: mask is required and cannot be deleted.
validation error acl, java, mask
invalid mode
validation error python, file-open, argument-validation
invalid uid for sid
validation error windows, sid, uid-mapping
remove dir stats
exception error go, redis, metadata, format-update
unexpected dragonfly max replicas
validation error configuration, url, dragonfly, validation
http status
exception warning sync, http, rate-limit, traffic-control
ldap_search_sW failed
exception error windows, ldap, active-directory, query
create %sor
exception error encryption, config, sync, juicefs, invalid-algorithm
unescape
exception error url, sync, juicefs, escaping
failed to get the last byte: expect "o", but got
exception error object-storage, range-read, benchmark, off-by-one
first key should be test, but got
console error object-storage, list, key-mismatch, filesystem
get err
exception error redis, dump, quota, hgetall
get current user
exception error hdfs, user-lookup, object-storage, container
invalid gc object record size
exception error gc, external-sort, corruption, deserialization
unable to use data source
exception critical go, database, connection, xorm, mysql, postgres, sqlite
write conflict: >
error_code warning concurrency, transaction, optimistic-locking, testing
arguments: " + off + " " + len
exception error java, hadoop, argument-validation, pread
deleting a non-existent object returns an error
console error object-storage, delete, idempotency, benchmark
invalid worker address
error_code error network, url, distributed-sync, config