ErrLookup › juicedata/juicefs

juicedata/juicefs

JuiceFS is a distributed POSIX file system built on top of Redis and S3. · Go · 280 source files

Analyzed at c9a67b23e8 on 2026-09-06. 688 documented errors.

Code / MessageTypeSeverityTags
failed to get object with the end out of range, expect "o"…
console warning object-storage, range-read, out-of-range, benchmark
load user/group quotas
error_code error metadata, quota, redis, sql, kv
new session
exception error metadata, session, redis, storage
object storage
exception critical object-storage, mount, configuration, s3
set worker environment
exception error environment, sync, worker, cli
can't locate source or destination in command arguments
error_code error sync, cluster, argv, config
failed to read segment value: err
exception error io, read-failed, truncated-data, short-read, backup
failed to parse listen port
console warning go, lsof, port-parsing, panic-recovery
Unable to skip bytes (position= , fileSize= )
exception warning java, io, eof, hadoop-filesystem
failed to get the first byte:, expect "h", but got
exception error object-storage, range-read, benchmark, s3
Invalid start or len parameter
exception error java, hadoop, argument-validation, block-locations
mkdir
exception error nfs, filesystem, mkdir, symlink, permissions
set total inodes
error_code error redis, metadata, write-failed, volume-stats
failed to write segment length
exception error io, write-failed, backup, protobuf
multipart upload error
console error object-storage, multipart-upload, benchmark
failed to read checkpoint
error_code error io, checkpoint, object-storage, resume
failed to marshal checkpoint
error_code error json, checkpoint, marshal, serialization
failed to chown object
exception error permissions, chown, filesystem
mtime of key should be within 30 seconds, but got
console error object-storage, objbench, clock-skew, metadata
cannot find command line for pid
console error windows, wmic, permission-denied, process-introspection
Mkdir
exception error filesystem, mkdir, metadata, mdtest
url parse
error_code error redis, url, config, parsing
writechunk
exception error metadata, write, slice-allocation, mdtest
failed to find command line for pid
console error windows, wmic, process-introspection
Problem loading configuration
exception error hdfs, configuration, object-storage, startup
failed to read segment type
exception error io, read-failed, eof, truncated-data, backup
(max tries) upload block
exception error object-storage, upload, retry-exhausted, network, s3
couldn't initialise SFTP
exception error sftp, ssh, network, configuration, subsystem
Initialize
exception error filesystem, initialization, metadata, storage
Did you forget to specify the `--storage
console warning cli, object-storage, missing-flag
update format
exception error go, redis, metadata, config
delete failed
console error object-storage, delete, benchmark, s3
writeend
exception error metadata, write, chunk, mdtest
parse private key
exception error crypto, rsa, pem, backup-restore
user/group quota is inconsistent, please repair it with…
error_code error quota, consistency, metadata, cli
create
exception error filesystem, create, metadata, mdtest
set tier for inode failed
exception error tier, metadata, cli, restore
SMembers
error_code error redis, network, session
Compression codec not found:
exception error hadoop, java, classpath, reflection
create table chunk, chunk_ref, delslices
exception error database, schema-migration, ddl, chunks
expect err is not nil
console error object-storage, head, delete-visibility, benchmark
LdapGetDefaultNamingContext failed
exception error windows, ldap, active-directory, startup
existing format is broken
error_code critical redis, metadata, json-unmarshal, corruption
ks3: CreateMultipartUpload returned empty UploadID for
exception error ks3, multipart-upload, s3, object-storage
DumpMeta error
exception error go, redis, dump, panic
HGet sessionInfos
error_code error redis, session, network, query-failed
only records inserted
exception error database, metadata, backup-restore, mysql, postgresql, sqlite
Invalid endpoint: , error
error_code error b2, object-storage, url-validation, config
Length mismatch: !=
exception error write-path, length-validation, api-misuse, state-mismatch
read fully: ( < ) after
exception critical short-read, corruption, decompression, object-storage, data-integrity
pprof will be collected, but no listen port
console error cli, debug, pprof, diagnostics
set tier for inode tier: failed
exception error tier, metadata, cli
create table session2, sustaind, delfile
exception error database, schema-migration, ddl, sessions
failed to parse pid
console error windows, wmic, parsing, strconv
please create bucket
exception error object-storage, bucket, s3-compatible
can not generate different endpoint using
error_code error config, endpoint, format-string
corrupted session info; json error
error_code error redis, metadata, json, session
json
error_code error redis, json-marshal, metadata, init
failed to parse value as int
exception error go, metadata, url-parsing, configuration
redis parse
error_code error redis, url, go-redis, config
write conflict: was version , now deleted
error_code warning concurrency, transaction, optimistic-locking, testing
delimiter list returned nested object
exception error go, object-storage, invariant-violation, delimiter-listing, gc
set quota usage for file
exception error go, metadata, quota, wrapped-error
%s
console info jni, native, logging
errno: (via error(); maps errno to…
exception error hadoop, jni, file-delete, errno
Cannot find WinFsp installation path from registry, please…
exception error windows, winfsp, registry, installation
delete src failed
exception error metadata, rename, race-condition, database
failed to unmarshal checkpoint
error_code error json, checkpoint, unmarshal, resume
apply object action failed in inode
exception error object-storage, tier, cli, cloud
create table edge
exception error database, schema-migration, ddl
error creating GET request
console error go, http, url-validation
invalid value for delSlices
error_code error redis, corruption, refcount, delayed-slices
load worker config
exception error sync, worker, cli, ipc
Failed to delete registry key
exception error windows, winfsp, registry, permissions
new HDFS client
exception error hdfs, network, connection, object-storage
tikv client txn func error
exception error tikv, panic, metadata, go
stream was closed
exception error java, hadoop, stream-closed, use-after-close
failed to read segment
exception error io, read-failed, eof, truncated-data, backup
ks3: UploadPartCopy returned no CopyPartResult for
exception error ks3, multipart-upload, copy, object-storage
ping database
exception critical database, startup, connectivity, metadata-engine
the content of the multipart upload file is incorrect
exception error object-storage, multipart-upload, verification
The directory item limit of " + controlDir + …
exception error java, hadoop, benchmark, limits
failed to complete multipart upload
console error object-storage, multipart-upload, benchmark
failed to marshal segment message
exception error protobuf, backup, marshal, serialization
no valid pprof port found
console error pprof, diagnostics, port-discovery
ibmcos: CreateMultipartUpload returned empty UploadId for
exception error ibmcos, multipart-upload, s3, object-storage
statistic
exception error cli, trash, object-storage, metadata
unusable kerberos principal
exception error hdfs, kerberos, principal, configuration
failed to set isolation level
exception critical mysql, database, isolation-level, compatibility, startup
unable to mount
exception error nfs, mount, object-storage
failed to load quotas
error_code error redis, quota, metadata
insert new session
exception error database, metadata, session, go
Could not get a FileSystem
exception error java, hadoop, filesystem, configuration
records not inserted: %+v
exception error database, insert, invariant, go
tierID: not found for
error_code error azure, blob-storage, tiering, config
Unable to get endpoint of container
error_code error azure, object-storage, endpoint-discovery, network
create table node, symlink, xattr
exception error database, schema-migration, ddl, inode
expected key 'test' but got
console error
Invalid ACL: the user, group and other entries are required.
validation error acl, java, validation
JuiceFS initialized failed for jfs://" + name
exception critical native-library, initialization, configuration