juicedata/juicefs
Documented errors, page 3 of 7. Back to juicedata/juicefs
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| produce meta records | exception | error | go, metadata, gc, external-sort, database |
| produce object records | exception | error | go, object-storage, s3, gc, external-sort |
| unknown cache eviction policy | exception | error | config, cache, validation |
| fail to initialize OBS | exception | error | obs, sdk-init, credentials, huawei-cloud |
| Hadoop version was incompatible, current hadoop version… | exception | error | hadoop, classpath, reflection |
| unexpected dragonfly mode | validation | error | configuration, url, dragonfly, validation |
| bucket name required | validation | error | configuration, url, dragonfly, bucket |
| already exists | console | error | cli, filesystem, clone, path |
| write | exception | error | java, io, jni, write-failed |
| create table acl | exception | error | database, schema-migration, ddl, acl |
| failed to stat | exception | error | cli, mount, fuse-options |
| merge sorted records | exception | error | go, gc, external-sort, disk-space, errgroup |
| open control file for | console | error | cli, fuse, control-file, mount-point |
| The PROPPATCH method is not currently enabled,please add… | http | error | http, webdav, feature-flag |
errUnstableCoLimit exceed concurrency limit for unstable disk cache | error_code | warning | disk-cache, concurrency, throttling, unstable-disk |
| failed to lookup inode for | console | warning | cli, filesystem, stat |
| lookup inode for | exception | error | filesystem, inode, cli, juicefs |
| remove user group quota | exception | error | go, redis, metadata, quota |
| [BUG] Could not build FS URI | exception | error | java, uri, internal-error |
| create table flock, plock, dirQuota, userGroupQuota | exception | error | database, schema-migration, ddl, quota, locks |
| new cipher | exception | error | crypto, encryption, aes, config |
| open control file for | exception | error | warmup, cache, control-file, cli |
| RangerPermissionChecker for volume: " + volName + " is… | exception | error | ranger, permission, lifecycle, state |
| Cannot overwrite uploaded block | exception | error | state, write, chunk |
| dump trash nodes | exception | error | go, dump, trash, sql, backup |
| failed to get volume config | console | error | cli, filesystem, permissions |
| insert/update failed | exception | error | database, locking, flock, concurrency, metadata |
| session not found | error_code | error | redis, session, not-found, cli |
| unable to create engine | exception | critical | mysql, database, connection-string, startup |
| create | exception | error | object-storage, sync, juicefs, backend-init |
| delete not existed | console | error | object-storage, delete, idempotency, benchmark |
| Init libjfs failed | exception | critical | native-library, file-io, jvm |
| Invalid ACL: this entry type must not have a name: " +… | validation | error | acl, validation, hadoop, permissions |
| unexpected | exception | error | json, metadata-dump, parsing |
| New quota is too small (used / quota) | console | warning | cli, quota, config |
| quota of is inconsistent, please repair it with --repair… | error_code | error | metadata, quota, consistency |
| error loading certificate and key file | console | error | tls, certificates, object-storage |
| found key with same prefix | exception | error | redis, load, restore, cluster |
| generate kerberos AP-REQ failed | exception | error | |
| inode is not a directory | exception | error | metadata, inode, not-a-directory, filesystem |
| list chunks from | exception | error | go, object-storage, s3, gc, prefix-listing |
| Compress block key | exception | error | compression, upload, data-corruption |
| juicefs mount command exit with error, please check the log… | exception | error | windows, winfsp, mount |
| load key | exception | error | encryption, rsa, sync, juicefs, key-format |
| invalid HSCAN response for | error_code | error | redis, hscan, protocol, unexpected-response |
| resolve path | error_code | error | filesystem, path-resolution, distributed-sync |
| get dirUsedInodesKey err | exception | error | redis, dump, dirstat, hgetall |
| The entry of the root inode was not found | error_code | critical | metadata, backup-restore, tikv, corruption |
| failed command %+v | exception | error | redis, pipeline, metadata-load, wrongtype |
| failed to read staging directory | exception | error | umount, writeback, staging, cache, filesystem |
| space not enough on device | error_code | warning | disk, cache, space |
| Failed to create bucket | exception | error | object-storage, s3, network |
| getattr inode | exception | error | metadata, filesystem, inode |
| Invalid parameter | exception | error | native-library, permissions, ranger |
| Cannot create file system. | exception | error | java, hadoop, benchmark, filesystem |
| get inode of | console | error | cli, filesystem, inode, permissions |
| write message | console | error | cli, fuse, control-file, io |
| failed to open file | exception | error | filesystem, file-open, backup-restore |
| Failed to set RunAs value | exception | error | windows, winfsp, registry, permissions |
| is not directory | exception | error | s3-gateway, mkdir, path-conflict |
| decrypt format | exception | error | encryption, format, config, decrypt |
| error appending CA cert to pool | console | error | tls, certificates, object-storage |
| failed to get two bytes: expect "ll", but got | exception | error | object-storage, range-read, benchmark |
| invalid cgroup entry | exception | error | linux, cgroups, fuse, mount |
| OS is not supported | exception | error | platform, umount, cli, unsupported |
| bucket does not exist | exception | error | obs, bucket, not-found, huawei-cloud |
| buffer too short: < | exception | error | compression, buffer-size, noop |
| Clients below version | console | warning | cli, versioning, compatibility |
| failed to unmarshal segment msg | exception | error | protobuf, backup, corruption |
| Failed to update WinFsp service registry | exception | error | windows, winfsp, registry, service |
| Cannot mount to a local directory when --as-local-volume is… | validation | error | windows, winfsp, mount, cli |
| invalid key , fail to parse slice id | error_code | error | redis, key-format, slice-id, delayed-slices |
| invalid quota type | error_code | error | redis, quota, invalid-argument |
| delete user group quota | exception | error | go, kv, format, quota, transaction |
| read cgroup file | exception | error | fuse, cgroup, container, linux, procfs |
| cannot disable dir stats when there are still | console | error | cli, quota, config |
| chunk pipeline exec err | exception | error | redis, pipeline, metadata-dump, network |
| --days should be at least 1 | validation | error | cli, validation, tier, argument |
| error GET request, status code | console | error | go, http, http-status, pprof |
| invalid key , fail to parse size | exception | warning | go, redis, gc, key-format |
| listen | error_code | error | network, tcp, listen, port-conflict |
| create table detachedNode | exception | error | database, schema-migration, ddl |
| failed to run command line | console | error | windows, process, exec |
| get proxy url for endpoint | exception | error | proxy, env, obs, network |
| Invalid default ACL: the user, group and other entries are… | validation | error | acl, java, validation, default-acl |
| open | exception | error | fuse, cgroup, container, linux, procfs |
| capture read position | error_code | error | storj, upload, io |
| panic in point get transaction | exception | error | go, tikv, panic, point-get, recovery |
| Cannot get file system. | exception | error | java, hadoop, benchmark, filesystem |
| check version | exception | error | version-compatibility, metadata |
| create external sorter | exception | error | gc, disk, sort |
| fail to auto-detect endpoint | error_code | error | azure, network, endpoint, storage |
| failed to begin transaction | exception | critical | go, tikv, transaction, network, pd |
| set quota | error_code | error | metadata, quota, repair, backend |
| abs of | console | error | cli, filesystem, path |
| first key should be empty string, but got | console | error | object-storage, list, filesystem, directory-entry |
| invalid endpoint | exception | error | object-storage, url, configuration |
| unsupported type: %T | exception | warning | go, generics, internal-error, metadata |
| Cannot serialise open write-mode local file | exception | error | python, valueerror, pickle, localfile, serialization |
| failed to mount SMB share | exception | error | object-storage, smb, cifs, mount |