juicedata/juicefs
Documented errors, page 5 of 7. Back to juicedata/juicefs
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| dest get | exception | error | sync, object-storage, checksum, network |
| list encode file failed | console | error | object-storage, list, encoding |
| expect group but got | exception | warning | permissions, group, verification |
| new sm4 cipher | exception | error | encryption, sm4, cipher, config |
| cannot update volume | exception | error | format, config, update, immutable-field |
| failed to find message | exception | error | protobuf, backup, registry, metadata |
| invalid key | error_code | error | redis, key-format, cleanup, delayed-slices |
| readdir | exception | error | nfs, readdir, object-storage, list |
| user( ):group( ) not found | exception | error | chown, user-lookup, permissions, juicefs |
| only acls inserted, expected | exception | error | |
| cannot find the mount process for | console | error | windows, process-lookup, mount |
| database is not empty | exception | error | |
| got | exception | warning | network, http, telemetry |
| invalid key , fail to parse timestamp | error_code | error | redis, key-format, timestamp, delayed-slices |
| part | exception | error | multipart-upload, object-storage, retry |
| 2. ALL entries in the metadata engine | console | warning | cli, destructive, metadata |
| failed to get mount command | console | error | cli, process, mount |
| failed to parse config | exception | error | umount, json, config, unmarshal |
| found invalid key from List, prefix: , marker | error_code | error | tos, listing, object-storage, invariant-violation |
| get dirDataLengthKey err | exception | error | redis, dump, dirstat, hgetall |
| list encode file failed: expect key | console | error | object-storage, encoding, key-mangling |
| write to | exception | error | linux, cgroups, permissions, fuse |
| get delslices | exception | error | database, gc, sql |
| get prefix with count only | panic | error | etcd, exists, network, juicefs |
| read worker config | exception | error | sync, cluster, io, stdin |
| scan global user group usage | error_code | error | metadata, quota, scan, backend |
| checksums of copied object | exception | error | sync, checksum, data-integrity |
| create request | exception | error | |
| prefix must be nil, but got | error_code | error | api-misuse, prefix, testing |
| read wrong data: expected | exception | critical | object-storage, data-corruption, s3 |
| src get | exception | error | object-storage, network, read |
| aborted | exception | info | sync, cancellation, checksum |
| decryt key | error_code | critical | encryption, aes, rsa, decryption, data-loss |
ErrNotSUP not supported | error_code | info | object-storage, unsupported-operation, benchmark |
| get dirUsedSpaceKey err | exception | error | redis, dump, dirstat, hgetall |
| Database redis:// is not empty | exception | error | redis, load, restore, non-empty-database |
| error reading response | console | error | |
| invalid storage | exception | error | object-storage, configuration, unsupported-backend |
| bucket doesn't exist | exception | error | cos, tencent, endpoint, bucket |
| build tls config from | error_code | error | etcd, tls, certificates, config, juicefs |
| Decrypt: truncated chunk header | exception | error | crypto, decrypt, truncated-data, object-storage |
| fail to find device cgroup | exception | error | linux, cgroups, fuse, cgroup-v2 |
| File already exists: " + f | exception | error | java, hadoop, file-already-exists |
| create B2 client | error_code | error | b2, authentication, credentials, object-storage |
| create table blob | error_code | error | sql, database, ddl, permissions |
| find sustained | exception | error | database, query, session, metadata |
| invalid key | error_code | error | metadata, kv-store, scan, corruption |
| Path already exists: " + f | exception | error | java, hadoop, file-already-exists |
| Failed to get | exception | error | object-storage, s3, read |
| put encode file failed | console | error | object-storage, encoding, utf-8, key-encoding |
| stat fs | exception | error | cli, metadata, statfs, redis, mysql |
| Auth | error_code | error | swift, openstack, authentication, object-storage |
| no attribute values | exception | warning | windows, ldap, active-directory, missing-attribute |
| unknown message type | exception | error | metadata, backup, protobuf, corruption |
| fuse | exception | error | fuse, mount, fuse-server |
| missing URL | validation | error | metrics, configuration, java-sdk |
| read | exception | error | |
| the clone DST path should not be under the SRC path | console | error | cli, filesystem, path-resolution, constraint |
| cannot get location of bucket | exception | error | obs, bucket, region, auto-discovery |
| invalid dumped meta: missing 'Counters' | validation | critical | metadata, validation, dump |
| open | error_code | error | sql, xorm, driver, config |
| update table flock, plock | exception | error | database, sql, schema-upgrade, locks |
| delete delayed slice | exception | error | |
| Invalid ACL: multiple entries with same scope, type and… | validation | error | acl, validation, hadoop, permissions |
| wrong ranger config | exception | error | ranger, configuration, format |
| CIFS username/ak is required | validation | error | cifs, smb, authentication, credentials |
| Failed to create bucket | exception | error | object-storage, s3, bucket |
| failed to get startTS, which is required for TiKV to ensure… | error_code | error | tikv, backup, consistency, metadata |
| failed to handle objects | exception | error | |
| failed to load quotas | error_code | error | quota, scan, kv-store, network |
| get session ID | exception | error | database, sql, session, counter, duplicate-key |
| get start | error_code | warning | etcd, scan, pagination, background, juicefs |
| the result for list is incorrect | console | error | object-storage, list, ordering |
| worker config is too large | exception | error | sync, cluster, payload-limit, stdin |
| encrypt format | exception | error | encryption, format, config, encrypt |
| object was removed during sync | exception | warning | sync, race, source-deleted |
| one of srcs is missing | exception | error | java, hadoop, file-not-found |
| storj: bucket name is required (set via --bucket) | validation | error | |
| error loading CA cert file | console | error | tls, ca-cert, file-read, object-storage |
| Invalid endpoint | validation | error | object-storage, baidu-bos, endpoint-format, configuration |
| renew token failed | exception | error | hadoop, kerberos, token, filesystem |
| root required | error_code | error | |
| scan slice | exception | error | gc, object-storage, sql |
| wrong type | exception | error | java, cli, benchmark, argument-parsing |
| failed to read password file | error_code | error | file, password, credentials |
| readdir inode | exception | error | metadata, readdir, inode, filesystem |
| cannot lower min-client-version from | validation | error | cli, version, compatibility |
| ensure bucket | error_code | error | storj, bucket, network |
| extract samples | exception | error | |
| Invalid ACL: only directories may have a default ACL | exception | error | |
| invalid stage footer length | exception | error | |
| invalid whence ( , should be , or ) | validation | error | python, valueerror, seek, whence |
| POST required | http | error | http, sync, method-not-allowed |
| can't find path for | error_code | error | filesystem, path, distributed-sync, env |
| invalid redisVersion | exception | error | redis, version-check, parsing |
| Unable to get endpoint of bucket | exception | error | cos, tencent, endpoint, api |
| a bytes-like object is required, not | validation | error | python, typeerror, bytes, binary-write |
| binary mode doesn't take an encoding argument | validation | error | python, file-open, argument-validation |
| CIFS password/sk is required | validation | error | cifs, smb, authentication, credentials |
| error checking pprof alive | console | error |