juicedata/juicefs
Documented errors, page 6 of 7. Back to juicedata/juicefs
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| find plock | exception | error | database, query, plock, session |
| can't have text and binary mode at once | validation | error | python, file-open, mutually-exclusive |
| cannot disable acl | console | error | |
| creating a bucket that already exists returns an error | exception | error | |
| read stage footer header | exception | error | |
| received encrypted text length is less than 3, the object… | exception | error | crypto, data-corruption, decrypt, object-storage |
| create session | exception | error | session, metadata, startup |
| invalid sustainedKey | error_code | error | sessions, kv-store, dump, corruption |
| open lock file | exception | error | |
| unescape access key | exception | error | object-storage, url-encoding, credentials |
| Can't connect to cluster | exception | error | object-storage, ceph, rados, network |
| Can't create connection to cluster | exception | error | object-storage, ceph, rados, connection |
| Database :// is not empty | error_code | error | load, metadata, non-empty, kv-store |
| get chunk result err | exception | error | redis, pipeline, chunk, metadata-dump |
| list failed | console | error | object-storage, objbench, list, wrapper |
| list quotas | exception | error | |
| changed during sync. Original: size= , mtime= ; Current… | exception | warning | sync, consistency, source-changed |
| unexpected number of fields | validation | error | |
| invalid file size , data length , checksum length | exception | error | |
| mtime deviation is too large, the actual mtime is | exception | warning | object-storage, mtime, clock-skew, benchmark |
| no volume provided | exception | error | |
| not implemented, use kvMeta.LoadMetaV2 instead | error_code | error | metadata, backup-restore, kv, unsupported |
| Permission denied: user=" + user + ", access=" + action +… | exception | warning | permission, ranger, acl, hadoop |
| read lock file | exception | error | |
| : please set the 'JFS_RSA_PASSPHRASE' environment variable | exception | error | encryption, environment, config |
| Invalid version string | validation | error | cli, validation, version |
| malformed ciphertext | exception | error | crypto, data-corruption, decrypt, malformed-data |
| timeout after | exception | error | timeout, goroutine |
| Aborted | error_code | error | |
| failed to get object with the offset out of range, expect… | console | error | |
| max inode | exception | error | go, dump, sql, database-query |
| entry / not found | exception | error | metadata, inode, dentry, orphan |
| random, backward, skip are mutually exclusive | exception | error | java, cli, benchmark, argument-parsing |
| RangerPermissionChecker for volume: " + volName + " is… | exception | error | ranger, permission, lifecycle, state |
| SMB authentication failed | exception | error | object-storage, smb, cifs, authentication |
| create bucket | error_code | error | b2, object-storage, bucket-creation, permissions |
| failed to chtimes | exception | error | object-storage, mtime, chtimes, benchmark |
| page is already released | error_code | error | memory, lifecycle, page |
| put object failed | exception | error | |
| ${errMsg} | http | error | ufile, api-error, listing |
| Failed to create Azure credential (managed identity/Azure… | error_code | error | azure, authentication, managed-identity, credentials |
| passphrase is required to private key | error_code | error | encryption, rsa, passphrase, env-var |
| storj: access grant is required (pass via --access-key) | validation | error | |
| UploadPart | http | error | ufile, multipart-upload, http, object-storage |
| database is not formatted, please run `juicefs format ...`… | exception | error | metadata, formatting, config |
| invalid changelog entry | exception | error | changelog, parsing, corruption |
| Parent directory of mount point does not exist | validation | error | windows, winfsp, mount, filesystem |
| path is not a mount point | console | error | cli, filesystem, mount-point |
| Can only commit if not already set to autocommit | exception | error | python, runtimeerror, autocommit, commit, localfile |
| failed to create current out dir | console | error | cli, filesystem, mkdir |
| list with delimiter | exception | error | |
| No ETag | error_code | error | ufile, multipart-upload, http-response |
| No matching attributes found for remove operation | exception | error | |
| range( , ) | exception | error | multipart-upload, permission, destination |
| failed to marshal segment | exception | error | backup, protobuf, dump, serialization |
| failed to read footer length: err | exception | error | backup, io, read, truncated-file |
| not supported | error_code | error | cache, unsupported-operation, memory |
| 1. ALL objects in the data storage | console | warning | cli, destructive, object-storage |
| Aborted. | console | warning | cli, confirmation, quota |
| decode key | exception | error | base64, decoding, config, encryption |
| invalid guid-mask : expected an unsigned 32-bit integer | exception | error | |
| not exists | error_code | error | object-storage, not-found, in-memory |
| readlink from | exception | error | |
| File exists | exception | error | python, fileexistserror, makedirs, idempotency |
| scan trash files | exception | error | metadata, trash, scan |
errDirSuffix dir miss suffix '/' | error_code | error | sync, validation, directory |
| invalid endpoint | validation | error | object-storage, eos, url-parsing, config |
| parse | error_code | error | etcd, url, config, juicefs |
| get not existed object should failed | exception | error | |
| No kerberos credential was found! Parameter "--keytab" and… | validation | error | kerberos, authentication, cli, ranger |
| resolve dir | error_code | error | quota, directory, path |
| The target volume will be permanently destroyed, including: | console | warning | cli, destructive, data-loss |
| convert metrics | exception | error | |
| delimiter should be a rune but now is | validation | error | |
| status: , message | http | error | ufile, http, object-storage, api-error |
| failed to get log path | console | error | |
| invalid NFS address | exception | error | nfs, url-format, configuration |
| invalid value for delayed slices | exception | error | |
| Mount point cannot be an existing folder | validation | error | windows, winfsp, mount, filesystem |
| closed | error_code | warning | sync, io, reader-lifecycle |
| copied size mismatch: original= , current= | exception | critical | sync, data-integrity, size-mismatch |
| database redis:// is not empty | exception | error | redis, load, non-empty-database, safety-check |
| Failed to start juicefs service by 'net use | exception | error | |
| failed to write footer data: err | exception | error | backup, io, write, short-write |
| Decrypt | exception | error | crypto, decrypt, object-storage, key-mismatch |
| invalid magic number | exception | error | backup, validation, magic-number, format |
| must have exactly one of create/read/write/append mode | validation | error | python, file-open, argument-validation |
| no quota for any trash directory | error_code | error | quota, trash, meta |
| remote_write failed | exception | error | |
| dump trash failed | exception | error | |
ErrFuncTimeout function timeout | error_code | error | timeout, cache, chunk |
| fail 3 times in , give up | exception | error | |
| Failed to create Azure blob client with SAS token | error_code | error | azure, object-storage, sas-token, url-validation |
| Fetch all metadata from DB | exception | error | |
| GOOGLE_CLOUD_PROJECT environment variable must be set | error_code | error | gcs, object-storage, env-var, gcp |
| no bucket name provided in | exception | error | object-storage, minio, missing-argument |
| read trash | exception | error | metadata, trash, readdir |
| Invalid ACL: ACL has " + defaultEntries.size() + " default… | validation | error | acl, java, limit-exceeded, default-acl |
| list sessions | exception | error | cli, metadata, sessions, redis, mysql |
| object size is too large to copy | exception | error | sync, object-storage, size-limit |