hashicorp/nomad
Documented errors, page 9 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| task not found in allocation | validation | error | nomad, client, tasks, not-found |
| unable to create executor config | exception | error | json, serialization, executor-plugin |
| unable to read usable cores | error_code | error | docker, cgroups, cpuset, linux |
| Constraint validation failed: using unsupported operand | validation | error | nomad, constraint, validation, jobspec |
| CSI.ControllerDeleteSnapshot | exception | warning | csi, snapshot, plugin, retry |
| error creating volume | error_code | error | host-volumes, external-plugin, process-execution |
| Error parsing max kill timeout | validation | error | config, nomad, duration-parsing |
| failed to set subtree control on nomad cgroup | error_code | error | linux, cgroups, cgroupv2, filesystem-permissions |
| failed to write vault token to secrets dir | exception | error | nomad, vault, filesystem, permissions |
| handle cannot be nil | exception | error | nomad, java-driver, recover-task, nil-check |
| invalid name . Must match regex | validation | error | nomad, validation, namespace |
| Unable to tar files | exception | error | filesystem, archive, debug-bundle |
| validating volume update failed | validation | error | nomad, host-volumes, update-validation, immutable-field |
| : ; see… | exception | error | nomad, consul, envoy, exec, retry |
| all servers should be running version | validation | error | nomad, host-volumes, version-skew, rpc |
| artifact destination path escapes alloc directory | exception | error | artifacts, path-traversal, sandbox |
| Claim.AllocationID is required | validation | error | csi, validation, nomad, storage |
| failed to launch docker logger plugin | exception | error | docker, go-plugin, plugin-launch, nomad-driver |
| Failed to start workers | exception | error | nomad, go, workers, scheduler, startup |
| host path must be set in configuration for devices | validation | error | go, docker, nomad, config-validation, devices |
| invalid name , must match regex | validation | error | nomad, consul, config-validation, naming |
| Missing HealthCheck | validation | error | nomad, go, validation, migrate-strategy, deployment |
| only one name may be specified | validation | error | nomad, hcl, quota, device |
| requested access mode | validation | error | csi, access-mode, validation, volume-capability |
| requested filesystem type | validation | error | csi, filesystem, validation, mount |
| Total length of the prefix message is out of range | exception | error | logging, testing, buffer-overflow |
| Unable to parse address template | validation | error | config, template, network |
| ACL role not found | error_code | error | nomad, acl, state-store, delete-not-found |
| ACL token not found or invalid workload identity | http | error | acl, authentication, token, nomad |
| CSI.ControllerDetachVolume | exception | error | csi, grpc, unpublish-volume, detach |
| failed to close WAL store | exception | error | raft-wal, close-failed, fsync, io |
| failed to create FSM | exception | error | fsm, snapshot, initialization |
| Failed to pull | exception | error | docker, image-pull, registry, recoverable |
| Invalid change mode. Must be one of the following: noop… | validation | error | nomad, template, validation, enum |
| Invalid task directory given | validation | error | config, validation, nomad-client, template |
| Lock delay and TTL must be positive | validation | error | nomad, variables, lock, validation, configuration |
| setting job status failed | exception | error | nomad, state-store, evals, job-status |
| task.consul.partition | validation | error | nomad, consul, partitions, job-validation |
| Check invalid | validation | error | nomad, consul, service-check, validation |
| client_service_name must be set when auto_advertise is… | validation | error | config, nomad, consul |
ErrAllocBroadcasterClosed alloc broadcaster closed | error_code | warning | go, concurrency, client-structs |
| failed to create nomad cgroup | error_code | critical | cgroups, linux, client-startup, permissions |
| missing volume claim | validation | error | nomad, csi, validation, request, claim |
| PluginInfo info failed for internal plugin | exception | error | go, plugin-loader, nomad, fingerprinting |
| setting config for plugin | exception | error | plugin-loader, config-validation, rpc, nomad |
| updating alloc failed | exception | error | nomad, state-store, alloc-update |
| users must not be nil | validation | error | nomad, agent-config, validation |
| ; certificate-derived key header must be one of | validation | error | nomad, acl, oidc, jwt, fips, validation |
| ACL auth method not found | error_code | error | nomad, acl, sso, delete-not-found |
| empty variables are invalid | validation | error | nomad, variables, validation, empty-payload |
| executor shutdown error | exception | warning | process-management, signals, shutdown |
| failed to build client_assertion jwt | exception | error | jwt, oidc, client-assertion, nomad |
| failed to configure networking for alloc | error_code | error | nomad, network, cni, configuration |
| failed to get docker client | exception | critical | docker, connection, driver-setup |
| failed to parse 'image_pull_timeout' duration | validation | error | config, docker, duration-parsing |
| invalid destination path | validation | error | nomad, validation, path-traversal, dispatch |
| Malformed constraint | validation | error | semver, parsing, validation, constraints |
| Malformed hard ulimit | validation | error | docker-driver, ulimit, config-parsing |
| opening seccomp profile | validation | error | docker, security, seccomp, filesystem |
| running as gid is disallowed | validation | error | security, gid, policy, validation |
| unable to pull infra docker image | exception | error | docker, config, image-reference |
| unknown alloc | validation | error | nomad, state-store, allocation, raft |
| ACL policy lookup failed | exception | error | nomad, acl, state-store, memdb |
| 'block-device' access type was not requested but was… | validation | error | csi, block-device, validation, access-type |
| cannot create copy | exception | error | go, windows, filesystem, permissions |
| <combined HCL diagnostics from str.String()> | validation | error | hcl, parsing, nomad, jobspec, validation |
| could not resolve node secret | exception | error | nomad, authentication, state-store, rpc |
| deploy_query_rate_limit must be greater than 0 | validation | error | config, validation, rate-limit, nomad |
| Error querying CSI volumes | console | error | nomad-api, csi, acl, network |
| Error querying job | exception | error | nomad-cli, job-lookup, api-error, acl |
| Error querying job summary | exception | error | nomad, cli, api-client, job-summary |
| error reading plugin response when deleting volume | error_code | error | host-volumes, external-plugin, process-execution |
| Failed to initialize the Vault client config for | exception | error | vault, configuration, client |
| failed to write string to eventstream.json; chars written | exception | error | filesystem, io, durability |
| fuzzy search query must be at least | validation | error | nomad, go, validation, input-length |
| missing task names | validation | error | nomad, client, validation, tasks |
| plugin missing controller | exception | error | nomad, csi, plugin, state-consistency |
| unable to move to - alloc dir is not built | exception | error | filesystem, lifecycle, allocation-migration |
| unknown volume attachment mode | exception | error | csi, validation, volume, configuration |
| alloc dir must be absolute | validation | error | filesystem, path-validation, config |
| could not create Windows job object for executor | exception | error | windows, job-object, process-management, kernel |
| could not load key file | console | critical | keyring, keystore, file-io, go |
| failed to create socket mount point | exception | error | filesystem, csi, permissions |
| failed to encode bootstrap environment | exception | error | go, json, encoding, nomad, envoy |
| failed to launch plugin | exception | critical | plugin-loader, plugin-launch, process-spawn, nomad |
| failed to parse max job source bytes | validation | error | nomad, config-validation, byte-parsing, humanize |
| host volume validation error | validation | error | nomad, volumes, config, host-volume |
| hostname is not currently supported on driver | validation | error | nomad, hostname, bridge-network, docker |
| requested docker runtime | validation | error | docker, gpu, nvidia, runtime |
| Semver constraint is invalid | validation | error | nomad, constraint, semver, job-validation |
| (rsa key) | console | error | encryption, kms, rsa, jwt-signing |
| certificate has expired or is not yet valid | exception | error | oidc, x509, certificate-expired, tls |
| Check invalid: check requires a port but neither check nor… | validation | error | nomad, service-check, validation, port |
| Connect proxy service name | validation | error | nomad, consul-connect, service-mesh, validation |
| error storing OIDC request | exception | error | oidc, cache, storage, network |
| expand is not implemented by this controller plugin | exception | error | nomad, csi, storage, volume-expansion |
| failed adding job | exception | error | periodic-jobs, cron, scheduling |
| failed parsing cron expression | exception | error | cron, validation, periodic-jobs |
| failed to login with JWT | exception | error | vault, jwt, authentication, nomad |
| failed to lookup node ID | exception | error | nomad, scheduler, state-store |