hashicorp/nomad

Documented errors, page 11 of 29. Back to hashicorp/nomad

Code / MessageTypeSeverityTags
no attribute provided but is required by operator
validation error nomad, constraint, validation
OOM Killed
exception error docker, oom, memory-limit, container
periodic launch lookup failed
exception error nomad, state-store, periodic-job, lookup-failed
scheduler resulted in an unexpected number of plans
exception error nomad, scheduler, plan
unable to configure cgroups
exception error cgroups, resource-isolation, linux, nomad-executor
an address or id is required for the destination peer
validation error cli, raft, validation, nomad
bug: users pool cannot be nil
panic error panic, configuration, nil-pointer
cannot open cpuset
panic error cgroups, linux, panic, programming-error
check is missing a port
validation error nomad, health-check, port, service-validation
could not query host volume
exception error nomad, host-volumes, state-store, internal-error
CSI.ControllerDeleteVolume
exception error csi, nomad, grpc, volume-delete
CSI.ControllerListSnapshots
exception error csi, grpc, snapshot, timeout, pagination
Disconnect cannot be configured with both lost_after and…
validation error nomad, job-spec, validation, disconnect
either RequiredBytes or LimitBytes must be set
validation error csi, validation, capacity
error opening reader at
error_code error go, filesystem, fifo, file-not-found
error unknown signal given for shutdown
validation error signals, configuration, shutdown, executor
failed to get job
exception error nomad, scheduler, sysbatch, state-store
failed to read intro token file
exception error filesystem, nomad, permissions
failed to restore from snapshot
exception error snapshot, fsm, restore, version-compatibility
invalid capacity
console error hcl, nomad, validation, bytes
maximum count must be specified and non-negative
validation error nomad, scaling-policy, validation
plugin does not support listing snapshots
validation error csi, storage, snapshots, nomad, capability-check
rotated key does not exist in keyring
exception error keyring, encryption, state-consistency
task.Resources is empty
error_code error docker, nomad, task-config
Unable to convert Uid to an int
exception error users, parsing, linux, nomad
unable to look up summary for job
exception error nomad, state-store, job-list
unknown algorithm
validation error nomad, keyring, algorithm, configuration
unknown checks namespace
console error testing, consul, mock, namespace
check cannot use a numeric port without setting…
validation error nomad, health-check, port, address-mode
CSI plugin failed to register
exception error nomad, csi, plugin-registration, grpc, restart-loop
does not match registry specification
exception error nomad, docker, image-reference, validation
Error loading
validation error config, consul, hcl, file-loading
Error querying job prefix
exception error nomad-cli, prefix-lookup, api-error, compatibility
Error querying node
exception error cli, nomad, node, api-error, network
failed to create network for alloc
error_code error nomad, network, cni, bridge
failed to retrieve checks from consul
console error consul, service-discovery, network
Filter expression cannot be used with other filter…
error_code warning nomad, filtering, request-validation, http
index update failed
exception critical nomad, state-store, index, volume-claims
invalid KeyIDHeader
validation error nomad, oidc, jwt, client-assertion
Multiregion jobs are unlicensed.
validation error nomad, licensing, enterprise, multiregion
No client configuration found for Vault cluster
exception error vault, nomad-client, configuration, tokens
no such plugin
validation error nomad, csi, plugin-registration
must be integer; got (%T) %[2]v
console error hcl, nomad, type-mismatch, validation
WAL directory already exists at
exception error filesystem, preflight, migration, idempotency
cannot give both an address and id
validation error cli, raft, argument-validation, nomad
Consul Connect transparent proxy port
validation error consul-connect, transparent-proxy, port-label, nomad-job-spec, validation
CSI.ControllerListVolumes
exception error csi, nomad, grpc, list-volumes
Emitting node events failed
exception error nomad-client, rpc, node-events
error interpreting desired Envoy version from Consul
exception error nomad, consul, envoy, semver, interpolation
error looking up job version by tag
exception error nomad, state-store, job-versioning, internal-error
eval broker disabled
exception warning go, nomad, scheduler, broker, lifecycle
Failed to create docker client
exception critical docker, client-init, tls, endpoint
nil config passed
validation error go, configuration, nil-pointer, validation
restoring mounts
error_code error csi, storage, nomad, volumes
selector is invalid
validation error nomad, acl, binding-rule, selector, bexpr, validation
Service [ ]-> or Check must specify task parameter
validation error nomad, job-validation, script-check
Task group volume claim lookup failed
exception error nomad, state-store, volume-claims, read
Unable to determine format of
console error cli, nomad, flags, file-extension
Unknown periodic specification type
validation error nomad, validation, job-spec, enum
used task driver is not allowed in namespace
validation error nomad, namespace, driver-policy, job-validation
Affinity validation failed
validation error nomad, affinity, validation, jobspec
failed to create exec object
exception error docker, exec, dockerd
Failed to mount task dir
exception error filesystem, mount, nomad-client
image_path must be set
validation error qemu, nomad, missing-config, image-path
invalid key/value pair
validation error cli, argument-parsing, key-value
Invalid variable capability
validation error nomad, acl, variables, capabilities
must specify at least one namespace to delete
validation error nomad, api-validation, namespace-delete
root key algorithm cannot be changed after a key is created
validation error nomad, keyring, immutability, root-key
rpc_max_conns_per_client must be >
validation error config, validation, limits, nomad
plugin ' ' did not become ready
exception error csi, nomad, plugin-manager, timeout, storage
unexpected bucket missing
error_code critical bolt, upgrade, corruption, state-store
Vault cluster is disabled or not configured
exception error vault, nomad-client, configuration
volume topology request update was not compatible with…
validation error csi, nomad, volume, topology, immutable-field
command is required but was empty
validation error docker, exec, validation
could not delete volume
validation error nomad, state-store, host-volume, in-use-resource
error decoding stats data: no reader body
exception error nomad, docker, stats, http-response
Failed to lookup user
exception error users, mount, unveil, nomad
Failed to query for root keys
exception error raft, snapshot, keyring, go
failed to read device manager plugin state
exception error bolt, state-store, deserialization, nomad
failed to upgrade state database
exception critical client-init, state-database, schema-migration
failed to write to file
exception error io, json, debug-bundle
invalid or missing issuer parameter in callback
validation error oidc, issuer, callback, csrf-mixup
missing TargetPath
validation error csi, storage, mount, validation
Specified config is missing from options
validation error config, options, go, missing-key
token expiration TTL
validation error acl, token, validation, ttl
unable to find eval id
exception error nomad, eval, plan-apply, missing-entity
acquire conflict
exception warning locking, concurrency, conflict
Check invalid: tcp checks are not valid for Connect enabled…
validation error nomad, consul-connect, service-check, validation
Couldn't change owner/group of
exception error filesystem, permissions, chown, linux, nomad
ErrInvalidKeyIDHeader
; must be one of: "x5t", "x5t#S256
exception error oidc, jwt, validation, config
failed to create namespace
exception error linux, network-namespace, privileges
failed to determine last evaluation index for job
console error nomad, deployment-watcher, internal, state-store
failed to encrypt rsa key
exception error kms, rsa, encryption
failed to generate auth URL
exception error nomad, acl, oidc, sso, redirect-uri
failed to parse 'creation_grace' duration
validation error docker, duration, config, nomad
failed to process eval
exception error nomad, scheduler, panic, sysbatch
failed to stat intro token file
exception error filesystem, nomad, permissions
invalid hosts entry
validation error docker, networking, etc-hosts, config-validation
Missing job type
validation error nomad, go, validation, job-spec
missing path
validation error nomad, variables, validation