hashicorp/nomad
Documented errors, page 13 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to parse cert bytes | exception | critical | tls, x509, certificate, nomad |
| missing auth method name | validation | error | nomad, acl, oidc, validation |
| [✘] Role could not be interpolated with args | exception | error | go, json, vault, serialization |
| version not found | validation | error | nomad, job-versioning, version-not-found |
| volume name cannot be a reserved word for Windows filenames | validation | error | docker, volumes, windows, naming |
| cannot compute bind name for bind target | exception | error | auth, acl-binding-rule, template-interpolation |
| cannot open current nomad path for install | exception | error | windows, file, permissions |
| csi updates already batched | exception | warning | nomad-client, csi, fingerprinting, one-shot |
| failed to parse CA file | exception | critical | tls, x509, file-parsing, nomad |
| failed to parse follow field to boolean | http | error | http-api, query-params, parsing, boolean, nomad |
| Invalid plugin policy: %#v | validation | error | acl, policy-validation, hcl, consul |
| missing PemCert, PemCertFile, or KeyID | validation | error | nomad, oidc, client-assertion, config-validation |
| no ACL token returned | exception | error | consul, acl, empty-response, one-time-token |
| node not found | http | error | nomad, api, node, http-endpoint |
| root key metadata is required | validation | error | nomad, keyring, root-key, nil-validation |
| service is duplicate | validation | error | nomad, service-validation, duplicate, consul |
| %sunexpected keys | validation | error | reflection, config-validation, go |
| unable to convert userid | exception | error | unix, user-lookup, parsing |
| Volume Mount ( ) is invalid | validation | error | nomad, volume, csi, job-validation |
| , Namespaces | validation | error | nomad, vault, validation, job-spec |
| alloc entry not found | error_code | warning | bolt, upgrade, corruption, allocation |
| cannot prepare consul tokens, no task specified | exception | error | nomad, consul, programming-error, nil-pointer |
| conflicting runtime requests: gpu runtime | validation | error | docker, gpu, nvidia, config-conflict |
| deleting job volume claims failed | exception | error | nomad, state-store, volumes, job-deletion |
| error getting plugin | exception | error | csi, nomad, state-store, internal |
| error reading dynamic node metadata | exception | error | nomad-client, state-db, metadata |
| exec task timed out | exception | error | exec, timeout, context |
| executor failed to shutdown error: no process found | exception | warning | executor, process-lifecycle, shutdown |
| failed to bind mount ns at | exception | error | linux, network-namespace, mount, bind-mount |
| failed to open current netns | exception | error | linux, network-namespace, procfs, file-descriptors |
| Failed to parse RPC address | validation | error | config, network, bind-address |
| invalid certificate, not in | exception | error | nomad, tls, certificate, raft, security |
| missing ExternalVolumeID | validation | error | csi, validation, missing-field, storage |
| no formatting option given | validation | error | cli, formatting, argument-validation |
| No nomad log file defined | http | error | api, logging, configuration |
| no PEM-encoded data found | exception | error | tls, pem, certificate, file-parsing |
| plugin does not support snapshot | validation | error | nomad, csi, capability, snapshot |
| reconciliation of job summaries failed | exception | error | nomad, raft, job-summaries, leader-election |
| recovery failed to parse peers.json | exception | error | raft, recovery, json, configuration |
| Reschedule policy has unlimited attempts enabled and a low… | validation | warning | nomad, reschedule-policy, configuration, validation |
| checks require an address | validation | error | consul, service-check, configuration |
| volume row conversion error | exception | error | go, state-store, csi, nomad, corruption |
| check cannot use address_mode="alloc", only checks defined… | validation | error | nomad, health-check, address-mode, service-validation |
| error opening root dir | error_code | error | go, filesystem, fifo, cleanup |
| failed to create fifo for extracting logs | exception | error | logging, fifo, logmon, filesystem |
| Failed to read CA file | exception | error | tls, filesystem, configuration, certificate |
| missing VolumeID | validation | error | csi, validation, missing-field, snapshot, storage |
| node pool cannot be updated | validation | error | nomad, host-volume, node-pool, immutability |
| plugin for type not found | exception | error | plugin-registry, nomad, go, lookup-miss |
| : : group uses network mode ; must be | validation | error | nomad, consul-connect, network-mode, job-validation |
| Services are not unique | validation | error | nomad, job-validation, services |
| Task group has / healthy allocations | validation | error | nomad, deployment, canary, health-check |
| token lookup failed | exception | error | nomad, state-store, memdb, acl, raft |
| Unsupported signature algorithm %T; RSA and ECDSA only are… | exception | error | tls, cryptography, key-type |
| : must be absolute; got | validation | error | nomad, acl, oidc, file-path, validation |
| can't specify empty port | validation | error | nomad, ports, validation, config |
| deleting node pool is not allowed | validation | error | nomad, state-store, node-pools, validation |
errMissingACLBindingRuleID missing ACL binding rule ID | error_code | error | consul, acl, binding-rule, validation, sentinel-error |
| error deleting unexpected task bucket | console | error | nomad, boltdb, state-migration |
| failed to open a streaming connection | exception | error | rpc, yamux, streaming |
| failed to parse | exception | error | nomad, acl, hcl, parse-error |
| failed to stat | exception | error | raft, filesystem, path, go |
| http_read_timeout not a valid duration | validation | error | nomad, config, validation, duration-parsing |
| invalid configuration | validation | error | configuration, scheduler, core, startup |
| The '-template' flag is only valid when using 'go-template'… | validation | error | go, cli, flags, validation |
| unable to provision in accessible_topology | error_code | error | csi, grpc, storage, capacity, topology |
| unknown format flag value | console | error | cli, nomad, flags, validation |
| Vault not enabled but used in the job | validation | error | nomad, vault, job-validation, server-config |
| VolumeID is required | validation | error | go, csi, validation |
| wsErr.Text | exception | error | |
| allow_caps configured with capabilities not supported by… | validation | error | java-driver, capabilities, config-validation, nomad |
| Check invalid: cannot use address_mode="driver", only… | validation | error | nomad, check, address-mode, consul, validation |
| error decoding stats data: stats were nil | exception | error | nomad, docker, stats, json-decode |
| failed to attach to exec | exception | error | docker, exec, streaming, network |
| Failed to create task mount directory | exception | error | filesystem, permissions, nomad-client |
| failed to setup IMDS client | exception | error | aws, imds, cloud-metadata |
| failed to validate API versions | exception | error | plugin-loader, api-version, version-mismatch |
| Invalid operator capability | validation | error | nomad, acl, capability-validation, operator |
| Max Delay cannot be less than Delay | validation | error | nomad, validation, duration, reschedule-policy |
| max_identity_ttl must be greater than 0 | validation | error | nomad, config, validation, ttl |
| plugin missing node | exception | error | nomad, csi, plugin, node-registration, state-consistency |
| rcp.keep_alive_interval must be greater than zero | validation | error | config, validation, nomad-agent, rpc, keepalive |
| require only one of PemCert, PemCertFile, or KeyID | validation | error | nomad, oidc, client-assertion, config-validation |
| Trying to map ports but no network interface is available | validation | error | docker, nomad-driver, ports, network |
| TTL must be between 10 seconds and 24 hours | validation | error | nomad, variables, lock, ttl, validation |
| volume is already published at target path but with… | exception | error | csi, volume, grpc, mount |
| all servers should be running version | exception | error | nomad, acl, version-skew, federation, binding-rules |
| attribute is missing a closing brace | validation | error | nomad, constraint, interpolation, validation |
| Both client cert and client key must be provided | validation | error | |
| Client RPC advertise address is not advertisable | exception | error | network, configuration, startup, nomad |
| [✘] Could not create Consul auth method | exception | error | consul, acl, network, setup |
| error evaluating symlink | exception | error | nomad, security, symlink, path-evaluation |
| invalid plugin loader configuration passed | exception | error | plugin-loader, config-validation, constructor, nomad |
| launch lookup failed | exception | error | nomad, memdb, state-store, lookup |
| MaxParallel must be >= 0 but found | validation | error | nomad, go, validation, migrate-strategy, deployment |
| missing node for client registration | validation | critical | nomad, rpc, validation, nil-pointer |
| Node ID must contain at least two characters. | validation | error | cli, nomad, node, input-validation |
| Prefix matched multiple host volumes | console | warning | cli, ambiguity, host-volumes, prefix-match |
| start_block_for not a valid duration | validation | error | nomad, mock-driver, config, duration-parsing |
| total count was greater than configured job_max_count | validation | error | nomad, scaling, configuration-limit, capacity |