ErrLookup › hashicorp/nomad
hashicorp/nomad
Nomad is an easy-to-use, flexible, and performant workload orchestrator that can deploy a mix of microservice, batch, containerized, and non-containerized applications. Nomad is easy to operate and scale and has native Consul and Vault integrations. · Go · 2,030 source files
Analyzed at 482b49bf1a on 2026-09-04. 2859 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to create nomad cgroup | error_code | critical | linux, cgroups, cgroup-v2, systemd, subtree-control |
| requested mount flags did not match available capabilities | validation | error | csi, storage, grpc, capability-validation, nomad |
| unexpected TTL type | validation | error | nomad, acl, json-decoding, type-mismatch |
| requested capabilities not compatible with volume | error_code | error | csi, grpc, volume-expansion, invalid-argument |
| eval delete failed | exception | error | nomad, state-store, memdb, evals |
| error creating bootstrap configuration for Connect proxy… | exception | error | consul, connect, envoy, nomad, recoverable |
| %w: %q | error_code | error | filesystem, plugin, host-volumes, path-resolution, go |
| failed to finalize snapshot | exception | error | go, io, snapshot, tar, disk |
| invalid value for | validation | error | validation, parameters, type-conversion, host-volumes, go |
| invalid range | validation | error | config-validation, nomad, parsing |
| plan_rejection_tracker.node_window must be greater than 0 | validation | error | nomad, config-validation, server-config, plan-rejection-tracker |
| Failed to create long operations docker client | exception | error | docker, client-initialization, driver |
| poststart hook failed | exception | error | nomad, task-runner, hooks, poststart |
| error making snapshot | http | error | nomad, allocations, filesystem, snapshot, http-api |
| error creating directory | exception | error | filesystem, mkdir, permissions, host-volumes, go |
| network namespace already exists but was misconfigured | exception | error | cni, network, nomad, netns |
| failed to marshal json from Topic | exception | error | json, serialization, streaming |
| failed to inspect container | error_code | error | docker, container-inspect, driver |
| cannot find node for plugin instance | exception | error | csi, storage, nomad, node-lookup |
| failed to read hash file | error_code | error | resolvconf, filesystem, permissions, dns |
| could not find destination path relative to chroot | exception | error | nomad, template, renderer, sandbox, path |
| CSI.ControllerListVolumes: plugin returned an invalid entry | exception | error | csi, grpc, plugin, storage |
| LimitBytes cannot be less than RequiredBytes | validation | error | csi, validation, capacity-range, storage |
| missing volumeID | exception | error | csi, go, nomad, volume-management, empty-argument |
| failed to launch command with executor | exception | error | nomad, java-driver, executor, process-launch, isolation |
| volume snapshot source is not compatible with these… | error_code | error | csi, grpc, storage, invalid-argument |
| ACL binding rule insert failed | exception | error | nomad, state-store, acl, memdb |
| failed to create HTTP request for Vault API URL= | exception | error | vault, http, url-parsing, debug |
| no plugin dispenser found for type | exception | error | plugin-registry, nomad, go, runtime-lookup |
| : volume or node could not be found | error_code | warning | csi, grpc, not-found, checkpoint |
| failed to marshal command | exception | error | json, exec, nomad-api |
| failed to validate API versions | exception | error | plugin-loader, nomad, api-version, compatibility |
| unable to read rooted allocation directory | exception | error | filesystem, client, allocdir, io |
| failed to parse config: | validation | error | nomad, hcl, config-validation, task-runner |
| artifact includes symlink that resolves outside of sandbox | exception | critical | security, sandbox, symlink, artifact |
| validation error | validation | error | csi, go, nomad, validation, volume-management |
| error getting snapshot from previous alloc | exception | error | network, http, allocation-migration, tls |
| unexpected SupportedProxies response format from Consul | exception | error | consul, connect-proxies, response-format |
| No addresses found, please configure one. | validation | critical | network, address-resolution, config, startup |
| volume clone ID cannot be updated | validation | error | csi, nomad, volume, immutable-field, validation |
| %s %s: %s | exception | error | docker, container-inspect, recoverable |
| task driver for does not support host volumes | validation | error | nomad, host-volumes, driver-capabilities, prestart |
| setting config on plugin failed | exception | error | plugin-loader, config-validation, nomad |
| getter subprocess failed | exception | error | artifacts, subprocess, network, retryable |
| task in group defines services, but has no shutdown_delay… | validation | warning | nomad, task-group, services, shutdown-delay |
| unable to find task group in the job summary | exception | error | nomad, state-store, job-summary, raft |
| plugin is shut down | exception | error | nomad, plugin, driver, process-shutdown |
| volume is already published on another node and does not… | error_code | error | csi, grpc, storage, attach-conflict |
| error setting directory permission mode | exception | error | filesystem, chmod, permissions, host-volumes, go |
| network already configured but not found in state | exception | error | nomad, state-store, network, netns |
| failed to convert HCL schema: | validation | critical | device-plugin, hcl, schema, launcher |
| file path escapes capture directory | exception | error | filesystem, security, path-traversal |
| invalid host_volumes limit | validation | error | nomad, hcl, quota, input-validation |
| Semver affinity is invalid | validation | error | nomad, affinity, semver, job-spec, validation |
| service contains invalid check: agent checks do not support… | validation | error | consul, nomad, service-registration, config-validation |
| cap_add configured with capabilities not supported by system | validation | error | nomad, java-driver, linux-capabilities, validation |
| failed to decode log entry at index | console | warning | raft, decoding, msgpack, versioning |
| failed to delete peers.json, please delete manually (see… | exception | error | raft, filesystem, recovery, permissions |
| Job type does not allow max_run_duration | validation | error | nomad, job-validation, max-run-duration, job-type |
| max requested capacity | validation | error | csi, storage, validation, capacity |
| error marshaling volume pramaters | error_code | error | json, host-volumes, serialization |
| Failed to retrieve allocation | exception | error | nomad, cli, api-client, allocation |
| <remote node streaming RPC error relayed from ack.Error> | exception | error | nomad, rpc, streaming, remote-node |
| Couldn't copy to | exception | error | filesystem, io, copy, nomad |
| failed to set cpuset.mems on nomad cpuset cgroup | error_code | critical | linux, cgroups, cgroup-v1, cpuset, permissions |
| operation on unknown device(s) | exception | error | devices, gpu, nomad, fingerprinting |
| Job type does not allow update block | validation | error | nomad, job-validation, update-block, hcl |
| module not in | exception | info | fingerprint, linux, kernel-module, bridge-networking |
| Claim is required | validation | error | csi, validation, nomad, storage |
| failed lock release | exception | error | nomad, state-store, raft, persistence |
| no driver handle | exception | error | driver, task-runtime, handle |
| : volume could not be found | exception | warning | csi, go, nomad, grpc, not-found, volume-management |
| artifact must not be nil | validation | error | nomad, config, validation, nil-receiver |
| alloc failed to claim volume | exception | error | csi, nomad, volume-claim, capacity |
| error changing owner/group | exception | error | filesystem, chown, permissions, host-volumes, linux |
| volume name cannot be updated | validation | error | nomad, csi, storage, immutable-field |
| failed to sandbox alloc dir | exception | error | nomad, template, renderer, sandbox, allocdir |
| Headers must be in the form 'Key: Value' but found | validation | error | cli, input-validation, http-headers |
| node has reached the maximum allowable number of attached… | error_code | error | csi, grpc, storage, resource-limit |
| Task group volume claim insert failed | exception | critical | nomad, state-store, memdb, volume-claims |
| timed out waiting for socket proxy to exit | exception | error | consul, connect, service-mesh, shutdown-timeout |
| Failed to parse value of | http | error | http, query-parameter, parsing, nomad |
| error stream is no longer running | exception | error | streaming, context-cancelled, ndjson, goroutine-lifecycle |
| image_path is not in the allowed paths | validation | error | qemu, security, path-validation, nomad |
| Not ready to serve consistent reads | error_code | warning | nomad, raft, consistency, read-repair, transient |
| failed to get plugin config schema for plugin | exception | error | plugin-loader, grpc, config-schema, fingerprinting |
| Failed to purge container | exception | error | docker, container-name-conflict, cleanup |
| reserved port collision | validation | error | nomad, port-collision, network, scheduling |
| secret path cannot be empty | validation | error | nomad, validation, secrets, config |
| Could not find allocation task group | console | error | nomad, cli, task-group, stale-state |
| Service is Connect Native and requires setting the task | validation | error | nomad, consul-connect, connect-native, validation |
| unknown mkdir parameter | validation | error | validation, parameters, host-volumes, go |
| Consul Connect services | validation | error | consul-connect, nomad-job-spec, port-conflict, validation |
| job summary update failed | exception | error | nomad, state-store, job-summary, error-wrapping |
| error parsing: root should be an object | console | error | hcl, csi, config-parsing, nomad-cli |
| failed to parse signal | exception | error | nomad, vault, signal, config |
| Invalid host volume name: %#v | validation | error | nomad, acl, policy-validation, host-volume |
| %v | exception | error | templates, io, debug-bundle |
| exposed service check | validation | error | nomad, consul-connect, job-validation, expose-check |
| service cannot use address_mode="alloc", only services… | validation | error | nomad, service-validation, address-mode, job-spec |