hashicorp/nomad
Documented errors, page 3 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| alloc lookup failed | exception | error | nomad, state-store, memdb, raft |
| Invalid or duplicate policy keys | validation | error | nomad, acl, hcl, strict-parsing, unknown-keys |
| no CNI network config found | exception | error | cni, network, nomad, configuration |
| no Nomad Servers advertising service | exception | critical | nomad, consul, service-discovery, no-servers |
| unable to query service %+q from Consul datacenter %+q | exception | error | nomad, consul, multi-datacenter, service-discovery |
| volume cannot be expanded online | error_code | error | csi, grpc, failed-precondition, online-expansion |
| cap_drop configured with capabilities not supported by… | validation | error | nomad, java-driver, linux-capabilities, validation |
| envoy must be used as connect sidecar or gateway | validation | error | consul-connect, envoy, nomad, job-spec |
| executor Shutdown failed | exception | error | nomad, java-driver, task-stop, executor-shutdown, graceful-shutdown |
| invalid certificate: not in expected | exception | error | nomad, tls, mtls, certificate, x509 |
| normalizedAddrs is nil or empty | validation | error | config, nomad, network, address-normalization |
| Permission denied | error_code | error | acl, authorization, permissions, nomad |
| failed to find | exception | warning | fingerprint, linux, kernel-module, bridge-networking |
| failed to remove container | exception | error | docker, container-lifecycle, cleanup |
| No Connect services in task group with Connect proxy | validation | error | nomad, consul-connect, service-mesh, validation |
| No path to region | error_code | error | nomad, networking, multi-region, routing, federation |
| stop hook failed | exception | warning | nomad, task-runner, hooks, stop |
| data verification failed | exception | critical | migration, data-integrity, verification, raft |
| error fingerprinting plugin | error_code | error | plugin, fingerprint, process-execution, host-volumes, go |
| index update failed | exception | error | nomad, state-store, raft, memdb |
| : : group has networks | validation | error | nomad, consul-connect, job-validation, network |
| volume insert | exception | error | state-store, memdb, csi, nomad |
| work_dir must be an absolute path | validation | error | nomad, java-driver, path-validation, config |
| Consul Connect transparent proxy requires there is only one… | validation | error | consul-connect, transparent-proxy, nomad-job-spec, validation |
| dispensed plugin doesn't meet base plugin interface | exception | error | plugin-loader, type-assertion, api-compatibility, base-plugin |
| error getting file handle to fifo parent directory | exception | error | go, linux, fifo, file-descriptors |
| failed to create vault client for cluster | exception | error | nomad-client, vault, configuration |
| invalid name | validation | error | nomad, validation, job-spec, actions |
| missing stagingTargetPath | exception | error | csi, go, nomad, volume-management, empty-argument |
| service cannot use address_mode="alloc_ipv6", only services… | validation | error | nomad, service-validation, ipv6, address-mode |
| failed to open snapshot | exception | error | go, raft, snapshot, io |
| mount --make-rshared | exception | error | linux, network-namespace, mount, privileges |
| tty value is not a boolean | http | error | http, query-parameter, boolean, exec, nomad |
| unable to get address for service | validation | error | consul, nomad, address-mode, port-label |
| alloc delete failed | exception | error | nomad, state-store, allocs, memdb |
| allocation missing | exception | error | nomad, csi, volume-claim, missing-allocation |
| error creating rpc client for executor plugin | exception | error | go-plugin, rpc, plugin-handshake, nomad |
| failed to write nomad token | exception | error | filesystem, workload-identity, permissions |
| Memory oversubscription is not enabled; Task | validation | warning | nomad, resources, memory, oversubscription, scheduler-config |
| plugin not found | exception | error | nomad, csi, plugin, not-found, storage |
| release conflict | exception | warning | go, consul, distributed-lock, http-409 |
| volumes are not enabled; cannot mount host path | validation | error | docker, volumes, security, path-escape |
| write error, wrote bytes of | exception | error | filesystem, io, disk-full, json, debug |
| error evaluating object | exception | error | security, path-validation, tar-stream |
| failed to create job diff | exception | error | nomad, job-diff, serialization |
| Invalid quota policy: %#v | validation | error | acl, policy-validation, hcl, consul |
| " " contains characters that require the 'index' function… | console | error | templates, nomad, validation, naming |
| AdvertiseAddrs is nil or empty | validation | error | config, nomad, advertise, network |
| all servers should be running version | exception | error | nomad, acl, version-skew, federation, rolling-upgrade |
| error inserting job summary | exception | error | nomad, state-store, job-summary, raft |
| Failed to create container configuration for image | exception | error | docker, task-configuration, validation |
| log entry mismatch | exception | critical | raft, data-integrity, migration |
| service registration delete for alloc failed | exception | error | nomad, state-store, service-registration, allocs |
DriverStatsNotImplemented stats not implemented for driver | error_code | info | nomad, driver, stats, sentinel-error |
| error parsing fingerprint output as json | error_code | error | plugin, json, fingerprint, parsing, host-volumes, go |
| failed checking integrity of snapshot | exception | critical | go, snapshot, integrity, checksum, corruption |
| service name must include 'nomad | validation | error | systemd, validation, naming, journald |
| : (wraps ErrPluginNotExists) | exception | error | nomad, plugin, secrets, file-not-found |
| (root key) | console | critical | encryption, kms, keyring, decrypt-failed |
| error parsing reserved_ports | validation | error | nomad, scheduler, ports, network, validation |
| failed to close BoltDB store | exception | error | boltdb, close-failed, fsync, io |
| failed to get job's allocations | exception | error | nomad, scheduler, state-store |
| unable to dispense the executor plugin | exception | error | go-plugin, rpc, plugin-dispense, nomad |
| could not start service | exception | error | windows, service, upgrade |
| error making executable | exception | error | filesystem, permissions, chmod, executor |
| Error querying latest job deployment | exception | error | nomad, cli, api-client, deployment |
| failed to create mount point | exception | error | filesystem, csi, permissions |
| Failed to parse named repo | validation | error | docker, image-reference, parsing |
| Invalid key | exception | error | keyring, base64, configuration, security, nomad |
| Job registration, dispatch, and scale are disabled by the… | error_code | warning | acl, scheduler, nomad, http-403, configuration |
| list missing hash for | exception | error | snapshot, integrity, sha256, archive |
| MaxClientDisconnect is deprecated and ignored in favor of… | validation | warning | nomad, deprecation, config-migration |
Pprof profile not found profile: %s %s | http | warning | pprof, http, profiling, nomad |
| task not found in updated alloc | exception | error | nomad, allocrunner, services, allocation-update |
| template destination path escapes alloc directory | exception | error | nomad, template, path-escape, security-sandbox |
| default_ipc_mode must be | validation | error | nomad, exec-driver, configuration, validation |
| exec not possible, client status of allocation | http | error | nomad, exec, allocation-lifecycle |
| Failed to parse server members, members==nil | exception | error | api, nomad, debug-bundle |
| plugin does not support snapshot | validation | error | csi, plugin-capability, snapshot, controller |
| running container as ContainerAdmin is unsafe; change the… | exception | error | nomad, docker, windows, security, container-admin |
| ' ' is not an allowed emulator | validation | error | qemu, nomad, driver-config, allowlist |
| task with ID already started | exception | error | docker, nomad-driver, task-lifecycle, duplicate-task-id |
| %w: %v | exception | info | csi, nomad, unpublish, garbage-collection, storage |
| failed to copy logs | exception | error | migration, raft, io, context-canceled |
| failed to sign node introduction identity claims | exception | error | nomad, signing, keyring, jwt |
| no node meets constraints | exception | error | nomad, host-volumes, placement, constraints, scheduling |
| Set the interval to at least | validation | error | nomad, go, validation, reschedule-policy, remediation |
| stable key mismatch: source= , destination= | exception | critical | raft, migration, stable-store, last-vote |
| %v: %v | exception | warning | nomad, csi, grpc, retryable, attach |
| Constraint validation failed | validation | error | nomad, constraint, validation, jobspec |
| deleting job scaling events failed | exception | error | nomad, state-store, memdb, job-deletion |
| Malformed ulimit specification | validation | error | docker, ulimit, config-validation |
| migration succeeded but failed to rename | exception | error | filesystem, rename, migration, raft |
| ShutdownDelay must be a positive value | validation | error | nomad, job-validation, config |
| start_timeout should be greater than 0s | validation | error | config, nomad, duration-parsing |
| Task group validation failed | validation | error | nomad, job-validation, task-group, hcl |
| Task Group should have a reschedule policy | validation | error | nomad, job-validation, reschedule, missing-config |
| actual resource usage not present | exception | warning | cli, nomad, node-status, stats, client-unreachable |
| compacting json for seccomp profile | validation | error | docker, seccomp, json, config |
| CSI.ControllerListSnapshot: plugin returned an invalid entry | exception | error | csi, grpc, snapshot, plugin, nil-check |