hashicorp/nomad
Documented errors, page 7 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| service[ ] %+q validation failed | validation | error | nomad, service, validation, consul |
| Unknown rpc method | error_code | error | rpc, nomad, method-not-found |
| variables are limited to 64KiB in total size | validation | error | nomad, variables, size-limit, validation |
| VerifyOutgoing set, and no CA certificate provided! | exception | error | tls, configuration, ca-certificate |
| CSI.ControllerDeleteSnapshot | exception | error | csi, grpc, snapshot, delete |
| downgrading Raft is not supported, current version is | exception | critical | raft, versioning, upgrade, configuration |
| error executing protected function | exception | error | go, callback, context, error-wrapping |
| failed check for macOS jvm | exception | error | nomad, java-driver, macos, jvm-detection, fingerprint |
| failed to create share cpuset partition | error_code | critical | linux, cgroups, cgroup-v1, cpuset, mkdir |
| failed to get plugin info for plugin | exception | error | plugin-loader, go-plugin, plugin-handshake |
| failed to read snapshot metadata | exception | error | go, io, snapshot, network |
| fuzzy search is not enabled | exception | error | nomad, go, configuration, feature-flag |
| http_read_timeout must be set | validation | error | nomad, config, validation, missing-field |
| Invalid sentinel policy: %#v | validation | error | nomad, acl, policy-validation, sentinel, enterprise |
| no servers | exception | warning | nomad, rpc, discovery, client |
| node pool not found | validation | error | nomad, state-store, node-pool, not-found |
| Nomad can only make attempts in with initial delay , delay… | validation | error | nomad, go, validation, reschedule-policy, configuration |
| Request body is empty | http | error | http-api, json, request-body |
| snapshot cannot be nil | validation | error | nomad, csi, snapshot, nil-pointer, request-validation |
| Task Group should have a restart policy | validation | error | nomad, job-validation, restart-policy, canonicalize |
| unable to find configuration for consul cluster | exception | error | consul, client-configuration, nomad, token-revocation |
| volume existence check error | exception | error | nomad, csi, volume, state-store |
| can't reload uninitialized RPC listener | exception | error | tls, reload, rpc, sighup |
| consul address must be set on nomad client | exception | error | consul, connect, configuration, service-mesh |
| could not query plugin | exception | error | csi, state-store, snapshot, plugin |
| failed to configure container | exception | error | libcontainer, configuration, cgroups, executor |
| failed to identify user | exception | error | user-lookup, os-users, validation, security |
| keyring has not been initialized yet | exception | warning | keyring, not-initialized, bootstrap |
| no such volume | validation | error | nomad, csi, snapshot, volume-not-found |
| variable not found | error_code | warning | nomad, variables, not-found, kv-store |
| alloc is not part of deployment | validation | error | nomad, state-store, deployment, allocation, mismatch |
| could not read from random source | exception | critical | crypto, entropy, random-source, filesystem |
| error parsing rpc_handshake_timeout | validation | error | config, duration-parsing, startup-validation, nomad |
| failed to create user token | exception | error | windows, logonuser, token, impersonation |
| failed to detect executable | panic | critical | panic, filesystem, process |
| failed to initialize Consul client config | exception | error | consul, configuration, tls |
| Failed to parse value of | http | error | http, query-parameter, parsing, integer, nomad |
| failed to reattach to plugin | exception | warning | devicemanager, reattach, plugin |
| minimum file size is 1MB; got | validation | error | nomad, validation, job-spec, logging |
| missing allocation ID | validation | error | nomad, rpc, argument-validation, filesystem |
| Nomad Enterprise only endpoint | exception | info | http, licensing, nomad-enterprise, api |
| plugin for volume not found | validation | error | csi, plugin, storage, lifecycle |
| writer ui: unsupported Ui type: %T | exception | error | cli, unsupported-type, type-assertion |
| bug: pool exhausted | panic | critical | panic, concurrency, resource-leak |
| csi_volumes lookup failed | exception | error | state-store, memdb, csi, read-txn, nomad |
| empty response from AWS metadata | exception | warning | fingerprint, aws, metadata-service, network |
| exposed service check | validation | error | nomad, consul-connect, job-validation, expose-check |
| failed reading snapshot | exception | error | go, tar, snapshot, corruption |
| failed to open WAL logs | exception | error | raft, wal, corruption, go |
| request certificate is only valid for | exception | error | nomad, tls, certificate, raft, security |
| [✘] Role data could not be deserialized | exception | error | vault, json, setup, cli |
| unable to send signal to process | exception | error | linux, signals, kill, cgroups, executor |
| ACL token is invalid | error_code | error | acl, auth, nomad, invalid-token |
| failed to build template manager | exception | error | template, nomad, update, configuration |
| failed to decode and failed to read buffered data | exception | error | streaming, json, network |
| failed to determine absolute path for | exception | error | windows, filesystem, fingerprinting |
| invalid server.client_introduction configuration | validation | error | config, nomad, validation |
| unable to create local docker image | exception | error | docker, config, image-parsing |
| unable to pull docker image | exception | error | docker, image-pull, image-reference |
| unable to release dynamic workload user | exception | error | linux, dynamic-users, nomad |
| bad nameserver address | validation | error | dns, network, parsing, config |
| could not assign executor to Windows job object | exception | critical | windows, process-management, job-object |
| CSI.ControllerValidateVolume | exception | error | csi, plugin, retryable, controller |
| error unmarshaling json | console | error | json, cli, nomad, unmarshaling |
| failed inserting variable | exception | error | nomad, state-store, storage, variables |
| failed to probe plugin | exception | error | nomad, csi, grpc, fingerprint, plugin-startup |
| failed to reserve device | exception | error | devices, nomad, scheduling |
| failed to retrieve jobs for idempotency check | error_code | error | nomad, state-store, idempotency, dispatch, storage |
| hash check failed for | exception | error | integrity, hash-mismatch, snapshot |
| invalid configuration: unknown scheduler | validation | error | configuration, scheduler, startup |
| invalid key | validation | error | hcl, config-validation, go |
| invalid type %T | exception | error | nomad, type-error, json, quota |
| Max Delay cannot be less than | validation | error | nomad, validation, duration, reschedule-policy |
| nil consul config | exception | error | consul, config, nil-pointer, client-setup |
| Task group service check validation failed | validation | error | nomad, job-validation, services, health-checks |
| unable to expand volume | exception | error | csi, rpc, plugin, storage |
| Unable to parse configured address | exception | error | cli, nomad, url-parsing, configuration |
| variable error: encrypt | exception | error | nomad, variables, encryption, keyring |
| can't revert to current version | validation | error | nomad, job-revert, no-op, version-mismatch |
| could not create snapshot | exception | error | nomad, csi, rpc, snapshot, storage-backend |
| CSI.NodeDetachVolume | exception | error | csi, storage, plugin |
| deployment promotion cannot be undone | error_code | error | nomad, state-store, deployment, write-skew, consistency |
| error encoding basic auth | exception | error | docker, json, serialization, registry-auth |
| failed to get source log | exception | error | raft, logstore, corruption, migration |
| failed to parse plugin | exception | error | plugin-loader, nomad, semver, fingerprinting |
| hg_timeout must be > 0 | validation | error | nomad, config-validation, duration, mercurial |
| invalid type for node variable: %T | exception | error | nomad, taskenv, interpolation, type-error |
| job summary for job in namespace is not present | exception | error | nomad, state-store, job-summary, corruption |
| plugin not found | exception | error | nomad, plugin, filesystem, config |
| %s%d,%s | http | error | nomad, rpc, status-code, acl |
| unknown task name | http | error | nomad, exec, validation, api |
| variable doesn't hold a lock | exception | error | nomad, state-store, variables, locking |
| unread uncompressed bytes remain | exception | error | gzip, snapshot, malformed, stream |
| default_identity_ttl must be greater than 0 | validation | error | nomad, config, validation, ttl |
| error parsing HTTPMaxSize | validation | error | config, parsing, duration, go |
| error saving client identity | exception | error | nomad-client, state-db, identity |
| failed to determine state store's index | exception | error | nomad, state-store, raft, garbage-collection |
| failed to parse start_timeout | validation | error | nomad, config-validation, duration-parsing, server-config |
| Failed to parse X-Nomad-Index | exception | error | http, headers, blocking-queries, nomad-api |
| failed to set cpuset | exception | error | cgroups, linux, executor |