hashicorp/nomad

Documented errors, page 6 of 29. Back to hashicorp/nomad

Code / MessageTypeSeverityTags
unauthorized raft connection from
exception error nomad, tls, raft, unauthorized, security
unexpected ClockSkewLeeway type
validation error nomad, acl, auth-method, configuration, type-mismatch
CSI.ControllerCreateVolume: plugin did not return error or…
exception error csi, plugin-protocol-violation, volume-provisioning, vendor-bug
destination escapes allocation directory
validation error nomad, job-spec, path-traversal, validation
failed executing plugin
exception error nomad, secrets, plugin, grpc
failed to create executor
exception error nomad, java-driver, executor, go-plugin
fingerprint name cannot be empty
validation error config, validation, fingerprint
node ID setup failed
exception critical nomad-client, node-registration, state-db
state for allocation
http error nomad, client, allocation, http-404, streaming
tag already exists on a different version of job
validation error nomad, state-store, job-versions, tag-conflict
timeout ( ) is lower than required minimum timeout
validation error nomad, service-check, config-validation, timeout
unable to get orphaned task PIDs
exception error linux, cgroups, pids, executor
unexpected state
panic error fsm, state-machine, programming-error, panic
volume content source does not exist
error_code error csi, grpc, storage, not-found
consul tokens for cluster
exception error consul, workload-identity, nomad-client, tokens
Error listing host volumes
exception warning nomad, cli, host-volumes, sentinel-error
ExecStreaming
exception error cgroup, linux, executor
failed to convert reattach config
exception warning devicemanager, reattach, state-store
Multi-Cluster Vault is unlicensed.
validation error nomad, licensing, enterprise, vault
unable to retrieve summary for parent job
exception error state-store, job-summary, parent-job
unknown old job status
exception error state-store, job-summary, status, corruption
volume is currently unschedulable
error_code error csi, storage, nomad, scheduling
client_introduction.enforcement must be set
validation error config-validation, client-introduction, missing-field, startup
CSI.ControllerListVolumes
exception error csi, nomad, plugin-not-found, retryable
error getting signed identity for service
exception error nomad, consul, workload-identity, jwt, services
event dropped from buffer
exception warning nomad, event-stream, backpressure, streaming
failed to generate OIDC provider
exception error nomad, acl, oidc, sso, network
failed to serialize client_assertion jwt
exception error jwt, serialization, oidc, client-assertion, nomad
not a terminal
exception error tty, terminal, cli, exec
only one of cgroups_v1_override and cgroups_v2_override may…
validation error rawexec, cgroups, config-validation, nomad
snapshot is already pending
error_code warning csi, snapshot, grpc, concurrency, nomad
task driver for does not support CSI
validation error nomad, csi, driver-capabilities, prestart
unable to create key wrapper
exception error kms, key-wrapping, configuration
unable to determine local service port for service check
validation error nomad, consul-connect, port-label, expose-check
unexpected file in snapshot
exception error go, snapshot, format, validation
unknown service registration provider for update
validation error nomad, service-registration, invalid-enum, provider-update
A template must be supplied using '-template' when using…
validation error cli, nomad, validation, output-format
context must be one of
validation error nomad, go, search, invalid-context
failed parsing cron expression
exception error cron, panic-recovery, periodic-jobs
failed to decode taskConfig state from handle
exception error nomad, java-driver, recover-task, state-corruption
failed to retrieve services from consul
console error consul, nomad, acl, service-discovery
Invalid host volume policy: %#v
validation error nomad, acl, policy-validation, host-volume
no task resources found on allocation
exception critical nomad, taskrunner, allocation, resources
Node Pools Governance is unlicensed.
validation error nomad, licensing, node-pool, validation
provider for secret response contained error
exception error nomad, secrets, plugin
retry config is nil or empty
validation error config, validation, retry
secret path cannot contain template delimiters or…
validation error validation, template-injection, vault, secrets
unable to parse configured address
exception error cli, nomad, url-parsing, configuration
unknown new job status
exception error nomad, state-store, job-status, validation
Unsupported restart mode
validation error nomad, validation, job-spec, restart-policy
cannot rekey without setting the new key active
validation error nomad, state-store, keyring, encryption-key
default auth config text could not be deserialized
exception error consul, json, setup, cli
invalid redirect location
exception error websocket, redirect, http, nomad-api
invalid suffix
validation error systemd, validation, naming, journald
Invalid variable operation
exception error nomad, fsm, variables, version-skew
port label referenced by services does not exist
validation error nomad, job-spec-validation, service, ports
reloading server config failed
console error nomad, agent, reload, sighup, server-config, tls
error parsing server's last_log_index value
exception error nomad, raft, parsing, rpc
Failed to load snapshot from archive
exception error raft, snapshot, corrupt-archive, go
failed to set cpuset.mems on reserve cpuset partition
error_code critical linux, cgroups, cgroup-v1, cpuset, numa
requested runtime is not allowed
validation error docker, runtime, security, allowlist
volume lookup failed
exception error state-store, memdb, csi, claim, nomad
cannot update volume
validation error nomad, host-volumes, update, not-found
error parsing DecompressionLimitSize
validation error config, parsing, bytes, go
failed to parse signal
validation error docker, signals, validation
failed to setup replacement docker logger
exception error docker, logging-plugin, task-recovery, cleanup
missing target RPC
exception error nomad, rpc, agent-profiling, region
tag not found
validation error nomad, job-versioning, tag-not-found
task is not running.
http error nomad, exec, process-lifecycle
the image does not exist
error_code error docker, windows, lcow, image-inspect
unexpected executor rpc type: %T
exception error go-plugin, type-assertion, rpc, nomad
unsupported version=
exception warning versioning, feature-detection, nomad
all servers should be running version
validation error service-registration, versioning, cluster, upgrade
bind name should be empty
validation error nomad, acl, validation, binding-rule
Error parsing advertise address template
validation error config, consul, template-parsing, advertise-address
failed to add key to keyring
exception critical go, nomad, keyring, replication, encryption
failed to build mount for resolv.conf
exception error nomad, java-driver, dns, filesystem
failed to decode snapshot metadata
exception error go, json, snapshot, corruption
failed to open WAL store
exception error filesystem, raft-wal, migration, storage
failed to read snapshot
exception error snapshot, io, corruption
Failed to signal task
exception error nomad, client, signal, multierror
MinHealthyTime must be less than HealthyDeadline
validation error nomad, go, validation, migrate-strategy, cross-field
missing device name
validation error nomad, hcl, quota, device
validating volume against state failed
validation error nomad, host-volumes, validation, state-store
Allocations bucket doesn't exist and transaction is not…
exception warning database, bolt, read-only-transaction, bucket-missing
command is required
validation error executor, validation, exec
deployment watcher not enabled
console warning nomad, configuration, deployment-watcher
ErrCgroupMustBeSet
cgroup must be set
error_code error cgroups, linux, executor, nomad
error determining port
exception error cli, nomad, curl, url-parsing, tls
Failed to create keystore tempdir
exception error nomad, go, filesystem, keystore, dev-mode
failed to get docker long operations client
exception error docker, client-init, tls, task-recovery
failed to get plugin info for plugin
exception error plugin-loader, nomad, fingerprinting, go-plugin
failed to get tainted nodes for job
exception error nomad, scheduler, sysbatch, tainted-nodes, state-store
failed to write bytes to eventstream.json; bytes written
exception error filesystem, io, durability
failed to write snapshot file
exception error filesystem, io, snapshot, disk-full
invalid value for cpu_cfs_period
validation error docker, nomad-driver, config-validation, cpu
namespace has non-terminal jobs in regions
validation error nomad, namespace-delete, precondition-failed
no plugins registered for type
exception warning dynamic-plugins, csi, registry
no such volume
validation error nomad, csi, volume, not-found, unpublish
QEMU memory assignment out of bounds
validation error qemu, resources, validation, memory