hashicorp/nomad

Documented errors, page 8 of 29. Back to hashicorp/nomad

Code / MessageTypeSeverityTags
Feature "Node Pools Governance" is unlicensed
validation error nomad, licensing, enterprise, node-pools
locks
exception error
PluginID is required
validation error go, csi, validation
running as user is disallowed
validation error security, validation, user, nomad
unable to check for existing service
exception error go, windows, service-control-manager, permissions
cannot use address_mode="alloc": no allocation network…
validation error nomad, service-registration, networking, configuration
error getting address for check
validation error consul, nomad, health-check, address-resolution
ErrPluginNotExecutable
plugin not executable
error_code error go, plugins, filesystem-permissions, host-volumes
failed to delete job
exception error nomad, state-store, job-versions, delete
failed to set cpuset.mems on share cpuset partition
error_code critical linux, cgroups, cgroup-v1, cpuset, numa
failed updating variable index
exception error nomad, state-store, memdb, index
group references task in a service definition, but the task…
validation warning nomad, service-definition, shutdown-delay, task-group
http addr of node ( ) is not advertised
exception error nomad, node, network, nomad-api
job source size of exceeds maximum of and will be discarded
exception warning nomad, job-submission, size-limit, hcl, job-registration
no such provider configured
exception critical kms, keyring, configuration
number of schedulers should be between 0 and
validation error config, nomad, schedulers
Service provider must be
validation error nomad, service-discovery, validation, config
stdout_repeat_duration
validation error nomad, mock-driver, duration-parsing, config-validation
svPreApply: unexpected VarOp received
exception error nomad, variables, validation, acl, unsupported-operation
Task validation failed
validation error nomad, job-validation, task, hcl
command is not present
http error api, validation, exec
Could not re-encode redacted key
exception error raft, snapshot, encoding, msgpack, go
CSI.ControllerDeleteVolume
exception error csi, nomad, plugin-not-found, retryable
empty AZ Environment value
exception warning fingerprint, azure, metadata-service, network
failed to load SI token for
exception error go, filesystem, nomad, consul, si-token
failed to Statfs
exception error linux, network-namespace, filesystem, statfs
handshake auth token mismatched auth header token
validation warning websocket, auth, token, security
minimum number of files is 1; got
validation error nomad, validation, job-spec, logging
rpc error
exception error network, rpc, connection, go
volume identity cannot be updated
validation error nomad, csi, volume, immutability
all servers must be running version
exception error nomad, variables, version-compatibility, cluster-upgrade
Could not find task named
console error nomad, cli, task-name, invalid-input
Error querying job allocations
exception error nomad, cli, api-client, allocations
failed to identify user
exception error unix, user-lookup, exec, nomad-executor
failed to launch docker logger process
exception error docker, logging, tls, container, nomad-driver
failed to read log entry at index
console warning raft, corruption, data-loss, storage
failed to read or write snapshot data
exception error go, io, snapshot, disk, stream
invalid initial check state
validation error nomad, service-check, config-validation, consul
plugin in use
error_code warning csi, storage, nomad, cleanup
unknown fingerprint
exception error fingerprint, configuration, typo
BoltDB store not found at
exception error filesystem, preflight, missing-file, migration
can not target wildcard ("*")namespace
validation error nomad, variables, locking, namespaces, validation
cannot detect Windows ProgramFiles path
exception error windows, environment, registry, paths
Docker container exited with non-zero exit code
exception error docker-driver, exit-code, container-crash
error at index: , Err
exception warning streaming, consul-api, partial-failure
error marshaling json for stream
exception error nomad, streaming, json, serialization
Error querying job evaluations
exception error nomad, cli, api-client, evaluations
error retrieving supported Envoy versions from Consul
exception error nomad, consul, envoy, network, api
failed to create container
exception error libcontainer, container-creation, filesystem, executor
failed to dispense driver
error_code error nomad, driver, plugin-dispense, network-setup
failed to get blocked evals for job
exception error nomad, state-store, memdb, blocked-evals
failed to hash to check for modifications
error_code error resolvconf, io, dns, filesystem
invalid claims
validation error jwt, claims, validation, jose, go
Specified cipher suites don't support the certificate…
validation error tls, ciphersuite, certificate
task group volume claim lookup failed
exception error nomad, state-store, volume-claims, delete
Unexpected task coordinator state
panic error panic, state-machine, enum, tasklifecycle
unknown volume access mode
exception error csi, validation, volume, configuration
Chmod( ) failed
exception error filesystem, permissions, chmod, nomad
dispatch error
console error hcl, decoding, nomad, validation
failed to create terminal
exception error pty, terminal, socket, linux, executor
failed to initialize table forwarding rules
error_code error nomad, iptables, bridge, cni, networking
invalid acl policy
validation error acl, hcl, panic, consul
KillTimeout must be a positive value
validation error nomad, task, duration, validation
namespace does not exist
validation error nomad, namespace, not-found
network hostname is not a valid DNS name
validation error nomad, network, dns, hostname, validation
require only one of PemKey or PemKeyFile
validation error nomad, oidc, client-assertion, config-validation
timeout cannot be negative
validation error go, nomad, scheduler, configuration, validation
Unexpected nil volume returned for ID
error_code error nomad, csi, rpc, nil-response
auto_promote must be true for all groups to enable…
validation error nomad, deployment, auto-promote, canary
CSI client error (retryable)
error_code warning csi, storage, retry, nomad
CSI.ControllerExpandVolume
exception error csi, grpc, volume-expansion, storage-backend
error deleting invalid task state for task
console error nomad, boltdb, state-migration, client
error getting client config
exception error nomad-cli, client-config, tls, environment
failed to lookup eval allocs
exception error nomad, state-store, allocs, evals
failed to parse rules
validation error acl, validation, hcl, parse-error
failed to retrieve Consul client for cluster
exception error consul, client-configuration, nomad, token-derivation
'file-system' access type was not requested but was…
validation error csi, file-system, validation, access-type
hostname cannot be set on task group using
validation error nomad, network, hostname, validation, jobspec
invalid ';' character in CNI arg value
validation error nomad, cni, validation, networking
Invalid time zone
validation error nomad, validation, timezone, job-spec
log storage ( MB) must be less than requested disk capacity…
validation error nomad, validation, disk-capacity, logging
plugin loaded does not implement the driver interface
exception error plugin, devicemanager, type-assertion
Quota matched no quotas
exception error nomad, cli, quota, prefix-lookup
specified binary is invalid
exception error filesystem, permissions, launch
task memory requirements exceed driver hard limit of
validation error docker, memory, config, nomad
template evaluated to empty result
validation error config, network, template
unexpected envoy version format
exception error nomad, envoy, semver, version-parsing
Unknown payload requirement
validation error nomad, validation, dispatch, enum
unknown scheduler
exception error nomad, scheduler, configuration, invalid-argument
variable already holds a lock
exception warning nomad, variables, locking, concurrency
acl policy lookup failed
exception error nomad, acl, state-store, read-path
command did not include data
exception error raft, corruption, data-loss, storage
error creating file header
exception error filesystem, tar, archive
error from unshare
exception error linux, network-namespace, unshare, privileges
executor failed to find process
exception error process, shutdown, executor
journald log monitoring only available on linux
validation error journald, platform, linux, log-monitoring
missing AllocID
http error nomad, rpc, streaming, filesystem, argument-validation
missing parameterized job ID
validation error nomad, api, missing-parameter, validation
Plugin.Name must not be empty
validation error validation, plugin-registry, nomad
Region
exception error nomad, network, rpc, federation