kubernetes/kops

Documented errors, page 27 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
error deleting network
exception error gce, network, vpc, deletion
error deleting tags on
exception error aws, ec2, tags, iam-permissions
error listing ServiceAccounts
exception error gce, iam, service-account, listing
error reading data
exception error vfs, memfs, io
expected RoleAssignment, but got %T
exception error
failed to initialize the service controller, error
console error dns-controller, kubernetes, initialization
failed to list backend services
exception error gce, backend-service, load-balancer, listing
found multiple Instances for
exception error aws, ec2, instances, invariant-violation
Found multiple NLBs with DNSName
exception error aws, nlb, dns, ambiguity
image name specification not recognized
exception error aws, ec2, ami, input-validation
keyStore path is not cluster readable
exception error vfs, pki, storage-permissions
must specify mode for (non-shared) Network
validation error
project metadata was empty
validation error gce, metadata, project-id, empty-value
SizeGB cannot be decreased
validation error linode, volume, validation, resize, immutable
unexpected key type
exception error go, rsa, pem, certificates, bootstrap
build STS request
exception error
can only promote to one keyset at a time
validation error cli, argument-validation
cannot interpret value as bool
exception error go, parsing, bool
control-plane InstanceGroup
validation error kops, subnets, control-plane, validation
decoding authorization token
exception error
error deleting autoscaling group
exception error aws, autoscaling, deletion, api-error
error deleting Disk
exception error
error extracting servers from pages
exception error openstack, gophercloud, response-parsing, servers
error listing Routers
exception error
error marshalling host data
exception error yaml, serialization, bare-metal
error reading operator manifest
exception error
failed to read metadata information
exception error digitalocean, metadata, io, network
failed to sign data
exception error
image is required
validation error karpenter, aws, validation, missing-value
instanceGroup cannot be nil
exception error instancegroup, nodeup, nil-check
projectID does not match expected: got
validation error gcp, tpm, configuration, authorization
provider ID is missing prefix
validation error digitalocean, provider-id, validation, format
unrecognized token (expected k=v)
validation error parsing, pki, config
completed cluster failed validation
validation error
creating clientset
exception error
creation of AWS Classic Load Balancers is no longer…
validation error aws, elb, deprecated, validation
error building token source
exception error
error creating NLB : found
exception error
error fetching recordset images for upsert operation
exception error
error waiting for NLB
exception error
failed to extract images
exception error
method metal.Cloud::DeleteInstance not implemented
exception error
method metal.Cloud::DeregisterInstance not implemented
exception error
NatGateway has no addresses
exception error
parsing keypair-ids.yaml
exception error
parsing S3 location
exception error s3, url-parsing, nodeup
reading created ForwardingRule
exception error gce, forwarding-rule, labels, read-after-write
unable to parse JSON
console error
yaml output format is not (currently) supported for secrets
exception error cli, kops, unsupported-feature, output-format
building node labels for instance group
exception error hetzner, node-labels, instance-group
determining IG name for
exception error azure, tags, instance-group, kops
error building kube-apiserver flags
exception error
error creating NLB
exception error
error listing autoscaling cluster tags
exception error
error pruning manifest
exception error
error setting GCS bucket ACL for gs://
exception error gcs, gcp, storage, acl, api-error
error tagging IAMOIDCProvider
exception error aws, iam, oidc, tagging, kops
error updating port
exception error openstack, neutron, port
error writing SSL private key
exception error pki, private-key, serialization, pem
failed to parse public key
exception error pki, pem, configuration, key-format
invalid google cloud URL (token count)
exception error
method metal.Cloud::FindVPCInfo not implemented
exception error
not a supported security group type
exception error
unable to parse as a url
exception error
attested document createdOn
validation error
error building kops API client
exception error
error creating cluster
error_code error state-store, cluster, api
Error creating Nat Gateway
exception error aws, ec2, natgateway, provisioning
error deleting router
exception error gce, router, deletion, cloud-api
error getting projectID from metadata
error_code error
error querying for IP Address
exception error
error setting tags to unknown volume
exception error
evictionSoftGracePeriod
exception error kubelet, eviction, config-parsing
failed to get info for server
error_code error
failed to get keyset from
exception error pki, keyset, bootstrap, nodeup
HeartbeatInterval not supported by etcd-manager
validation error kops, etcd-manager, unsupported-field, etcd-tuning
host did not have public-key
exception error kubernetes, pki, missing-field, configuration
issuing certificate
exception error certificates, keystore, etcd, bootstrap
LeaderElectionTimeout not supported by etcd-manager
validation error kops, etcd-manager, unsupported-field, etcd-tuning
listing forwardingRules
exception error gce, forwarding-rule, list, deletion
must specify the name of the instance group to delete
validation error cli, kops, missing-argument, validation
setting ForwardRule labels
exception error gce, forwarding-rule, labels, operation
Volume.Name is required
validation error linode, volume, validation, missing-field
creating route tables client
exception error azure, client-initialization, credentials
discoveryService URL must be specified
validation error config, validation, oidc, service-account
droplet not found
exception error digitalocean, droplet, not-found, api
Error appending tag to port
exception error openstack, neutron, tags
error calculating CIDR subnet
exception error
error listing hosted zones
exception error aws, route53, iam
error listing tags on
exception error
error opening
exception error opentelemetry, file-io, permissions
error reading /proc/self/mountinfo
exception error filesystem, procfs, mount
error while waiting for volume
exception error digitalocean, volume, timeout
failed to delete load balancer
exception error hetzner, load-balancer, deletion, cloud-api
failed to list dns recordsets
exception error
InstanceGroupVFS DeleteCollection not implemented for vfs…
exception error vfs, not-implemented, instancegroup
linode subnet requires a CIDR
validation error linode, subnet, cidr, validation
load balancer service get request returned error
error_code error
VMSS has no network profile
exception error
base URL path is too broad
validation error