ErrLookup › kubernetes/kops
kubernetes/kops
Kubernetes Operations (kOps) - Production Grade k8s Installation, Upgrades and Management · Go · 1,363 source files
Analyzed at 4c8573c808 on 2026-09-05. 3212 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| found instance with unexpected status | exception | error | |
| error finishing target | exception | error | |
| unmarshalling authorization token data | exception | error | go, json, authentication, pki, bootstrap |
| unhandled type at path | exception | error | json, transform, type-mismatch |
| waiting for kubernetes API to be served | exception | error | api-server, validation, reconcile, cluster-health, timeout |
| unable to convert from Quantity | exception | error | reflection, quantity, kube-scheduler, conversion |
| failed to deregister instance from loadBalancer before… | exception | error | aws, load-balancer, rolling-update, drain |
| InstanceGroups::Update not supported for server-side client | exception | error | go, unsupported-operation, kops, read-only |
| could not find Render method on type %T (target %T) | exception | error | |
| error subnets must exist in the cluster | exception | error | kops, subnets, validation, cli |
| failed to get bootstrap data secret | exception | error | kubernetes, rbac, secret, controller-runtime, bootstrap-data |
| error getting ForwardingRule | exception | error | gce, gcp, load-balancer, api-error |
| reading actual user-data | exception | warning | scaleway, io, user-data, network |
| failed to get info for server | exception | error | hetzner, bootstrap, api, authentication |
| loading AWS config | exception | error | aws, imds, config, nodeup |
| error creating sftp client | exception | error | ssh, sftp, vfs, network |
| node identity is required | exception | error | kubernetes, kops, bootstrap, authentication |
| keypair has no certificate | exception | error | keypair, keystore, rotation, cluster-administration |
| writing keyset | exception | error | keystore, state-store, persistence, aws, permissions |
| cannot load kubecfg settings for | console | error | kubernetes, kubeconfig, cli, client-go |
| getting location for bucket | exception | error | aws, s3, network, permissions |
| Volume.RenderOpenstack | exception | error | openstack, cinder, availability-zone, error-wrapping |
| cannot mix egress values in private or IPv6-capable subnets | exception | error | aws, networking, cluster-spec, validation |
| Error creating instance | exception | error | openstack, nova, instance-provisioning, kops |
| challenge.secret not set | exception | error | bootstrap, validation, missing-config |
| arn has unrecognized type | exception | error | aws, iam, sts, bootstrap, arn |
| multiple physical network interfaces found with MAC address | exception | error | networking, aws, eni, nodeup |
| building kubernetes client | exception | error | kubernetes, client-init, kops |
| error getting ingress status | exception | error | cloud-api, load-balancer, gcp, controller |
| resolving EC2 endpoint for region | exception | error | aws, endpoint-resolution, region, s3 |
| error deleting | exception | error | gcs, google-cloud, delete, permissions, kops |
| listing resources for | exception | error | kubernetes, dynamic-client, list, network, timeout |
| connecting | exception | error | ssh, network, cluster-dump, go |
| failed to extract storage availability zones | exception | error | openstack, cinder, json-parsing, gophercloud |
| building json | exception | error | containerd, json, kubenet, nodeup |
| building node patch | exception | error | kubernetes, json, serialization |
| failed to serialize public key to DER format | exception | error | oidc, x509, crypto, der-serialization |
| error creating SecurityGroup | exception | error | openstack, security-group, neutron, cloud-provisioning |
| error finding aws DNSName | exception | error | aws, load-balancer, dns, kops |
| error listing security group rules | exception | error | openstack, neutron, security-group, api-error |
| error writing updated instancegroup configuration | exception | error | state-store, instancegroup, cluster-creation, persistence |
| building bootstrap data | exception | error | kubernetes, kops, nodeup, bootstrap-data, state-store |
| failed to parse template, error | exception | error | go, templates, panic, kops |
| error building nova client | exception | error | openstack, nova, endpoint, service-catalog, gophercloud |
| error creating server group | exception | error | openstack, nova, server-group, api-error |
| error recreating Instance | exception | error | gce, gcp, instance-group, rolling-update, kops |
| error removing file | exception | error | filesystem, golang, kops, delete |
| building static config | exception | error | etcd-manager, bare-metal, json-marshal |
| encoding kubelet component config | exception | error | kubelet, config-encoding, nodeup |
| error deleting InstanceGroupManager | exception | error | gce, compute-api, instance-group-manager, deletion, wrapped-error |
| error running tasks | exception | critical | nodeup, tasks, bootstrap, systemd |
| error seeking to start of data stream for write to | exception | error | gcs, io, seek, kops, golang |
| reconcile is not supported with terraform | exception | error | reconcile, terraform, unsupported-target, cli |
| error creating KopsConfig controller | exception | critical | kubernetes, controller-runtime, crd, scheme, startup |
| cannot build kube client | console | error | kubernetes, client-go, kubeconfig, tls |
| error reading instance-id from AWS metadata | exception | critical | aws, metadata, imds, nodeup |
| found multiple subnets with name | validation | error | kops, cluster-spec, subnets, configuration |
| error parsing version spec | exception | warning | json, annotations, corrupt-state, kubernetes |
| error decoding EC2 UserData | exception | error | aws, ec2, base64, userdata, instance-find |
| unable to marshal YAML | console | error | yaml, serialization, cli-output |
| VPC ID is required when EgressOnlyInternetGateway is shared | validation | error | aws, ec2, vpc, ipv6, shared-resource |
| applying ConfigAdditions to containerd config | exception | error | containerd, config, toml, configuration |
| error building cinder client | exception | error | openstack, cinder, endpoint, service-catalog, gophercloud |
| EgressOnlyInternetGateway for shared VPC was not found | error_code | error | aws, ec2, vpc, ipv6, shared-resource |
| attested document expired at | validation | error | azure, attestation, expired-document, clock-skew |
| error reading actual policy document | exception | error | aws, iam, policy-document, kops-apply |
| instanceGroup: does not exist (try adding --force flag) | error_code | error | kops, instancegroup, cli, not-found |
| rendering policy as json | exception | error | aws, iam, sqs, json-serialization |
| error listing systemd services | exception | warning | ssh, systemd, node-dump, go |
| failed to verify claim signature for node | exception | error | go, pki, ecdsa, signature-verification, authentication |
| reading expected user-data | exception | error | scaleway, user-data, io, kops |
| error executing command | exception | warning | ssh, remote-command, timeout, go |
| getting data from secret | exception | warning | kubernetes, secret, unstructured, dump |
| error building dns scope | console | error | dns-controller, dns-provider, configuration |
| error loading NodeupConfig | exception | error | kubernetes, kops, state-store, bootstrap, s3 |
| error querying ec2 metadata service (for region) | exception | critical | aws, imds, network, controller-startup |
| cannot create cluster validator | error_code | error | validation, kubernetes, client |
| found multiple instances with instance id | exception | error | aws, ec2, bootstrap, invariant-violation |
| unhandled bastion LoadBalancer type | exception | error | kops, aws, bastion, load-balancer, config-validation |
| expected exactly one container in dns-controller… | exception | error | kops, addon, dns-controller, deployment, manifest |
| found IAM instance profile assigned to multiple Instance… | exception | error | aws, iam, instance-group, config-validation |
| getting VMSS | exception | error | azure, vmss, api-error, error-wrapping |
| NAT EC2 Instance not found | exception | error | aws, ec2, shared-resource, nat-instance, kops |
| load balancer not yet ready (arn is empty) | exception | error | aws, nlb, target-group, apply-ordering |
| error building kubeproxy flags | exception | error | go, nodeup, kube-proxy, flag-builder |
| error node usage class not supported | exception | error | kops, ec2, spot, cli, validation |
| keypair/service-account task not found | exception | error | kops, oidc, model-builder, internal-error |
| found VMSS without IP config subnet ID | exception | error | azure, vmss, networking, missing-id |
| getting cluster control plane VMSS for API ingress status | exception | error | azure, api-ingress, vmss, cloud-api |
| invalid InstanceGroup name | validation | error | kubernetes, kops, validation, instancegroup |
| unable to remap CNI plugin binaries asset | exception | error | kops, cni, asset-download, http, checksum-mismatch |
| error listing nodes | console | error | kubernetes, dns-controller, rbac, api-server |
| decoding PKCS7 signature | exception | error | azure, pkcs7, base64, attestation |
| error adding asset | exception | error | nodeup, assets, download, hash-mismatch |
| error deleting volume | exception | error | openstack, cinder, volume, delete, retry |
| error watching nodes | console | error | kubernetes, dns-controller, watch, rbac |
| verifying PKCS7 signature | exception | critical | azure, pkcs7, signature-verification, x509, attestation, security |
| building presigned request | exception | error | aws, sts, presign, credentials, configuration |
| kops currently only supports re-use of either NAT EC2… | validation | error | aws, networking, egress, unsupported-value |
| error parsing NodeupConfig | exception | critical | nodeup, yaml, config-parsing, bootstrap |