kubernetes/kops
Documented errors, page 2 of 33. Back to kubernetes/kops
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| reading instance metadata response | exception | error | http, io, linode, metadata |
| error starting a new AWS session | exception | error | aws, session, credentials, region |
| error trying to locate asset | exception | error | go, nodeup, kubectl, asset-download, network |
| providerID not recognized for node | exception | error | azure, node-identity, provider-id, kops |
| error creating cloud instance group member | exception | error | openstack, instance-group, rolling-update, cloudinstances |
| error listing ElasticIPs | exception | error | aws, ec2, elastic-ip, api-error |
| failed to generate AWS IAM Policy | exception | error | aws, iam, kops, policy-generation |
| parsing kops version | exception | error | kops, addons, version-parsing, build |
| unable to SSH to | exception | error | ssh, network, authentication, go |
| unable to verify token | exception | error | bootstrap, auth, token, kops |
| did not find API endpoint | exception | error | load-balancer, endpoints, controller, cloud |
| error listing ManagedInstances in | exception | error | gce, compute-api, instance-group-manager, listing, wrapped-error |
| parsing presigned url | exception | error | aws, sts, url-parsing, bootstrap |
| unexpected error creating validatior | exception | error | kubernetes, validation, kops |
| failed to deregister instance from load balancers | exception | error | aws, load-balancer, drain, concurrency |
| unable to parse KubernetesVersion | validation | critical | nodeup, kubernetes-version, parsing, configuration |
| cluster name label not yet set | exception | error | labels, kubernetes, bootstrap, cluster-api |
| error creating Router | exception | error | gce, networking, router, api-error |
| error listing IAM instance profiles | exception | error | aws, iam, pagination |
| querying instance metadata | exception | critical | azure, imds, network, bootstrap |
| waiting for disk create/update completion | exception | error | azure, disk, long-running-operation, timeout |
| error building node labels | exception | error | kops, node-labels, instance-group, validation |
| Error getting image information | exception | error | openstack, glance, boot-from-volume, kops |
| error serializing secret | exception | error | serialization, json, kops, secrets |
| path: already exists but is not a directory | exception | error | filesystem, nodeup, directory |
| error creating security group rule | exception | error | openstack, neutron, security-group, rule-conflict |
| error initializing AWS client | exception | error | aws, cloud-client, configuration |
| InstanceGroups::DeleteCollection not supported for… | exception | error | kubernetes, kops-controller, clientset, unsupported-method |
| method DeleteSSHCredential not supported in server-side… | exception | error | kubernetes, kops-controller, ssh, credentials, unsupported-method |
| deregistering cloud instance | exception | error | scaleway, load-balancer, backends, pagination |
| error rendering Scaleway file | exception | error | terraform, scaleway, vfs, object-storage |
| parsing kops-channels manifest | exception | error | yaml, kubernetes, manifest-parsing, enrollment |
| cluster not yet healthy | exception | error | kubernetes, kops, validation, cluster-health |
| error remapping manifest | exception | error | addons, manifest, yaml, bootstrap-channel |
| getting kubernetes client | error_code | error | kubernetes, client, kubeconfig, tls |
| got an error while querying for valid regions (verify your… | exception | error | aws, ec2, credentials, api-error |
| resource ID subscription | exception | error | |
| cannot apply changes to InstanceGroupManager | exception | error | gce, instance-group-manager, unsupported-change, drift |
| cluster has no subnets | validation | error | azure, cluster-config, validation, subnets |
| error finding relative path for | exception | warning | filesystem, internal, assets |
| updating back-end for load-balancer | exception | error | scaleway, load-balancer, backend, validation |
| validating PKCS7 signer SAN | validation | critical | azure, x509, san, attestation, security |
| error deleting Instance | exception | error | gce, compute-api, instance, deletion, wrapped-error |
| parsing StorageAccountID | exception | error | azure, terraform, config-validation |
| unable to render template | exception | error | kops, templates, rendering, validation |
| exactly one 'admin' SSH public key can be specified when… | validation | error | openstack, ssh, configuration, precondition |
| ServiceAccount with email | exception | error | gce, gcp, iam, service-account, shared-resource |
| bastion is not set, but useBastion is true | exception | error | ssh, bastion, configuration |
| failed to marshal json | exception | error | oidc, json, marshal, jwks |
| method AddSSHPublicKey not supported in server-side client | exception | error | kubernetes, kops-controller, ssh, credentials, unsupported-method |
| unknown cloudprovider | validation | error | cloudprovider, builder, configuration |
| Could not extract flavors | exception | error | openstack, nova, gophercloud, json-decode |
| error extracting security group rules from pages | exception | error | openstack, neutron, security-group, response-parsing |
| Failed to find floatingip subnet | exception | error | openstack, networking, router, neutron |
| could not init DNS provider | exception | error | dns-provider, configuration, plugin |
| failed to load default aws config | exception | error | go, aws, aws-sdk-go-v2, config-load, bootstrap |
| marshaling to yaml for | exception | error | yaml, serialization, kubernetes, kops |
| rendering S3 file | exception | error | terraform, s3, aws, vfs |
| Subnet.ID is required | validation | error | linode, subnet, reconciliation, config |
| could not find user | exception | error | kubeconfig, authentication, go |
| error querying namespace | exception | error | kubernetes, namespace, rbac, api-server |
| Etag was not a valid MD5 sum | exception | error | |
| failed to associated floating IP to instance | exception | error | openstack, neutron, floating-ip, kops |
| unable to unmarshall content from template | exception | error | kops, yaml, templates, parsing |
| unhandled kind in | console | error | cli, validation, unsupported-kind |
| error creating sftp client (in new-session) | exception | error | ssh, sftp, vfs, network |
| error rendering addon | exception | error | addons, templates, bootstrap-channel |
| error reading cluster configuration | error_code | error | kops, state-store, cluster-config |
| promoting keypair for | exception | error | keypair, rotation, keystore, cli |
| error creating ssh session | exception | warning | ssh, session, connection-limit, go |
| unsupported arch | exception | error | architecture, platform-support, go-runtime |
| validation of the full cluster and instance group specs… | exception | error | cli, validation, cluster-spec |
| error creating DHCPOptions | error_code | error | aws, ec2, kops, dhcp-options, cluster-creation |
| error deleting security group | exception | error | openstack, neutron, security-group, deletion-failed |
| error marshaling to yaml | exception | error | go, yaml, serialization, kubemanifest |
| error resizing Akamai (Linode) volume | exception | error | linode, storage, resize, api-error, kops |
| incorrect Audience | exception | error | go, authentication, pki, replay-attack, bootstrap |
| creating aws IPAM controller | exception | error | aws, ipam, controller-runtime, startup |
| expected an AWS cloud, got %T | exception | error | aws, karpenter, type-assertion, cloud-provider |
| found subnets of different types | validation | error | kops, subnets, instance-group, topology |
| invalid base channel location | exception | error | kops, channel, url-parsing, configuration |
| listing public ip addresses | exception | error | azure, networking, pagination, error-wrapping |
| error listing secrets for mirror | exception | error | vfs, secrets, storage, mirror |
| error listing ServiceAccount | exception | error | gce, iam, service-account, api-error |
| fetching | exception | error | network, registry, container-image, authentication |
| found multiple ElasticIPs for | exception | error | aws, ec2, elastic-ip, ambiguous-state |
| Secret not found | exception | error | kops, secrets, not-found |
| unknown group type for group | exception | error | configuration, instance-group, role, rolling-update |
| creating/updating disk | exception | error | azure, disk, arm-api, cloud-provider |
| error computing key fingerprint for SSH key | exception | error | |
| error listing Akamai (Linode) interfaces for instance | exception | error | linode, api, networking, reconciliation |
| error setting clientConnection.kubeconfig in kube-scheduler… | exception | error | kube-scheduler, unstructured, componentconfig, manifest-validation |
| encoding resources for | exception | error | filesystem, dump, io, kops |
| error marshaling json | exception | error | json, serialization, cache |
| error reading | exception | error | aws, s3, network, io, streaming |
| error writing | exception | error | |
| found cert in store, but did not find private key | exception | error | pki, keystore, corrupt-state, tls |
| loadbalancer has gone into ERROR state | exception | error | openstack, octavia, loadbalancer, kops |
| spotinst: failed to create ocean | exception | error | spotinst, aws, cluster-provisioning, api-error |
| error creating pod log dumper | error_code | error | cli, kubernetes, kubeconfig, dump |