kubernetes/kops

Documented errors, page 28 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
error creating InternetGateway
exception error aws, ec2, internet-gateway, iam, api-error
error creating PersistentVolume
error_code error aws, ec2, ebs, volume-creation
error deleting Keyset
exception error
error getting HTTPHealthCheck
exception error
error listing Akamai (Linode) volumes
exception error linode, akamai, api-listing, volumes
error registering kops control-plane cluster API
exception critical cluster-api, scheme, startup, dependencies
error suspending processes
exception error aws, autoscaling, scaling-processes
found virtual network without properties
exception error
GetFloatingIP: fetching floating IP
exception error
instance group deletion is not yet implemented for Akamai…
exception error linode, akamai, instancegroup, unimplemented
instance group not found
exception error instance-group, not-found, configuration
listing NLBs
exception error aws, nlb, pagination, api-error
method metal.Cloud::DetachInstance not implemented
exception error
must specify name of keyset to add keypair to
validation error cli, args, validation
parsing ConfigStore.Base
exception error
providerID not set for node
exception error scaleway, node-identity, providerid
timed out waiting for a successful response from…
exception error
attested document nonce mismatch: got=
validation error
can only edit one instance group at a time
validation error
cluster Watch not implemented for vfs store
exception error vfs, unimplemented, watch, clientset
error cleaning up old records
exception error
error creating Healthcheck
exception error gce, http-health-check, create, cloud-api
error creating VPC
exception error aws, ec2, vpc, quota, cidr
error decoding SSH public key
exception error ssh, base64, key-parsing
error deleting Akamai (Linode) VPC
exception error linode, akamai, vpc, delete, api-error
error listing Disks
exception error
error listing files in state store
exception error
error listing Health Checks
exception error gce, health-check, reconciliation, cloud-api
error waiting for backend service
exception error
evictionSoft
exception error kubelet, eviction, config-parsing
expected slice, got %T
exception error reflection, api-misuse, programming-error
getting local IP from metadata is not supported for cloud…
exception error cloud-provider, unsupported-operation, nodeup, metadata
GroupName is required
console error cli, instancegroup, validation
listing application security groups
exception error
Multiple load balancers for name
exception error
must specify name of keyset to trust keypair in
exception error cli, validation, arguments
no certificate provided
validation error pki, keyset, validation
parsing certificate
exception error
unable decode the configuration file
exception error cli, yaml, parsing
unhandled instanceGroup role
exception error instancegroup, role, labels, config
unknown authorization mode
validation error authorization, rbac, validation
unknown write option
exception error vfs, api-misuse, programming-error
unsupported public key type for service-account: %T
exception error
cannot parse KubernetesVersion
exception error semver, validation, kubernetes-version
ErrAlreadyExists
node already exists
error_code error aws, autoscaling, instance-group, naming
error creating Disk
exception error
Error fetching vpcUUID from network cidr=
error_code error
error listing Akamai (Linode) VPC Subnets
exception error linode, akamai, subnet, api-error, vpc
error listing instance groups
exception error
error listing subnets in VPC
exception error aws, ec2, subnet, iam, api-error
error removing file/marker versions
exception error aws, s3, versioning, batch-delete, iam
error untagging IAMInstanceProfile
exception error aws, iam, tags, instance-profile
failed to delete
exception error delete, prune, finalizer, kubernetes
failed to detach volume
exception error digitalocean, volume, storage
failed to fetch instances
exception error
failed to list L3 floating ip
exception error
found multiple VPCs matching tags
exception error aws, vpc, duplicate-resources, tag-collision
incorrect account
validation error
must specify name of keyset promote keypair in
validation error cli, argument-validation, keypair
network load balancers do not support modifying address…
exception error
spotinst: failed to find ocean
exception error spotinst, ocean, api-error
calling IAM GetRole on
exception error
creating/updating application security group
exception error
determining cluster name
exception error
error creating a ServiceClient
exception error
error creating EventBridge rule
exception error aws, eventbridge, create
error creating Healthcheck
exception error gce, http-health-check, operation, async-wait
error creating tags on
exception error
error deleting Akamai (Linode) instance
exception error linode, akamai, api-error, instance-deletion
error deleting ELB LoadBalancer
exception error aws, elbv2, load-balancer, deletion
error listing DHCPOptions
error_code error aws, ec2, dhcp-options, api-error
expected VirtualMachineScaleSetVM, got %T
exception error
failed to build cloud instance group for instance group
exception error hetzner, groups, instances, state-drift
failed to convert provider ID number
validation error digitalocean, provider-id, parsing, strconv
failed to delete ssh key
exception error
failed to find domain for cluster
exception error digitalocean, dns, configuration
Failed to get storage availability zone
exception error
failed to initialize the ingress controller, error
console error dns-controller, kubernetes, ingress, initialization
failed to stop server
exception error hetzner, api, server, shutdown
fetching vpcUUID from network cidr=
error_code error
Invalud URL for file
exception error url, download, validation
SSH key not found in Akamai (Linode)
exception error ssh, linode, lookup
Subnet with name not found
exception error
the sha value in does not match calculated value
exception error
unmarshalling attested data
exception error
unrecognized certificate option
validation error pki, certificate, configuration
unsupported architecture for instance type
exception error aws, architecture, instance-type
error listing NatGateway
exception error aws, ec2, api-error, natgateway
error parsing network cidr
validation error cidr, network, validation
failed to create the dockerconfig secret as it already…
console error
failed to find network interfaces matching
exception error
failed to parse manifest
exception error manifest, yaml, parsing, addons, kops
finding load-balancers
exception error
found multiple ASG Lifecycle Hooks with the same name
validation error aws, autoscaling, lifecycle-hook, duplicate-resource
found multiple RouteTables matching ID
exception error aws, ec2, routetable, invariant
InstanceGroup name is missing
validation error configuration, instance-group, validation
reading primary MAC address from ec2 metadata
exception error aws, imds, io, network
spotinst: failed to find elastigroup
exception error spotinst, aws, api, authentication
unhandled load-balancer type
exception error
cannot connect to SSH agent; SSH_AUTH_SOCK env variable not…
exception error ssh, ssh-agent, environment