kubernetes/kops

Documented errors, page 25 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
method DeleteCluster not supported in server-side client
exception error go, unsupported-operation, kops, destructive-operation
spec.PublicKey is required
validation error kops, sshcredential, validation, manifest
unknown load balancer type
validation error
apiserver nodes requires the APIServerNodes feature flag to…
exception error feature-flag, apiserver, instance-group, kops
cannot distrust the primary keypair
exception error
error building instance task for
exception error
error creating Network
exception error
error deleting IAMRolePolicy
exception error aws, iam, delete-policy
error deleting record
exception error
error deleting TargetPool
exception error
error finding launch template by ID
exception error
error parsing key from
exception error
failed to add cilium addon
exception error cilium, networking, addons, kops
failed to get updates
exception error addons, versioning, kubernetes-api
failed to list dns zones
exception error openstack, designate, dns, api-error, auth
getting server IP
exception error
HCLOUD_TOKEN is required
error_code error
load balancer has no LoadBalancerName
validation error aws, autoscaling, loadbalancer, nil-pointer
method metal.Cloud::DeleteGroup not implemented
exception error
NewLBListenerTaskFromCloud: Failed to create new LBListener…
exception error openstack, octavia, loadbalancer, find
reading key
exception error
unable to convert CIDR subnet net num to int
exception error network, cidr, parsing, ipv6, hex
unable to remap crictl binaries asset
exception error
unknown asset format
validation error
AssociatedRouteTable not provided
validation error aws, nat-gateway, shared, config
error building subnets
exception error aws, subnets, spotinst, networking
error creating Akamai (Linode) Subnet
exception error linode, akamai, subnet, api-error, cidr
error deleting instance
exception error cloud, delete, rolling-update, instance
error fetching KopsControlPlane
exception error
error listing autoscaling groups
exception error
error listing IAM role policies
exception error aws, iam, pagination, api-error
error loading certificate
console error certificate, pem, parsing
error querying instance metadata
exception error
error reading SSHCredential
exception error kubernetes, ssh, rbac, api-server
error updating object
exception error kubernetes, update, conflict
failed to delete volume
exception error
failed to get networks matching label selector
exception error hetzner, network, cloud-api
image must be ami-*, ssm: , , or /
validation error karpenter, aws, validation, image-format
incorrect SHA
validation error
instance not found while waiting for instance to be running
exception error
instanceGroup already exists
exception error kops, cli, instancegroup, already-exists
listing InstanceGroups
exception error cli, instancegroup, api
reading body
exception error network, http-body, io
SSH public key must be specified when running with…
validation error
deleting VMSS VM
exception error
error deleting ELB TargetGroup
exception error aws, elbv2, deletion, target-group
error deleting ngw
exception error aws, ec2, nat-gateway, deletion
error listing Akamai (Linode) instances
exception error linode, akamai, api-listing, authentication
error listing FirewallRules
exception error
error parsing addons or manifest
exception error yaml, parsing, manifest
error populating configuration
error_code error cloud, configuration, aws
error reading kubeconfig
exception error
error reading user provided cert
console error file-io, certificate, cli
failed to determine VPC id of subnet
exception error
failed to extract dns recordsets pages
exception error
failed to get load balancers matching label selector
exception error hetzner, api, loadbalancer, network
failed to load default aws config for IMDS client
exception error aws, route53, config
invalid google cloud storage path
validation error gcs, url-parsing, vfs, validation
loadbalancer API versions not found
exception error openstack, octavia, loadbalancer, api-version
secret name is required
validation error cli, secrets, validation
Subnet has configured Zone , but the actual Zone found was
exception error subnet, zones, aws, config-validation
taints
exception error kubelet, taints, config-parsing
ca key for was not found; cannot issue certificates
exception critical pki, ca, keystore, missing-key
client certificate missing Common Name
console error mtls, certificate, common-name, identity
could not get existing object
exception error kubernetes, get, not-found
DetachInstance is not implemented yet for Scaleway
exception error
Error adding user data bytes to terraform resource
error_code error
error building kube-apiserver manifest
exception error
error creating RouteTable
exception error aws, ec2, routetable, infrastructure
error creating VPCDHCPOptionsAssociation
exception error aws, ec2, dhcp, vpc, api-error
error deleting VPC
exception error
error listing IAM OIDC Providers
exception error aws, iam, oidc
error parsing
exception error vfs, parsing, codec, corrupt-state
expected v1.Pod object in manifest
exception error kops, etcd-manager, manifest, type-mismatch
found multiple RouteTables attached to subnet
exception error aws, route-table, subnet, conflict
found subnet without properties
exception error
promoting keypairs for
exception error cli, validation, keyset, keypair
spotinst: failed to update elastigroup
exception error spotinst, aws, api, update
unable to execute --dry-run without setting --output
exception error cli, validation, dry-run
unmarshalling authorization token
exception error
cannot parse SecretStore
exception critical go, vfs, secrets, cli-options
cannot use both --all flag and positional arguments
validation error cli, flags, kubeconfig
ClusterName is missing
exception error configuration, cluster, validation
could not find Scaleway profile
exception error
Could not find Server with id
exception error
encryptionConfig enabled, but could not load…
exception error
error listing ForwardingRules
exception error
error storing keyset
exception error
Failed to update security group for port
exception error openstack, security-group, neutron, permissions
kubernetes feature gate must include a feature name
validation error
must specify at least one zone for the cluster (use --zones)
validation error zones, cli, validation
received status code
exception error
Scaleway clusters don't have a VPC yet, so internal…
exception error
spotinst: failed to find ocean
exception error spotinst, ocean, not-found
unable to decode addresses
exception error
unable to find instance in compute API
error_code error gcp, compute-api, authentication, not-found
unable to parse Scaleway zone
exception error
unknown etcd cluster key
validation error kops, etcd-manager, naming, cluster-spec
cannot build kubernetes api client for
exception error
cannot set value
exception error go, reflection, immutable-field