hashicorp/nomad
Documented errors, page 18 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| ; key header for key ID must be | validation | error | nomad, acl, oidc, jwt, validation |
| work_dir must be an absolute path | validation | error | rawexec, paths, config-validation, nomad |
| controller delete snapshot | exception | error | csi, nomad, snapshot, rpc-forwarding |
| error opening fifo parent directory | error_code | error | linux, fifo, filesystem, logging |
| error parsing 'vault | validation | error | hcl, config-parsing, vault |
ErrPoolExhausted users: uid/gid pool exhausted | error_code | error | go, resource-exhaustion, nomad, pool |
| failed to parse policy | validation | error | acl, hcl, syntax-error, consul |
| failed to read plugin state | exception | error | devicemanager, state-store, startup |
| filesystem_isolation_extra_paths contains invalid lockdown… | validation | error | config, validation, landlock, paths |
| Invalid sentinel capability | validation | error | nomad, acl, capability-validation, sentinel, enterprise |
| missing node pool name | validation | error | nomad, hcl, quota, node-pool |
| mounting volumes | error_code | error | csi, storage, mount, nomad |
| must provide task name | validation | warning | api, validation, logs, exec |
| Only cron or crons may be used | validation | error | nomad, periodic-job, validation |
| post-run hook failed | exception | error | nomad, client, hooks, postrun, cleanup |
| root key ID must match key file | console | critical | keyring, keystore, key-rotation, go |
| scaling_policy lookup failed | exception | error | nomad, state-store, scaling-policy, lookup |
| unsupported transport | exception | error | |
| used group network mode | validation | error | nomad, namespace, network-mode, job-validation |
| can not delete default namespace | validation | error | nomad, namespace-delete, protected-resource |
| error validating | exception | error | oidc, client-assertion, rsa, key-validation, corruption |
| Failed to create container configuration, cannot use… | validation | error | docker, windows, isolation, portability |
| job delete failed | exception | error | state-store, raft, delete |
| Malformed soft ulimit | validation | error | docker, ulimit, config-validation |
| maximum of ports can be reserved | validation | error | nomad, ports, validation |
| node ids missing | error_code | error | nomad, state-store, input-validation, node-deregistration |
| unable to determine remaining read limit | exception | error | nomad, client, logs, streaming, internal |
| unsupported scheme | exception | error | websocket, url, configuration, nomad-api |
| ack.Error | exception | error | go, rpc, network |
| eventlog.level must be one of INFO, WARN, or ERROR | validation | error | config-validation, windows, eventlog, logging |
| exchanged token is not valid; potentially expired or empty | exception | error | oidc, token, expiry, acl |
| failed creating runner for task | exception | error | task-runner, driver, configuration, alloc-runner |
| failed to fetch first index | exception | error | raft, boltdb, corruption, go |
| failed to stream | exception | error | nomad, client, logs, streaming, io |
| Identifier must contain at least two characters. | validation | error | cli, identifier, argument-validation |
| StreamFramer not running | exception | error | streaming, lifecycle, logging, goroutines |
| unknown nomad server | exception | error | nomad, rpc, server-membership, routing |
| ws_handshake value is not a boolean | validation | error | websocket, query-param, validation, go |
| attempting to upsert allocation | exception | error | nomad, alloc, validation |
| can only use change_signal= | validation | error | nomad, workload-identity, validation, config |
| controller list snapshots | exception | error | csi, nomad, snapshot, rpc-forwarding |
| CSI.ControllerCreateVolume | exception | error | csi, plugin, retryable, create-volume |
| Error formatting CSI volume | console | error | nomad-cli, csi, formatting |
| error looking up user | exception | error | unix, user-lookup, os, permissions |
| existing BoltDB raft store found at | exception | error | storage, raft, upgrade, nomad |
| failed to create file | exception | error | filesystem, file-create, permissions, debug |
| failed to find system jobs for | exception | critical | nomad, state-store, system-jobs, internal |
| failed to get free disk space for | exception | error | windows, filesystem, disk-space, fingerprinting |
| failed to open plugin directory | exception | error | go, filesystem, plugin-dir, permissions, nomad |
| failed to retrieve the ID token claims | exception | error | oidc, jwt, claims, nomad |
| failed to write Raft version file | exception | error | filesystem, storage, nomad |
| invalid websocket connection in context | console | error | websocket, context, type-safety, go |
| job_default_priority cannot be | validation | error | nomad, jobs, config, validation |
| job_max_priority cannot be | validation | error | nomad, jobs, config, validation |
| modifying node pool is not allowed | validation | error | nomad, state-store, node-pool, immutable-resource |
| no network_interface given and failed to determine… | exception | error | network, routing, fingerprinting |
| No such allocation on client, or allocation not eligible… | exception | error | |
| timed out waiting for re-run of leader actions | http | error | leadership, timeout, raft, snapshot |
| unable to get validation keys from OIDC provider | exception | error | oidc, jwt, discovery, network, tls |
| ACL binding rule deletion failed | exception | error | nomad, state-store, acl, delete |
| acl token lookup failed: missing secret id | exception | error | nomad, state-store, acl, input-validation |
| cannot destroy running task | exception | error | nomad, java-driver, task-destroy, lifecycle, guard |
| / signing request was rejected | exception | error | workload-identity, rpc, rejection, nomad |
| failed creating temporary directory for the StateDir | exception | error | filesystem, temp-dir, initialization |
| failed to get job | exception | error | nomad, scheduler, state-store |
| failed to initialize HTTP server TLS configuration | exception | critical | tls, configuration, certificates, nomad |
| failed to lookup evals | exception | warning | nomad, state-store, memdb, garbage-collection |
| invalid capacity_max | console | error | hcl, csi, validation, nomad-cli |
| invalid source, must be "" for tmpfs | validation | error | docker, mount, tmpfs, validation |
| pull_activity_timeout is less than minimum | validation | error | docker, duration, config, nomad |
| Service kind must be one of consul service kind or empty | validation | error | nomad, consul, service-kind, validation |
| Unknown affinity operator | validation | error | nomad, affinity, job-spec, validation |
| using env=%t without change_mode= | validation | warning | nomad, workload-identity, env-vars, rotation |
| volumes are not enabled; cannot mount volume | validation | error | docker, nomad, volumes, security-sandbox |
| check type %+q not valid | validation | error | consul, service-check, validation |
| consul tokens for cluster | exception | error | consul, workload-identity, tokens, nomad-client |
| Distinct Property must have an allowed count of 1 or greater | validation | error | nomad, constraint, distinct-property, job-validation |
| failed creating alloc dir | exception | critical | client-init, filesystem, permissions, directory |
| failed to create result paginator | error_code | error | pagination, filtering, rpc, nomad |
| Failed to retrieve evaluations for job | exception | error | nomad, api, evaluation, polling, network |
| given no jobs to deregister | validation | warning | nomad, validation, batch, empty-input |
| invalid address_mode | validation | error | nomad, service-check, address-mode, config-validation |
| Invalid job type | validation | error | nomad, job, validation, jobspec |
| invalid volume specification | validation | error | docker, volumes, windows, parsing |
| network address family must be one of | validation | error | nomad, node, network, validation, enum |
| no more logs | exception | info | raft, sentinel-error, go |
| Plugin.Type must not be empty | validation | error | dynamic-plugins, validation, nomad, csi |
| does not meet systemd conventions | validation | error | |
| Secret is invalid | validation | error | nomad, secrets, validation |
| server_join and retry_join cannot both be defined; prefer… | validation | error | nomad, configuration, validation, deprecated-fields |
| telemetry in-memory collection interval cannot be greater… | validation | error | config-validation, telemetry, consistency, duration |
| unable to update preserved values | exception | error | nomad, state-store, multiregion |
| unknown Nomad server | exception | error | nomad, rpc, serf, membership, cluster |
| used task drivers are not allowed in namespace | validation | error | nomad, namespace, driver-policy, job-validation |
| Connect only supported with exactly 1 network | validation | error | consul, connect, networking, nomad |
| expected map/object cty value, got %T | validation | error | cty, type-assertion, go |
| Failed to parse Serf address | validation | error | config, network, bind-address, serf |
| Failed to read var file(s) | exception | error | jobspec, parsing, files, variables |
| failed to scan plugin directory | exception | error | go, filesystem, permissions, plugins |
| group must be set to set task | validation | error | acl, validation, job-acl |