hashicorp/nomad
Documented errors, page 20 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to attach to exec object | exception | error | docker-driver, exec, stream-attach |
| failed to create deployment watcher | exception | critical | startup, deployment-watcher, server |
| failed to insert job into job_version table | exception | error | nomad, state-store, job-versions, insert |
| Hostname is not a valid DNS name | validation | error | nomad, service-discovery, config-validation |
| identities without an audience are insecure | validation | warning | nomad, workload-identity, security, jwt |
| scaling policy lookup failed | exception | error | nomad, state-store, scaling-policy, prefix-lookup |
| Set contains operators require an RTarget | validation | error | nomad, affinity, missing-value, job-validation |
| task not found | exception | error | nomad, client, driver, task-not-found |
| unknown service registration provider | validation | error | nomad, service-registration, invalid-enum, provider |
| VerifyIncoming set, and no Cert/Key pair provided! | exception | error | tls, mtls, certificate |
| alloc id must be set | validation | error | nomad, task-scheduling, validation, required-field |
| cannot remove existing nomad binary install | exception | error | go, windows, filesystem, file-locked |
| cannot use custom advertise address with | validation | error | |
| CSIPluginConfig PluginType must be one of 'node'… | validation | error | nomad, csi, validation, jobspec |
| envoy must be configured with a service name | validation | error | |
| failed to hcl parse the config | exception | error | hcl, config, parsing, device |
| Failed to open current namespace | exception | error | linux, network-namespace, procfs, initialization |
| failed to restore from snapshot | http | critical | raft, snapshot, restore, state-store |
| failed to start HTTP listener | exception | critical | network, tcp-listener, port-in-use, nomad |
| file is a directory | http | error | nomad, client, filesystem, bad-request, path |
| json format does not support template option. | validation | error | cli, json, template |
| missing target job | validation | error | nomad, scaling-policy, target, validation |
| Missing tasks for task group | validation | error | nomad, job-validation, invalid-duration-value |
| node update failed | exception | error | nomad, state-store, storage, node-events, write-failure |
| QEMU graceful shutdown is unsupported on the Windows… | exception | error | nomad, qemu, windows, platform-limitation, graceful-shutdown |
| unsupported TLS cipher | validation | error | tls, ciphersuite, configuration |
| cannot update a volume in use: claimed by allocs | validation | error | nomad, validation, host-volume, volume-in-use |
| csi_plugins insert error | exception | error | nomad, csi, state-store, memdb |
| deployment is terminal | console | error | nomad, deployment, lifecycle |
| error parsing GCSTimeout | validation | error | config, parsing, duration, go |
| failed to find nomad binary | panic | error | panic, testing, path |
| failed to sign node identity claims | exception | error | nomad, jwt, keyring, node-identity |
| Invalid node policy: %#v | validation | error | nomad, acl, policy-validation, node |
| launch not found | exception | error | nomad, state-store, periodic-job, not-found |
| missing node secret ID for client registration | validation | critical | nomad, rpc, validation, auth |
| no auth method config or client assertion | exception | error | oidc, jwt, authentication, configuration, nomad |
| Raft error when restoring snapshot | exception | error | raft, consensus, snapshot-restore, fsm |
| timed out waiting to re-run leader actions | http | error | leadership, raft, timeout, snapshot |
| users: unable to parse uid/gid from username | exception | warning | go, parsing, nomad, users |
| deleting scaling policy failed | exception | error | nomad, state-store, scaling-policies, job-deletion |
| failed to get ready nodes | exception | error | nomad, scheduler, sysbatch, nodes, state-store |
| failed to initialize process manager | exception | error | client, process-management, initialization |
| invalid client assertion config | validation | error | acl, oidc, validation, nomad |
| Invalid event hook given | validation | error | |
| job version not found | validation | error | nomad, state-store, job-versions, not-found |
| job submission lookup failed | exception | error | nomad, state-store, job-submission |
| malformed port map | validation | error | nomad, mock-driver, config, port-mapping |
| must provide peer id or address | http | error | nomad, raft, api-validation, leader-election |
| raft_protocol must be 3 in Nomad v1.4 and later, got | validation | error | nomad, raft, config, upgrade |
| 0: job already exists | validation | error | nomad, job-register, enforce-index, cas |
| service.port must be set for mesh gateway service | validation | error | nomad, consul-connect, mesh-gateway, job-validation |
| stdin is not supported | exception | error | cli, stdin, configuration |
| unable to verify signature of JWT token | exception | error | auth, jwt, signature-verification |
| unexpected NotBeforeLeeway type | validation | error | json, unmarshal, acl, consul-api |
| Unknown constraint type | validation | error | nomad, constraint, unknown-operator, job-validation |
| acl token lookup failed: missing accessor id | exception | error | nomad, state-store, acl, input-validation |
| can't evaluate parameterized job | validation | error | nomad, parameterized-job, unsupported-operation |
| Couldn't open src file | exception | error | filesystem, file-copy, permissions |
| csi_plugins delete error | exception | error | nomad, csi, state-store, garbage-collection |
| device failed validation | validation | error | |
| device vendor must be specified | validation | error | devices, validation, plugin |
| error removing existing file | exception | error | nomad, filesystem, file-extraction, permissions |
| error syncing dynamic node metadata | exception | error | nomad-client, state-db, disk |
| Failed to chown task mount directory | exception | error | permissions, chown, nomad-client |
| http_max_conns_per_client must be >= 0 | validation | error | configuration, validation, limits, nomad |
| invalid capability | console | error | hcl, nomad, csi, validation |
| node setup failed | exception | critical | client, node, state-store |
| one of launch command or reattach config must be specified | exception | error | plugin-loader, argument-validation, reattach, nomad |
| service cannot use address_mode="driver", only services… | validation | error | nomad, service, address-mode, validation |
| ttl must be >= 0 | validation | error | nomad, workload-identity, validation, ttl |
| unable to update job recommendations | exception | error | nomad, state-store, recommendations |
| binary does not exist | exception | error | filesystem, launch, path |
| bind name is missing | validation | error | nomad, acl, binding-rule, config-validation |
| both -n and -c set | validation | error | cli, flags, logs, argument-validation |
| cannot create data directory | exception | error | windows, data-dir, permissions |
| check is duplicate | validation | error | nomad, health-check, duplicate, service-validation |
| could not configure cipher | console | error | encryption, aes-gcm, kms, key-length |
| CSI.ControllerDetachVolume: VolumeID is required | validation | error | csi, validation, nomad, storage |
| -dev-connect uses network namespaces and is only supported… | validation | error | linux, permissions, root, dev-connect |
| failed to retrieve allocation bucket | exception | error | |
| HealthyDeadline is and must be >= 0 | validation | error | nomad, go, validation, migrate-strategy, duration |
| job ID must be set to set group | validation | error | acl, validation, job-acl |
| job is in nonexistent node pool | validation | error | nomad, node-pool, job-validation |
| maximum attempts reached | exception | error | |
| nil factory passed for internal plugin | validation | error | go, configuration, plugins, factory |
| nil vault config | exception | error | vault, config, nil-pointer, nomad |
| service install failed | exception | error | windows, service-control-manager, installation |
| Task group count can't be negative | validation | error | nomad, job-validation, missing-field |
| Enterprise only | exception | error | nomad, enterprise, feature-gate, task-pause |
errMismatchChecksum mismatch checksum | error_code | error | |
| expected 1 argument, got | validation | error | cli, argument-validation, evals |
| failed to change directory permissions for the AllocDir | exception | critical | client-init, permissions, chmod, filesystem |
| invalid change_mode | validation | error | nomad, workload-identity, validation, enum-value |
| invalid user ID | validation | error | validation, connect, uid |
| missing name | validation | error | nomad, host-volume, validation, required-field |
| Must specify a destination for the template | validation | error | nomad, template, job-spec-validation |
| Only one task may be marked as leader | validation | error | nomad, job-validation, leader-task |
| root key UUID is required | validation | error | nomad, keyring, root-key, uuid-validation |
| : job does not exist | validation | error | nomad, job-register, enforce-index, cas |
| set_environment_variables must be set | validation | error | config, validation, nomad-agent |