hashicorp/nomad
Documented errors, page 16 of 29. Back to hashicorp/nomad
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| CSI.ControllerAttachVolume | exception | error | csi, plugin, retryable, attach |
| Duplicate key in passed metadata | validation | warning | nomad, api, metadata, validation |
| failed creating state dir | exception | error | filesystem, state-dir, initialization |
| failed to set clone_children on nomad cpuset cgroup | error_code | critical | cgroups, cpuset, client-startup, permissions |
| failed to write snapshot metadata | exception | error | tar, io, disk |
| Invalid node pool capability | validation | error | nomad, acl, node-pool, capabilities |
| Invalid node pool policy | validation | error | nomad, acl, node-pool, policy-validation |
| invalid variables limit | validation | error | hcl, quota, validation, variables, nomad |
| job not found | exception | error | state-store, job, deregistration |
| missing client nonce | validation | error | nomad, acl, oidc, validation, nonce |
| Missing spread attribute | validation | error | nomad, spread, scheduling, validation |
| must specify cron block | validation | error | nomad, validation, cron, scheduling |
| path exists and is not directory | exception | error | windows, filesystem, directory, path-conflict |
| timed out waiting for script checks to exit | exception | warning | nomad, script-check, consul, shutdown-timeout, goroutine |
| unsupported signal type | exception | error | signal, grpc, type-assertion |
| CSI.ControllerAttachVolume | exception | error | csi, validation, attach, request-conversion |
| error moving data dir | exception | error | filesystem, rename, allocation-migration, exdev |
| failed to configure network manager | exception | critical | nomad, client, network, cni |
| failed to get docker client | exception | error | docker, client-init, daemon-connection, nomad-driver |
| failed to list entries | exception | error | nomad, client, logs, filesystem, io |
| failed to parse `df` output; expected at least 2 lines | exception | error | filesystem, df, parsing, fingerprinting |
| failed to parse ipv6_address | validation | error | docker, nomad, ipv6, config-validation |
| failed to remove alloc dir | exception | error | filesystem, cleanup, nomad-client |
| failed to restore state | exception | critical | client, state-store, restore |
| failed to write root partition cpuset | error_code | error | linux, cgroups, cgroupv2, cpuset |
| job_submission requires a jobID | validation | error | nomad, state-store, job-submission, validation |
| keyring is not ready - waiting for keys | exception | warning | keyring, kms, transient, retry |
| ACL auth method lookup failed | exception | error | nomad, state-store, acl, lookup |
| ACL role insert failed | exception | error | nomad, state-store, memdb, acl |
| Affinity weight must be within the range [-100,100] | validation | error | nomad, affinity, weight, job-spec, validation |
| bandwidth exceeded | validation | error | nomad, bandwidth, network, deprecated-api |
| binary could not be found | exception | error | exec, path, launch |
| both launch command and reattach config specified | exception | error | plugin-loader, argument-validation, reattach, nomad |
| cannot apply configuration | validation | error | docker-driver, config-validation, namespace |
| cannot generate data path | exception | error | windows, data-dir, path |
| client_introduction.max_identity_ttl must be greater than… | validation | error | config-validation, ttl, consistency, client-introduction |
| could not delete service | exception | error | go, windows, service-control-manager, service-delete |
| expiration time cannot be less than | validation | error | acl, token, validation, ttl, expiration |
| failed to configure keyring | exception | critical | nomad, server, gossip, encryption, keyring |
| invalid artifact config | validation | error | nomad, config-validation, artifact |
| missing plugin ID | validation | error | validation, csi, nomad, missing-parameter |
| rpc_handshake_timeout must be >= 0 | validation | error | config, validation, nomad |
| client token missing policies or roles | validation | error | nomad, acl, token, validation |
| Constraint has disallowed Operand at task level | validation | error | nomad, validation, constraints, placement |
| controller create snapshot | exception | error | csi, nomad, snapshot, rpc-forwarding |
| csi_plugins lookup error | exception | error | nomad, csi, state-store, memdb |
ErrDriverNotFound driver not found | error_code | error | nomad, plugin, driver, catalog, sentinel-error |
| failed to initialize network configurator | exception | critical | nomad, client, network, cni, configuration |
| failed to query AWS metadata | exception | warning | aws, imds, network |
| failed to rewind snapshot | exception | error | filesystem, io, seek, snapshot |
| failed to sync snapshot | exception | error | filesystem, fsync, io, snapshot |
| Failed to unmount proc | exception | warning | linux, mount, proc, teardown |
| http_max_size must be < | validation | error | config, validation, overflow, nomad |
| job in namespace not found | exception | error | nomad, rpc, plan, state-store, race-condition |
| mbits has been deprecated as of Nomad 0.12.0. Please remove… | validation | warning | nomad, deprecation, network |
| Must specify signal value when change mode is signal | validation | error | nomad, template, signals, job-spec-validation |
| no addresses available for | validation | error | nomad, network, host-network, scheduling |
| socket path is longer than the maximum length allowed ( )… | exception | error | qemu, socket, path-length, unix-socket, nomad-driver |
| unable to convert user's group | exception | error | unix, groups, parsing |
| UpsertJob failed | exception | error | nomad, raft, fsm, state-store |
| cannot update expiration time | validation | error | nomad, acl, validation, immutable-field |
| could not copy file | exception | error | filesystem, disk-full, io, copy |
| dynamic_user_max must be set | validation | error | nomad, agent-config, validation |
| error cmd must have at least one value | validation | error | nomad, java-driver, exec-task, input-validation, argument-error |
| error deleting volume | error_code | error | host-volumes, external-plugin, process-execution |
| error encoding private key | exception | error | tls, pem, encoding |
| failed to create stdout | exception | error | fifo, stdout, streaming, nomad-executor |
| Failed to inspect container | error_code | warning | docker, nomad, race-condition, recoverable |
| Failed to parse auth config file | exception | error | docker, auth, json-parse, config-file |
| failed to resize tty | exception | warning | tty, resize, stdin, nomad-executor |
| getting job scaling policies for deletion failed | exception | error | nomad, state-store, scaling-policies, job-deletion |
| invalid docker volume | validation | error | docker, volumes, config-parsing |
| missing required Meta object | validation | error | nomad, validation, node-metadata, api |
| with input failed with stderr | exception | error | docker, credential-helper, subprocess, registry-auth |
| unable to start validator | exception | error | nomad, exec-driver, configuration, validator |
| couldn't be converted to boolean value | console | error | hcl, nomad, boolean, type-error |
| client_introduction.max_identity_ttl must be greater one | validation | error | config-validation, ttl, client-introduction |
| controller publish | exception | error | csi, controller, publish |
| decompression_file_count_limit must not be nil | validation | error | nomad, config-validation, missing-field, decompression |
| DeleteJob failed | exception | error | nomad, raft, fsm, job-purge |
| failed to create alloc/logs/envoy_bootstrap.stderr.0 for… | exception | error | go, filesystem, nomad, envoy, file-create |
| Failed to start Raft | exception | critical | nomad, go, raft, consensus, startup |
| File not found in path | exception | error | raft, filesystem, paths, not-found |
| need an executable to run | exception | error | cli, exec, nomad, arguments |
| policy lookup failed | exception | error | nomad, acl, state-store, memdb |
| can't parse time duration | validation | error | config-parsing, duration, go |
| Task has warnings | validation | warning | nomad, task, warnings |
| volume in use by allocations | validation | error | nomad, host-volumes, resource-in-use, delete, allocations |
| cannot create configuration directory | exception | error | windows, directory, permissions |
| cannot install new nomad binary | exception | error | go, windows, filesystem, rename |
| failed creating alloc mounts dir | exception | critical | client-init, filesystem, permissions, directory |
| failed to create OIDC request | exception | error | oidc, request-validation, nomad, config |
| Failed to create redacted snapshot | exception | error | raft, snapshot, fsm, go |
| failed to find allocs for | exception | critical | nomad, state-store, allocations, internal |
| failed to inspect container for id | exception | error | docker, container-missing, task-recovery, state |
| job is in nonexistent namespace | validation | error | nomad, namespace, job-validation, state-store |
| not implemented | panic | critical | unimplemented, platform-specific, mount, linux |
| oom_score_adj must not be negative | validation | error | rawexec, oom, config-validation, linux |
| Reading secret file prohibited | exception | error | security, secrets, path-traversal |
| rpc error: shutdown | exception | error | rpc, connection-pool, shutdown |