apache/pulsar
Documented errors, page 4 of 15. Back to apache/pulsar
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unable to delete | exception | error | filesystem, io, file-delete, file-lock |
| unable to parse namespaces parameter list: | validation | error | cli, argument-validation, pulsar-admin |
| You must specify tls-trust-store-type, tls-trust-store and… | validation | error | cli, tls, configuration, validation |
| Failed to get children of | exception | error | metadata-store, zookeeper, timeout, exception-wrapping |
| Invalid broker configuration. Authentication must be… | validation | error | configuration, authentication, authorization, security, startup |
| Namespace name is not valid | http | error | admin-api, validation, namespace, naming |
| No java.security.Provider named | validation | error | java, tls, security-provider, classpath, configuration |
| Update contains no change | http | warning | rest-api, bad-request, pulsar-functions, no-op-update |
| Could not find source config class | validation | error | pulsar-functions, class-not-found, config-validation, classloader |
| Invalid time unit | validation | error | pulsar, time-parsing, illegal-argument, configuration |
| Namespace does not exist | http | error | rest-api, admin, not-found, namespace, subscription |
| No PythonInstanceFile specified | exception | error | pulsar-functions, configuration, missing-env-var, python |
| Unrecognized runtime: | exception | error | enum, runtime, mapping, version-compatibility |
| V1 topic names (with cluster component) are no longer… | validation | error | java, topic-naming, backward-compatibility, v1-migration |
| Configuration field… | validation | error | configuration, transaction, validation |
DOMAIN_MISMATCH Athenz RoleToken Domain mismatch, Expected | exception | error | athenz, authentication, domain-mismatch, authorization |
| Subscription not found | http | error | pulsar, subscription, rest-api |
| Authentication required | http | error | authentication, pulsar, http |
EXPIRED_JWT JWT expired: | exception | error | auth, oidc, jwt, expired-token |
| there are redundant configure for listener | validation | error | configuration, broker-startup, validation, pulsar |
| Unrecognized processing guarantee: | exception | error | enum, processing-guarantees, mapping, version-compatibility |
| Interrupted while resuming auto ledger re-replication | exception | warning | interruption, threading, bookkeeper-replication |
METADATA_SERVICE_ERROR MetadataException | error_code | error | metadata-store, bookkeeper, initialization |
| Outbuffer has not enough space available | validation | error | crypto, aes-gcm, buffer, bytebuffer, argument-validation |
| Found null Audience in token, for claimed field | exception | error | jwt, token, claims |
| Function package is not provided | exception | error | rest, bad-request, missing-package, pulsar-functions |
| does not support this operation | http | warning | pulsar, load-manager, admin-api, http-409 |
| RuntimeException(err) | exception | error | pulsar, admin-api, runtime-exception, streaming-response, offloading |
| Implementation does not comply with… | exception | error | metadata-store, factory, api-compatibility |
| Interrupted at fetching schema info for… | exception | warning | pulsar, schema, interruption, threading |
| java.lang.RuntimeException (wrapping PulsarAdminException… | exception | error | pulsar-functions, status, pulsar-admin, wrapped-exception |
| getTopicNotFoundErrorMessage(topicName.toString()) | http | error | pulsar, rest-api, topic-not-found |
| Key reader class does not have constructor accepts map | exception | error | crypto, reflection, constructor, pulsar-client |
| bindAddresses: ip:port | validation | error | configuration, bind-address, tls, port-conflict |
| Could not import User Function Module | exception | critical | python, pulsar-functions, import-error, deployment |
| Invalid topic name | validation | error | java, topic-naming, parsing |
| Method not implemented! | exception | error | pulsar, authentication, deprecated-api, unsupported-operation |
| Not supported operation on partitioned-topic | exception | error | pulsar-client, message-id, partitioned-topic, illegal-argument |
| the value in the `advertisedListeners` configure is invalid | validation | error | configuration, broker-startup, validation, uri, pulsar |
| You must specify a name for the source | validation | error | pulsar-admin, cli, io-connector, missing-argument |
| Cannot handle messages with null messageIdList | exception | error | pulsar, acknowledgment, null-check, batch |
| Could not instantiate | exception | error | tls, reflection, config, instantiation |
| Didn't find in built-in connectors or functions | exception | error | pulsar-functions, builtin-connector, missing-archive, configuration |
| Entry filter ' ' not found | validation | error | pulsar, entry-filter, configuration, policy-validation |
| Failed to clone ClientConfigurationData | exception | warning | clone, defensive, configuration, unreachable |
| Metrics port need to be within the range of 0 and 65535 | validation | error | configuration, port, validation |
| Rebalance already in progress | http | warning | rest-api, concurrency, functions-worker |
| Rejected legacy package metadata: | exception | error | java, deserialization, serialization, package-management |
| Cannot delete the global namespace | http | error | pulsar, geo-replication, namespace-deletion, precondition |
| Consumer already closed | exception | error | pulsar, consumer, lifecycle, already-closed |
| failed to get client token | exception | error | java, authentication, jwt, token, pulsar-client |
| Invalid MetaValue data, no enough header data. expect | exception | error | rocksdb, deserialization, data-corruption |
| MD5 algorithm not found | exception | error | java, security, crypto, md5 |
| Timeout during close operation | exception | error | configuration, validation, offload, region |
| Unable to list directory content in | exception | error | filesystem, io, directory-listing, cleanup |
| Close interrupted | exception | warning | consumer, close, interrupted |
| Error while parsing ZK protobuf binary data | exception | error | zookeeper, protobuf, data-corruption, bookkeeper, parsing |
| cannot be bigger than < >! | validation | error | cli, validation, argument, pulsar |
| Sink class not found | validation | error | pulsar-functions, sink, classpath, configuration |
| Failed to find ownership for topic | http | error | http-412, topic, ownership, lookup |
| Input topic is invalid | validation | error | pulsar-functions, validation, topic-name, configuration |
| Cron Trigger is not provided with Cron String | validation | error | pulsar-io, configuration, cron, illegalargument |
| Function Package url is not valid.supported url… | validation | error | url-validation, pulsar-functions, illegal-argument |
| Getting consumer is not supported | exception | error | pulsar-functions, consumer, configuration, pulsar-client |
| Log folder creation error | exception | error | pulsar-functions, filesystem, io, runtime |
| Metadata cache implementation | exception | error | test, reflection, metadata-cache, fault-injection |
| Migration is already in progress | exception | error | migration, concurrency, metadata-store, oxia |
| the PulsarTlsFactory on this admin builder's configuration… | exception | error | tls, resource-ownership, illegal-state |
| Unauthorized to validateBothSuperuserAndBrokerOperation for… | http | error | pulsar, authorization, http-401, superuser, admin-api |
| webServicePort/webServicePortTls or http/https… | validation | error | configuration, broker, web-service, ports, startup |
| (wraps abort failure cause message) | exception | error | transaction, abort, pulsar-client, wrapped-exception |
| Authentication method missing | http | error | authentication, pulsar, http, configuration |
| Broker doesn't allow forced deletion of namespaces | http | error | pulsar, configuration, namespace-deletion, force-delete |
| brokerDeleteInactiveTopicsEnabled and… | validation | error | broker, configuration, startup, conflicting-flags, topics |
| domain() invoked from wrong resource | http | error | admin-api, rest, internal-error, url-path |
| Failed to load public key . | exception | error | crypto, pem, key-parsing, encryption, wrapped-exception |
| Namespace does not match policy | exception | error | namespace-isolation, regex-mismatch, lookup |
| Not the leader | exception | error | pulsar-functions, leader-election, state |
| Topic is not partitioned topic | http | error | http-409, partitioned-topic, admin-api |
| Cannot delete the global namespace | http | error | pulsar, geo-replication, bundle, precondition |
| Currently + type.name() + is not supported | exception | error | schema, validation, unsupported-feature, avro |
| --destinationBroker cannot be set when --bundle is not… | validation | error | cli, parameter-validation, pulsar-admin, namespaces |
| Unable to obtain an access token | exception | error | oauth2, authentication, token-endpoint, pulsar-client |
| Unknown producer protobuf failure action | exception | error | enum, crypto, configuration, mapping |
| Unsupported MetadataStoreConfig query parameter | validation | error | configuration, illegal-argument, metadata-store, url |
| Cannot parse encrypted message + msgMetadata + on topic +… | exception | error | encryption, message-parsing, raw-reader, security |
| Executor should have been shutdown before entering the… | exception | error | executor, shutdown, lifecycle |
| javaInstanceRunnable is not initialized | exception | error | pulsar-functions, metrics, lifecycle, thread-runtime |
| Message retries not yet supported in python | validation | error | pulsar-functions, python-runtime, unsupported-feature, configuration |
| Target buffer size is too small | validation | error | crypto, aes-gcm, buffer, decryption, bytebuffer |
| The schema is not a KeyValueSchema | exception | error | pulsar, schema, keyvalue, illegal-state |
| This topic already exists | http | error | http-409, topic-exists, partitioned-topic, admin-api |
| Cannot start the service once it was stopped | exception | error | lifecycle, state-machine, pulsarservice, illegal-restart, broker |
| Class does not implement additional servlet interface | exception | error | plugin, nar, servlet, type-mismatch, pulsar |
| External schema is not compatible with the other schema… | exception | error | pulsar, schema, compatibility |
| Failed to initialize BookKeeper metadata | exception | critical | bookkeeper, zookeeper, metadata, cluster-init |
| Failed to resolve the admin client TLS factory | exception | error | tls, configuration, certificate |
| Kubernetes Secret should contain id and key | validation | error | kubernetes, secrets, validation, pulsar-functions |
| Offload already in progress | exception | warning | pulsar, broker, offload, storage, conflict |
| Only one of retain ordering or retain key ordering can be… | validation | error | pulsar-functions, config-validation, illegal-argument |