apache/pulsar
Documented errors, page 2 of 15. Back to apache/pulsar
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Can't find owner for topic | http | warning | http-412, topic, lookup, precondition-failed |
| Client TLS factory <factory.getClass().getName()> supplied… | exception | error | tls, sslcontext, netty, factory |
| Cross-format TLS material: tlsPolicy(...) configures a… | exception | error | pulsar, tls, pem, keystore, configuration-conflict |
| Invalid schema class | exception | error | python, pulsar-functions, schema, configuration |
| Broker is forbidden to do read-write operations | http | error | admin-api, authorization, read-only, configuration |
| Malformed configuration parameter: earlyTokenRefreshPercent | validation | error | config, pulsar-client, oauth2 |
| Interrupted while connecting metadata store | exception | warning | interrupt, shutdown, metadata-store, threading |
| Failed to get the worker service definition from | exception | critical | pulsar-functions, nar-package, ioexception, worker-service |
INVALID_TOKEN Athenz Role Token Not Authenticated from Client | exception | error | auth, athenz, invalid-token, broker |
| The private key algorithm is not supported. attempted | exception | error | tls, pem, key-management, crypto |
| Timestamp extractor class | exception | error | pulsar-functions, windowing, classpath, classnotfound |
| Error reading list | exception | error | metadata-store, iterator, zookeeper, timeout, replication |
| Not supported | exception | error | authentication, oidc, deprecated-api, async, java |
| Passed in parameter empty. KEYSTORE_PATH | validation | error | java, tls, keystore, authentication, configuration, pulsar-client |
| cannot be admitted | http | error | rest-api, bad-request, admission-checks, kubernetes, pulsar-functions |
| Failed to instantiate | validation | error | reflection, configuration, instantiation |
| Synthetic layout missing segment_id= + partition + (N= + n… | exception | error | routing, illegal-state, segment-layout, concurrency |
| When Guarantees == ATMOST_ONCE, autoAck must be equal to… | validation | error | pulsar, functions, configuration, validation |
| bindAddresses: conflicting listener names for | validation | error | configuration, bind-address, port-conflict, multi-listener |
| Could not configure Kerberos principal name mapping. | exception | error | kerberos, configuration, static-initializer |
| Configuration field… | validation | error | configuration, pulsar, transactions, broker-startup |
| Could not instantiate | exception | error | reflection, instantiation, initialization, pulsar |
| Interrupted while creating transaction | exception | warning | transactions, interrupted, concurrency |
| Cluster does not exist. | http | error | rest-api, cluster-not-found, precondition-failed, validation |
| Proxy not authorized to access resource | http | error | authorization, http-401, proxy, pulsar-admin |
| Cannot disable validation of default values | exception | error | avro, reflection, schema, version-mismatch |
| Input bundles do not cover the whole hash range. first: | http | error | http-400, bundles, validation, admin-api |
| IOException | exception | error | io, metadata-store, bookkeeper, layout, timeout |
| RuntimeException(conversionError) | exception | error | pulsar, schema-registry, internal-error, ioexception |
| Invalid object type ' ' when expecting | exception | error | type-mismatch, schema, pulsar-client |
| Malformed JWKS returned by: | exception | error | jwks, oidc, json, validation, authentication |
| The function registration references a different set of jar… | exception | error | pulsar-functions, function-cache, classloader, state |
| A v5 authentication plugin | exception | error | serialization, not-serializable, authentication, configuration |
| ${cause.getMessage()} | exception | error | transactions, async, broker |
| Externally managed schedulers can't do per instance stop | http | error | pulsar-functions, kubernetes, unsupported-operation |
| Failed to delete cookie for bookie | exception | error | metadata-store, bookkeeper, cookie, decommission |
| Failed to setup / verify state table for function | exception | error | state, bookkeeper, timeout, pulsar-admin, io-exception |
| toIndex < 0 | validation | error | java, bitset, index-out-of-bounds |
| Interrupted while contacting metadata store | exception | warning | interruption, threading, metadata-store, replication, shutdown |
| Reset-cursor at position is not allowed for… | http | warning | rest-api, partitioned-topic, method-not-allowed, admin |
| cert/key file path or cert/key stream must be present | validation | error | pulsar-client, tls, authentication, configuration |
| Failed to update url | exception | error | pulsar, lookup, invalid-url, illegal-state |
| jitterPercent must be in [0, 100] | validation | error | java, configuration, illegal-argument, retry, client-api |
| value doesn't fit in given range ( , ) | validation | error | configuration, validation, range-check |
ALGORITHM_MISMATCH Expected PublicKey alg [ | exception | error | auth, oidc, jwt, key-type, configuration |
| SASL authentication HTTP client is not started | exception | error | lifecycle, sasl, illegal-state, initialization-order |
| Use #choosePartition(Message, TopicMetadata) instead | exception | error | deprecated-api, message-router, unsupported-operation, partitioning |
| Can not enable for all producers but denies for replicators | validation | error | cli, parameter-validation, schema, pulsar-admin |
| Can't use receive with timeout, if the queue size is 0 | exception | error | pulsar, configuration, receiver-queue-size, consumer |
| Unable to determine latest version since broker version map… | exception | warning | load-manager, broker-filter, version-comparison, empty-collection |
| Error contacting zookeeper | exception | error | metadata-store, zookeeper, timeout |
| Invalid combination of Original principal cannot be empty… | http | error | authentication, authorization, proxy, rest-api, pulsar |
| Output topic is also being used as an input topic (topics… | validation | error | pulsar-functions, topic-configuration, validation, configuration |
| period can not be null | validation | error | pulsar, scheduler, illegal-argument, argument-validation |
| Segment already has the requested entry-bucket splits | validation | error | java, illegal-argument, idempotency, rebucket |
| Failed to resolve localhost name. | exception | critical | network, dns, hostname-resolution, configuration |
| Field ' ' with value ' ' does not implement | validation | error | java, config-validation, classloader, illegal-argument |
| bindAddresses: malformed | validation | error | configuration, bind-address, multi-listener, broker |
| privateKeyProvider must be set when failureAction is FAIL | validation | error | java, configuration, encryption, crypto, illegal-argument |
| Source Archive does not exist | validation | error | pulsar-admin, cli, io-connector, file-not-found |
| The broker is not among the assigned broker pools for the… | exception | error | configuration, namespace-isolation, regex-mismatch |
| Cross-format TLS material: tlsPolicy(...) configures a PEM… | exception | error | pulsar, tls, pem, keystore, configuration-conflict |
| Must provide encryption key name for crypto key reader | validation | error | pulsar-functions, config-validation, encryption, crypto |
| Read ledgerMetadata from bytes failed | exception | error | io, truncated-data, corruption, index-block |
| Unsupported authentication method | http | error | authentication, pulsar, configuration, http |
| Entry-bucket boundaries must tile the 16-bit ring: last… | validation | error | pulsar, key-shared, entry-bucket, validation |
| Failed to load config into existing configuration data | exception | error | configuration, jackson, deserialization, type-mismatch |
| Invalid signature | exception | error | authentication, signature, hmac, security |
| ResourceGroup is in use | http | warning | rest-api, precondition-failed, resourcegroups, delete-guard |
| Exceed maximum number of topics in namespace. | http | error | http-412, quota, partitioned-topic, admin-api |
| Inconsistent types found between function input type and… | exception | error | java, generics, pulsar-functions, windowing |
| ResourceGroup already exists | http | warning | rest-api, conflict, duplicate-resource, resourcegroups |
| An error occurred while processing the field | exception | error | reflection, serialization, configuration |
| Either --compatibility or --disabled must be specified | validation | error | cli, enum-value, schema, pulsar-admin |
| Invalid backlog quota type | validation | error | cli, pulsar-admin, argument-validation, enum |
| Timeout during managed ledger close | exception | error | timeout, managed-ledger, bookkeeper, shutdown |
| Unauthorized to… | http | error | authorization, unauthorized, isolation-policy, security |
| Authentication use SASL/JAAS/GSSAPI but server not have… | exception | critical | sasl, kerberos, authentication, broker-startup |
| doesn't exist | http | error | rest-api, not-found, pulsar-functions, lifecycle |
| Source class not found in class loader | validation | error | pulsar-functions, classnotfound, connector-nar, packaging |
| Bundle range not found | http | error | http-404, admin-api, namespaces, bundle |
| Failed due to heap memory limit exceeded | http | warning | rate-limit, memory, rest-api, topics |
| Failed to acuire under-replicated ledger | exception | error | distributed-lock, metadata-store, timeout, bookkeeper |
| Invalid topic name | validation | error | java, topic-naming, null-pointer |
| Source tenant cannot be null | validation | error | pulsar-functions, config-validation, illegal-argument |
| Topic does not exist | http | error | pulsar, rest-api, topic-not-found |
| Either s3ManagedLedgerOffloadRegion or… | validation | error | cli, s3, configuration, validation |
| Interrupted when connecting to zookeeper server | console | error | zookeeper, interruption, startup, io |
| unsupported non-primitive Optional< | exception | error | reflection, generics, optional, configuration |
| Cannot create topic in system topic format! | http | error | http-400, system-topic, validation, admin-api |
| Failed to load the worker service | exception | critical | pulsar-functions, nar-package, worker-service, ioexception |
| Invalid object version | exception | error | versioning, metadata, tiered-storage, compatibility |
| Invalid privateKey format | validation | error | java, athenz, pem, url, auth-config |
| already exists | http | error | rest-api, bad-request, duplicate-resource, pulsar-sinks |
| Transaction ` ` CANNOT transaction from status to | exception | error | transaction, state-machine, pulsar |
| Unrecognized SASL GSSAPI Server Callback. | exception | error | sasl, kerberos, callback, authentication |
| Unsupported additional servlet type | validation | error | plugin, servlet, type-mismatch, pulsar |
| chunkSize must be > 0 when chunking is enabled | validation | error | java, configuration, chunking, illegal-argument, producer |
| Delete request ignored because it is out of date. Please… | exception | warning | pulsar-functions, version-conflict, optimistic-concurrency |
| Failed to update clusters because failed to create admin… | http | critical | network, rest-api, admin-client, connectivity |