apache/pulsar
Documented errors, page 3 of 15. Back to apache/pulsar
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Illegal schema compatibility strategy | validation | error | cli, enum-value, schema, pulsar-admin |
| Incompatible schema: exists schema type | exception | error | pulsar, schema-registry, avro, json |
| Invalid topic name: . Topic local name must not be blank. | validation | error | java, topic-naming, illegal-argument |
| No URL configured for broker | http | error | http-redirect, tls, lookup, configuration |
| Window Configs cannot be found | exception | error | pulsar-functions, windowing, missing-config |
| multiplier must be >= 1.0 | validation | error | retry, backoff, illegal-argument, configuration |
| Context does not provide SubscriptionType | exception | warning | pulsar-io, unsupported-operation, api-compatibility, sink-context |
| Failed to find ownership for ServiceUnit | http | error | http-412, namespace-bundle, ownership, load-manager |
| No usable leader URL | exception | error | tls, url, discovery, transaction |
| Partitioned Topic Name should not contain '-partition-' | http | warning | rest-api, pulsar-admin, topic-partitions |
| Peek messages on a partitioned topic is not allowed | http | warning | rest-api, partitioned-topic, method-not-allowed, admin |
| is a non-partitioned topic. Instead of calling… | http | error | pulsar, rest-api, conflict, wrong-api-endpoint |
| Schema ` ` is not supported to be used as a field for now | exception | error | schema, avro, unsupported-type |
| Tenant name or namespace is not valid | http | error | admin-api, validation, namespace, tenant |
| Cannot convert from to . Requested converter does not… | exception | error | reflection, type-conversion, configuration |
| Failed to authentication http request | exception | error | authentication, http, exception-wrapping |
| Invalid package domain | validation | error | pulsar, packages, enum, validation |
| Invalid path | exception | error | security, path-traversal, filesystem, storage |
| Invalid topic name: ' '. Topic name must not have leading… | validation | error | pulsar, topic, validation, whitespace, illegal-argument |
| ProducerCache is already closed | exception | error | lifecycle, producer-cache, illegal-state, shutdown |
| v4 plugin returned no AuthenticationDataProvider | exception | error | authentication, unsupported-authentication, v4-plugin, handshake |
| Additional servlet instance of type | validation | error | servlet, plugin, classloader, configuration |
| Audiences in token is not in expected format | exception | error | jwt, authentication, audience, malformed-token |
| Consumer was not connected | exception | warning | pulsar, broker, consumer, state-mismatch, race-condition |
| Failed to extract source class from archive | validation | error | pulsar-functions, connector-nar, missing-resource, packaging |
| Interrupted initializing OAuth2 IdP TLS factory | exception | error | oauth2, tls, interruption, shutdown, pulsar-client |
| Invalid MagicWord. read: 0x | exception | error | io, corruption, index-block, tiered-storage |
| No free port found | exception | error | network, port-allocation, resource-exhaustion |
| Sink package doesn't contain the… | validation | error | pulsar, pulsar-io, nar-packaging, connector |
| AutoConsumeSchema is not supported with schemaId | exception | error | pulsar, schema, keyvalue, unsupported-operation |
| BookKeeper client is not available | exception | error | bookkeeper, storage, unsupported-operation, broker-api |
| Failed to bind Pulsar Proxy on port | exception | critical | pulsar-proxy, network, bind-exception, port-in-use, startup |
| Failed to validate global cluster configuration | http | error | http-503, metadata-store, admin-api, namespace |
| Unauthorized to validateBrokerOperation for… | http | error | pulsar, authorization, http-401, broker-operation |
| Unauthorized to validateClusterPolicyOperation for… | http | error | authorization, rest-api, admin, policy |
| Failed to create authentication | exception | error | authentication, configuration, reflection |
| getSubNotFoundErrorMessage(topicName.toString(), subName) | http | error | pulsar, subscription, rest-api |
| isDuplicated cannot accept | exception | warning | pulsar, acknowledgment, messageid, illegal-argument, type-guard |
| No JavaInstanceJar specified | exception | error | pulsar-functions, configuration, missing-env-var |
| Schema is a client-side schema type | validation | error | pulsar, schema-validation |
| httpReverseProxy. .proxyTo must be specified exactly once | validation | error | pulsar-proxy, configuration, reverse-proxy, validation |
| Invalid token string, missing attributes | exception | error | sasl, token, parsing, authentication |
| Invalid namespace format. namespace | validation | error | pulsar, namespace, illegal-argument, input-validation |
| Metadata store address argument is required… | exception | error | cli, configuration, missing-argument, metadata-store, zookeeper |
| SASL/JAAS error | exception | error | sasl, kerberos, jaas, authentication |
| Config file not specified. Please use -c, --config-file or… | exception | error | cli, configuration, missing-config-file, standalone, startup |
| could not be created | exception | error | filesystem, io, permissions, mkdirs |
| function is nil | error_code | critical | go, function-registry, nil-value, startup |
| Invalid messageId base64 value | exception | error | websocket, base64, encoding, validation |
| Invalid metadata URL. Must start with 'oxia://'. | exception | error | configuration, url-validation, oxia |
| Invalid namespace format. expected | validation | error | pulsar, namespace, illegal-argument, migration |
| Ranges for KeyShared policy with overlap between | validation | error | keyshared, hash-range, illegal-argument, overlap |
| is not a directory | exception | error | filesystem, io, directory, nar |
| already exists in | http | error | rest-api, conflict, failure-domain, broker-assignment |
| Token Audience Claim | validation | error | configuration, jwt, token |
| Unsupported auth method | validation | error | pulsar-client, oauth2, configuration, unsupported-value |
| The function registration references a different set of… | exception | error | pulsar-functions, function-cache, classloader, state |
| Invalid filename: | validation | error | pulsar-functions, config-validation, path-traversal, security |
| Late data topic can be defined only when specifying a… | exception | error | pulsar-functions, windowing, late-data, invalid-config |
| Message not found | http | info | rest-api, message-not-found, not-found, race-condition, admin |
| Cannot create temp directory | exception | error | filesystem, io, startup |
| couldn't find subscription | exception | warning | pulsar, authorization, subscription, not-found |
| ${e} | exception | warning | lifecycle, shutdown, unchecked-exception |
| Failed to delete secrets for function | exception | error | kubernetes, secrets, cleanup |
| Failed to read CA bytes | exception | error | tls, configuration, filesystem, pulsar-worker |
| Invalid source type ' ' -- Available sources are | validation | error | pulsar-admin, cli, io-connector, invalid-argument |
| ManagedLedgerException (wrapped from err in… | exception | error | tiered-storage, object-storage, managed-ledger |
| the configure entry `advertisedListeners` is invalid… | validation | error | configuration, advertised-listeners, listener-name, multi-listener |
| Audiences in token: [ ] not contains this broker | exception | error | jwt, authentication, audience, broker |
| Backlog Quota exceeds configured retention quota for… | http | error | http-412, backlog-quota, retention, admin-api |
| Client is not authorized to perform operation | http | error | authorization, security, rest-api, pulsar-sinks |
| entryFilterNames can't be empty. To remove entry filters… | http | error | pulsar, broker, rest-bad-request, entry-filters, validation |
| Unsupported key type for key | exception | error | crypto, key-type, unsupported-algorithm, encryption |
| Not implemented | exception | error | schema, unsupported-operation, decoding, default-method |
| Window function does not implement the correct interface | exception | error | pulsar-functions, windowing, interface-contract |
| Cannot handle message with null messageId | exception | error | pulsar, message-id, acknowledgment, invalid-message |
ERROR_VERIFYING_JWT_SIGNATURE JWT signature verification exception: | exception | error | auth, oidc, jwt, signature, security |
| Expected TransactionV5, got: + txn.getClass() | exception | error | transaction, type-mismatch, illegal-argument, api-mixing |
| Invalid managedLedger name | validation | error | java, managed-ledger, parsing |
| Metadata path must start with | validation | error | oauth2, openid-connect, discovery, configuration, pulsar-client |
| Source does not implement correct interface | exception | error | java, pulsar-functions, classloader, source, interface |
| Source package doesn't contain the… | validation | error | pulsar-functions, connector-nar, missing-resource, packaging |
| The load shedding strategy | validation | error | configuration, load-manager, load-shedding, broker-startup |
| Unable to create producer for topic | exception | error | producer, pulsar-client, topic, runtime-exception |
| AutoScaledReceiverQueueSize is not supported in… | exception | error | java, consumer, configuration, pulsar-client |
| Can't get generic schema for topic… | exception | error | pulsar, schema, generic-schema, schema-version |
| cannot be null | validation | error | pulsar-io, configuration, required-field, illegalargument |
| fromIndex: > toIndex | validation | error | java, bitset, index-out-of-bounds, argument-validation |
| Invalid HTTP Authorization header | http | error | http, jwt, authentication |
| Invalid retention policy type | validation | error | pulsar-admin, cli, topic-policies, invalid-enum-value |
| User class must be in class path | exception | error | reflection, classpath, configuration |
| Cluster [ ] is not in the list of allowed clusters list for… | http | error | rest-api, admin, policy, replication, cluster |
| Concurrent modification | http | warning | rest-api, admin, concurrency, metadata-store |
| Failed to parse config file | validation | error | |
| Schema typed [<schema.getClass().getName()>]… | exception | error | pulsar, avro, schema, generic-schema |
| User class must be concrete | exception | error | pulsar-functions, windowing, reflection, abstract-class |
| (wraps commit failure cause message) | exception | error | transaction, commit, pulsar-client, wrapped-exception |
| Error when loading topic compaction strategy: | exception | error | reflection, classloading, configuration, compaction |
| Internal Error updating function at the leader | exception | error | pulsar-functions, metadata-topic, write-failure |
| nbits < 0 | validation | error | java, bitset, negative-array-size |