apache/pulsar
Documented errors, page 5 of 15. Back to apache/pulsar
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| RuntimeException | exception | error | metadata-store, underreplication, layout, runtimeexception |
| User class constructor throws exception | exception | error | pulsar-functions, windowing, reflection, constructor-exception |
ERROR_VERIFYING_JWT JWT verification failed: | exception | error | jwt, oidc, authentication, claim-validation |
| timeout must not be null | validation | error | java, validation, null-argument, client-config |
| Unable to convert digest type | validation | error | configuration, digest-type, unsupported-feature, tiered-storage |
| Unsupported request body type | validation | error | http-client, illegal-argument, request-body, auth-v5 |
| Error while scanning ledgers for | http | error | pulsar, admin-api, rest-exception, offloading, metadata |
| Failed to bind Pulsar broker on | exception | error | |
| Failed to open state table for function | exception | critical | bookkeeper, state-storage, timeout, pulsar-functions |
| Invalid Java object for schema type + type + : +… | exception | error | schema, validation, avro, type-mismatch |
| maxBytes must be >= 0 | validation | error | java, configuration, illegal-argument, batching, memory-size |
| No additional servlet is found for name | exception | error | servlet, plugin, configuration, broker |
| stream is not supported | exception | error | java, bitset, unsupported-operation, concurrency |
| Thread Container only supports Java Runtime | exception | error | pulsar-functions, runtime, configuration |
| Bookie 'group' parameters is missing | http | error | pulsar, admin-api, rest-exception, missing-parameter, bookkeeper |
| Cannot remove cluster | http | warning | http-412, tenant, replication-clusters, geo-replication |
| Failed to authentication token | exception | error | jwt, authentication, token-validation |
| first delta must be > 0, got | exception | error | metadata, argument-validation, sequence-deltas |
| Get message ID by timestamp on a partitioned topic is not… | http | warning | rest-api, partitioned-topic, method-not-allowed, admin |
| is NULL, empty or contains a '& | validation | error | sasl, token, validation, illegal-argument |
| path not found. | exception | error | rocksdb, not-found, delete |
| payload ( bytes) cannot be decoded with schema | exception | error | pulsar, schema, deserialization, compatibility |
| Unauthorized to validateNamespacePolicyOperation for… | http | warning | http-403, authorization, namespace-policies, rbac |
| Cluster already exists | http | error | rest-api, conflict, cluster-admin, duplicate-resource |
| Exceed the maximum number of namespace in tenant | http | error | quota, namespace, rest-api, admin |
| Interrupted while waiting for layout update | exception | error | interruption, segment-layout, retry, pulsar-client |
| Not support to set… | exception | error | pulsar, scheduler, unsupported-operation, shutdown-policy |
| Timeout during managed ledger terminate | exception | error | configuration, validation, s3, endpoint |
| Unsupported Runtime | exception | error | pulsar-functions, runtime, version-compatibility |
| v4 plugin provided no HTTP auth headers… | exception | error | authentication, http-headers, unsupported-authentication, v4-plugin |
| Error preloading next range | exception | error | metadata-store, zookeeper, timeout, iteration |
| Failed to extract class from archive | validation | error | pulsar-functions, nar-archive, io-connector, classpath |
| Invalid schema definition data for primitive schemas… | validation | error | pulsar, schema-validation |
| pulsarServiceUrl cannot be null | exception | critical | pulsar-functions, pulsar-client, configuration, null-check |
| The supplied go file does not exist | validation | error | pulsar-functions, config-validation, filesystem, builtin |
| tlsPolicy purpose and policy must not be null | exception | error | pulsar, tls, null-check, illegal-argument, builder |
| Compaction already in progress | exception | warning | pulsar, broker, compaction, long-running-process, conflict |
| Connector is already closed | exception | error | pulsar-functions, lifecycle, nar, connector, use-after-close |
| Failed to validate global cluster configuration : ns= | http | error | http-503, metadata-store, timeout, namespace-ownership |
| Function in trigger function is not ready | http | error | pulsar, broker, topic, not-ready |
| Functions Worker Service Nar Package | exception | critical | config, nar-package, startup |
| Invalid state value | exception | error | rest-api, validation, state, functions |
| Peer cluster does not exist | http | error | rest-api, peer-cluster, validation, replication |
| class must be in class path | validation | error | pulsar-functions, classnotfound, nar-archive, io-connector |
| Kubernetes job name size should be less than | validation | error | kubernetes, validation, naming, pulsar-functions |
| No athenz domain name specified | console | error | athenz, authentication, configuration, startup |
| Configuration field… | validation | error | configuration, transaction, validation |
| Error when get child nodes from zk | exception | error | metadata-store, zookeeper, timeout |
| Function Package management service is disabled. Please… | exception | error | configuration, package-management, pulsar-functions |
| No Function found | exception | error | rest, bad-request, builtin-functions, pulsar-functions |
| Partition count mismatch for | http | error | conflict, replication, partitioned-topic, geo-replication |
| The driver is not supported, support value | http | error | pulsar, broker, precondition-failed, offload, storage-driver |
| timeout must be > 0 | validation | error | java, validation, transactions, duration |
| Worker was not yet removed after a prior drain op; try later | http | error | pulsar-functions, drain, lifecycle |
| Cannot add servlet at | validation | error | pulsar-proxy, web-server, servlet, path-conflict, configuration |
| Cannot enable auto ack when using windowing functionality | validation | error | pulsar-functions, windowing, ack, configuration |
| ClassNotFoundException: className | exception | error | reflection, classloading, descriptor |
| expected MultiMessageIdImpl object. Got instance of | exception | warning | pulsar, messageid, compareto, illegal-argument, partitioned |
| Failed to retrieve the state value for key | exception | error | state, bookkeeper, read, blocking-call |
| Invalid topicname | exception | error | python, pulsar-functions, topic-name, ack |
| No offloader found for driver | exception | error | configuration, offloading, startup |
| protobuf root message descriptor is null, please recheck… | validation | error | pulsar, protobuf, schema-validation |
| Range end must >= range start. | validation | error | range, illegal-argument, validation |
| Invalid value for BROKER_CLIENT_TRUST_CERTS_SECRET_NAME… | validation | error | kubernetes, functions-runtime, config-validation |
| KeyStore creation error | exception | critical | security, keystore, tls |
| Need to specify either --enable or --disable | validation | error | cli, argument-validation, pulsar-admin |
| Non-null message is required | exception | error | pulsar, null-check, acknowledgment, invalid-message |
| Timeout during managed ledger offload operation | exception | error | timeout, offload, managed-ledger, storage |
| Timeout during mark-delete operation | exception | error | gcs, credentials, configuration, io |
| Both and must be set when providing offload credentials in… | validation | error | configuration, credentials, s3, offload |
| cancelAction can only be set once. | exception | error | concurrency, async, future, state |
| Cannot derive a tenant/namespace from --regex pattern | validation | error | cli, regex, validation, topic-pattern |
| Effective auto-topic creation policy mismatch for namespace | http | error | conflict, replication, auto-topic-creation, namespace-policy |
| Error parsing proto message | exception | error | corruption, protobuf, parsing, data-format |
| FunctionArchive is already closed | exception | error | pulsar-functions, lifecycle, nar, use-after-close |
| Header was too small | exception | error | io, truncated-data, eof, tiered-storage |
| Schema compatibility strategy is ALWAYS_INCOMPATIBLE | exception | error | pulsar, schema-registry, configuration |
| SequenceKeysDeltas requires at least one delta | exception | error | pulsar-metadata, illegalargument, validation, sequence |
| The update payload operation only support multi chunked… | exception | error | chunking, raw-reader, message-payload, precondition |
| Unable to initialize crypto config | exception | error | java, pulsar-functions, crypto, class-not-found, producer |
| Unknown component type | exception | error | pulsar-functions, metrics, configuration, enum |
| Deadlocked threads detected. | exception | critical | pulsar, deadlock, jvm, health-check, threads |
| Failed to get clientId from request | http | error | rest, authentication, unauthorized |
| GetMessageById is not allowed on partitioned-topic | http | warning | rest-api, partitioned-topic, method-not-allowed, admin |
| Invalid message id (must be in format: ledgerId:entryId)… | validation | error | cli, pulsar-admin, message-id, argument-validation, parsing |
| Invalid schema definition data for string schema : ' | validation | error | pulsar, schema-validation, python |
| NamespaceIsolationPolicies for cluster | http | warning | rest-api, not-found, isolation-policy, empty-state |
| Need to authenticate to perform the request | http | error | authentication, rest-api, authorization, pulsar |
| No usable service URL | exception | error | pulsar, topic-migration, tls, failover |
| 's peer-clusters can't be part of replication-clusters | http | error | configuration, geo-replication, http-409, cluster |
| Can't get Kerberos configuration | exception | error | kerberos, configuration, startup |
| Could not find sink config class | validation | error | pulsar, functions, connector, classpath, reflection |
| EarlyTokenRefreshPercent must be greater than 0. | validation | error | pulsar-client, oauth2, configuration, argument-validation |
| Failed to get auth data from the request | http | error | rest, authentication, unauthorized |
| fromIndex < -1 | validation | error | java, bitset, index-out-of-bounds, iteration |
| Incompatible layout version found | exception | critical | bookkeeper, metadata-store, layout-version, version-compatibility, upgrade |
| jcaProvider=' ' does not supply KeyStore type ' '. Types… | exception | error | java, tls, keystore, fips, configuration |
| Kerberos authentication without KerberosTicket provided! | exception | critical | kerberos, sasl, tgt, authentication |
| SourceRecord class type must be PulsarRecord | exception | error | java, pulsar-functions, sink, ack |
| Unrecognized SASL GSSAPI Client Callback. | exception | warning | sasl, kerberos, callback, unsupported-operation |