apache/cassandra
Documented errors, page 13 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unable to start because the node was drained. | exception | error | drain, shutdown, node-lifecycle |
| You cannot use -e and -m at the same time | validation | error | nodetool, cli, mutually-exclusive |
| You do not have access to this datacenter | exception | error | authentication, datacenter, authorization, multi-dc |
| Accord transaction uses dropped tables | validation | error | accord, dropped-table, invalid-request, schema-change, transactions |
| --all-tables option should be passed along with --keyspace… | console | error | cli, validation, permissions |
| Cannot include non-counter statement in a counter batch | validation | error | cql, batch, counters |
| CasWriteTimeoutException | exception | error | timeout, lightweight-transactions, paxos, contention |
| DROP COMPACT STORAGE is disabled. Enable in cassandra.yaml… | validation | error | cql, compact-storage, feature-flag, configuration |
ERR_WRONG_CONFIG Unable to instantiate a compressor for class | error_code | error | compression, provider, startup |
| If rpc_address is set to a wildcard address ( | validation | critical | cassandra, configuration, wildcard-address |
| Invalid size for a counter context | validation | error | cassandra, counters, corruption, serialization |
| metadata cannot be null | validation | error | io, mmap, null-argument |
| Missing CLUSTERING ORDER for column | validation | error | cql, schema, create-table, clustering-order |
| Not enough space for compaction | exception | critical | compaction, disk-space, storage |
| Password for role can only be changed every %sms. | exception | error | |
| Shoud not have a TTL without an associated local deletion… | validation | error | validation, ttl, tombstone, data-corruption |
| Unknown keyspace/cf pair | exception | error | schema, table-not-found, illegal-argument |
| Could not parse TokenKey " + vs[i] | validation | error | cassandra, cql, parsing, token |
| Failed to create instance of | exception | error | nodetool, reflection, picocli, initialization, cassandra |
| Invalid value for | validation | error | config, compression, parse-error |
| Invalid value of… | validation | error | configuration, startup, validation |
| It is not possible to import compression dictionaries of… | validation | error | compression, dictionary-import, enum-mismatch |
| Login config name specified for JMX auth, but no… | exception | error | jmx, authentication, configuration, jaas |
| Must provide truststore or trusted_certificates in… | exception | error | |
| Partitioner ' ' for table ' ' in keyspace ' ' is not… | exception | error | virtual-table, partitioner, unsupported, invalid-request |
| Root-level resource can't have a parent | exception | error | cassandra, auth, illegal-state, resource-hierarchy |
| does not support complex column updates | validation | error | cql, virtual-table, collections, mutation, invalid-request |
| Timeout waiting to exeute waiting transactions | exception | error | accord, startup, timeout, transactions, backlog |
| Unexpected extraneous bytes after + getCollectionName() +… | validation | error | serialization, cassandra, bytebuffer, collections |
| Unrecognised option(s) in column spec | validation | error | yaml, configuration, cassandra-stress |
| Unsupported time unit | validation | error | duration, unit, validation |
| You are using Cassandra with an unsupported deployment. The… | console | warning | logging, slf4j, logback, classpath, configuration |
| You have to be logged in and not anonymous to perform this… | exception | error | authentication, anonymous, role-management |
| Can't abort bootstrap for - it is alive | exception | error | nodetool, bootstrap, gossip, failure-detector, node-lifecycle |
| Can't upgrade the first node when STATUS = | exception | error | gossip, upgrade, tcm, compatibility |
| Cannot create materialized view | validation | error | cql, materialized-view, gc-grace-seconds, tombstones |
| Clustering block upper bits (those not associated with… | exception | error | sstable, corruption, deserialization, schema |
| Clustering column restrictions require the use of secondary… | validation | error | cql, cassandra, filtering, indexing |
| Corrupted Index File | exception | error | sstable, corruption, compression-index, eof |
| Could not list files in | console | warning | cache, filesystem, directory, permissions |
| Directory does not exist | exception | error | sstable, import, file-not-found, storage |
| Error during list snapshot | console | error | snapshots, io, nodetool |
| Failed parsing : [ ] reason | validation | error | cql, syntax, parser |
| Failed to build key manager store for secure connections | exception | error | |
| Illegal distribution specification: | exception | error | cli, distribution, argument-parsing |
| Invalid boolean value | validation | error | cql, boolean, property-parsing |
| Invalid duration: Accepted units: where case matters and… | validation | error | configuration, duration, validation |
| It is not possible to reconfigure role_name_policy… | console | warning | guardrails, security, configuration, runtime-reconfiguration |
| Range deletions must specify a complete partition key in… | validation | error | cassandra, virtual-table, range-tombstone, delete |
| Session failed acquiring sstables: , retrying every ms for… | console | warning | repair, compaction, retry |
| text or varchar values must be enclosed by single quotes | validation | error | cql, parsing, codec, string-literal |
| Unknown subcommand ' | console | warning | cli, picocli, help, typo |
| Variable column counts are not implemented for CQL | exception | error | cli, cql, unsupported-feature |
| You are not authorized to view roles granted to | validation | error | cassandra, cql, authorization, roles, privilege-escalation |
| Cannot drop PRIMARY KEY column | validation | error | cql, schema, primary-key, alter-table |
| Cannot return epoch when accord.enabled = false in… | exception | warning | accord, cassandra, epoch, unsupported-operation |
| Cannot run paxos only repair on | validation | error | repair, paxos, validation, illegal-argument |
| Cleanup of the system keyspace is neither necessary nor wise | exception | warning | cassandra, nodetool, maintenance, system-keyspace |
| Error reading key | exception | error | corruption, deserialization, offline-tools |
| Invalid statement in batch: only UPDATE, INSERT and DELETE… | exception | error | cql, batch, invalid-request, unsupported-operation |
| Invalid TxnId: | validation | error | accord, validation, txn-id |
| Invalid type id | exception | error | streaming, protocol, version-skew |
| Malformed target host | exception | error | cli, configuration, parsing |
| Out of bound timestamp, must be in | validation | error | timestamp, write-path, validation |
| phi_convict_threshold must be between 5 and 16, but was | validation | error | config, failure-detection, value-out-of-range, startup |
| The node does not have | exception | warning | bootstrap, schema, ownership |
| Token allocation does not support replication strategy | exception | error | token-allocation, replication-strategy, config |
| Unknown host in epState for | exception | error | gossip, dns, upgrade, configuration, tcm |
| Unsupported record version | exception | error | audit-log, serialization-version, forward-compatibility |
| Bootstrapping to existing token " + tokenString + " is not… | validation | error | cassandra, bootstrap, tokens, configuration-conflict |
| Cannot access method create in | validation | error | compression, reflection, visibility |
| Configuration must specify value for either keystore or… | validation | error | |
| could not read required number of bytes from file to be… | exception | error | streaming, file-io, short-read |
| default_keyspace_rf ( ) cannot be less than… | validation | error | cassandra, configuration, replication |
| EstimatedHistogram overflow | console | error | |
| Expected 4 or 16 byte inetaddress; got | validation | error | cassandra, serialization, inet, type-validation |
| Expected to complete startup sequence, but did not. Can't… | exception | error | tcm, bootstrap, startup, state-machine |
| Ignoring provided values | console | warning | guardrails, unsupported-values, configuration |
| Illegal index name | validation | error | index, naming, validation |
| Invalid double value | validation | error | cql, double, property-parsing |
| Invalid row " + row + " in table: " +… | exception | error | cassandra, virtual-table, metrics, latency |
| Log entry of unsupported type | exception | error | serialization, deserialization, dispatch |
| Materialized views are not supported on transiently… | validation | error | cassandra, materialized-view, transient-replication, replication |
| No in progress sequence for | exception | error | illegal-argument, not-found, cluster-metadata, sequence |
| Number of concurrent view builders should be greater than 0. | validation | error | configuration, jmx, materialized-views, validation |
| peer attempted to establish an unencrypted connection… | console | error | |
| repair_session_max_tree_depth of | console | warning | cassandra, config, repair, memory |
| repair_session_space must be > 0, but was | validation | error | cassandra, configuration, repair, memory |
| Request has spent over | console | info | native-transport, queue-time, latency, backpressure |
| SslContextFactory should configure ' ' as… | validation | error | ssl, configuration, encryption-options |
| Syntax error parsing | validation | error | cassandra, type-parser, syntax-exception, malformed-type-string |
| The number of initial tokens (by initial_token) specified | validation | error | configuration, startup, vnodes, tokens |
| This output stream is in an unsafe state after an… | exception | error | network, streaming, io |
| Unknown tables: " + verifier.get(ks) + " in keyspace: " + ks | validation | error | cassandra, nodetool, validation |
| Value of is too large ( ) | validation | error | config, compression, overflow |
| You are not authorized to view | exception | error | |
| Batch too large | validation | error | cql, batch, size-limit, guardrails |
| Cannot create index on non-frozen UDT column | validation | error | cassandra, cql, index, udt |
| Cannot re-add previously dropped counter column | validation | error | cql, schema, counter, alter-table, dropped-column |
| Cannot remove temporary or obsoleted files for | exception | error | offline-tools, sstable, transaction-log, cassandra |