apache/cassandra
Documented errors, page 12 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| ttl is too large. requested | validation | error | cql, ttl, invalid-request |
| Type error: cannot be passed as argument of function of type | validation | error | cql, type-mismatch, function-resolution |
| Unable to create instance of IAuditLogger. | exception | error | config, audit, reflection, classpath |
| `USE ` with prepared statements is considered to be an… | validation | info | cql, prepared-statements, anti-pattern |
| Can't ignore local host | exception | error | cassandra, tcm, upgrade, configuration |
| Cannot create secondary index on the only partition key… | validation | error | cassandra, cql, secondary-index, partition-key |
| Cannot parse 64-bits long value from | validation | error | cql, bigint, codec, number-parsing |
| Cannot set the value of counter column | validation | error | cql, counter, update |
| Checksum didn't match | exception | critical | streaming, checksum, corruption, io |
| Deserialized partition size histogram with | console | warning | sstable, histogram, io, deserialization |
| native_transport_max_frame_size must be positive value <… | validation | error | cassandra, configuration, cql, native-protocol |
| Operator not supported for txn_id | validation | error | cql, virtual-table, query, invalid-request |
| Timed out while trying to CAS | console | warning | cas, schema, timeout, startup |
| Unable to append merkle tree hash to result | exception | error | merkle-tree, hashing, runtime-exception |
| Unable to parse node id string | exception | error | nodetool, parsing, uuid, invalid-argument |
| Unable to perform authorization of super-user permission: | exception | error | |
| Booting with ClusterMetadata from file: | console | warning | tcm, startup, unsafe-flag, bootstrap |
| Cassandra system property flag | console | warning | deprecated, configuration, system-property |
| CorruptSSTableException (wrapped IOException from IOError… | exception | critical | sstable, corruption, io, storage |
| Invalid row " + row + " in table: " + countsMetricsTableName | exception | error | cassandra, virtual-table, metrics, cidr |
| No ciphers left after filtering supported cipher suite | exception | error | ssl, tls, ciphersuite, configuration |
| Number of concurrent index builders should be greater than… | validation | error | configuration, jmx, index, validation |
| Out of order rows found in partition | console | warning | scrub, out-of-order, clustering, data-integrity |
| output buffer is not large enough for data: current capacity | exception | error | bytebuffer, buffer-capacity, compression |
| Query attempted to read from too many indexes ( ) but max… | exception | error | sai, guardrails, query-planning, threshold |
| Racks by dc differ: != | console | warning | cassandra, tcm, topology, diagnostics |
| Request on table . with ttl of seconds exceeds maximum… | console | warning | ttl, expiration, client-warning, data-loss |
| '%skeystore_password' and '%skey_password' both… | validation | error | |
| Table ' . ' is already being dropped | validation | error | cassandra, cql, ddl, schema |
| Unable to bind to address | exception | critical | network, bind, configuration, ec2 |
| Unable to parse a date/time from | validation | error | cassandra, serialization, timestamp, invalid-date-format |
| Unexpected node type: " + ident | exception | error | serialization, repair, merkle-tree |
| Unknown field for column | validation | error | cql, udt, validation, query |
| Can only initialize cluster identifier during epoch | exception | error | cassandra, tcm, cluster-initialization, illegal-state |
| Cannot achieve consistency level | exception | error | paxos, unavailable, quorum, replica-down |
| Cannot index value of size | validation | error | cassandra, index, size-limit, invalid-request |
| capacity should not be negative. | validation | error | jmx, configuration, cache, memory |
| Column value does not satisfy value constraint for column | validation | error | cql, write-path, constraints, length, validation |
| Impossible partition size (greater than file length): | exception | critical | sstable, corruption, scrub, data-file |
| In progress sequences differ | console | warning | cluster-metadata, diagnostics, state-divergence |
| Invalid keyspace or table name | exception | error | jmx, nodetool, validation, objectname |
| Native protocol version | exception | error | java-driver, serialization, protocol-limit |
| Need to give either a token for a new move operation, or… | console | error | nodetool, cli, argument-validation, streaming |
| parameters have been deprecated. They have new names and/or… | console | warning | configuration, deprecation, yaml |
| is not a collection type | validation | error | cassandra, type-parser, collection-type, invalid-argument-value |
| SSTables import has been aborted | exception | warning | sstable, import, drain, shutdown, interrupt |
| String representation of blob is missing 0x prefix | validation | error | cassandra, marshal, json, blob |
| Unable to find sufficient sources for streaming range in… | exception | error | streaming, bootstrap, ring-movement |
| Access forbidden | validation | error | compression, security, reflection |
| Bad configuration; unable to start server: | validation | error | config, startup, wrapper |
| CasWriteTimeoutException | exception | error | timeout, paxos, lightweight-transactions, ballot |
| Constraint does not accept any arguments. | validation | error | cql, schema, constraints, arguments |
| Corrupted input: expected byte 1 or 2, received " + b | exception | error | serialization, accord, corrupted-input, seekable |
| Could not perform consistent fetch, downgrading to fetching… | console | warning | paxos, consistency-downgrade, cms |
| Failed adding SSTables | exception | error | sstable, import, memory, lifecycle |
| Failed to list files in | exception | error | filesystem, sstable, startup |
| Failed to update speculative retry thresholds. | console | warning | schema, speculative-retry, startup |
| Function doesn't support all-zero vectors. | validation | error | cassandra, vector-search, invalid-request |
| Input date is less than min supported date | validation | error | cassandra, serialization, date, range |
| Invalid comparator class | validation | error | cassandra, type-parser, configuration-exception, reflection |
| Not enough space to write | exception | critical | cassandra, disk-space, compaction, storage |
| Only free across all data volumes. Consider adding more… | console | warning | cassandra, disk-space, storage, capacity |
| QueryCancelledException(readCommand) | exception | warning | cassandra, sai, timeout, query |
| Source Keyspace ' ' doesn't exist | validation | error | cassandra, cql, create-table-like, keyspace-not-found |
| Transient replication is disabled. Enable in cassandra.yaml… | validation | error | configuration, replication, feature-flag, transient-replication |
| Unable to coerce ' ' to a formatted date (long) | validation | error | cassandra, serialization, date, invalid-date-format |
| Unknown keyspace: '" + keyspaceName + "' | validation | error | keyspace, accord, virtual-table, resource-not-found, cassandra |
| Zero vectors cannot be indexed or queried with cosine… | validation | error | vector-search, sai, invalid-request, cosine-similarity |
| Construction beam width | validation | error | cassandra, sai, vector-index, number-format, index-options |
| Could not resolve any streamCandidates node ids to… | exception | error | tcm, cms, streaming, endpoint-resolution |
| Dropping unsupported cipher_suite | console | warning | tls, cipher-suites, configuration, ssl |
| Invalid value for : maximum allowed value is | validation | error | guardrails, configuration, bounds |
| Keyspace " + keyspaceName + " does not exist | validation | error | keyspace, schema, illegal-argument, resource-not-found |
| Keyspace %r not found. | exception | error | cassandra, cqlsh, keyspace, schema-metadata, not-found |
| local_system_data_file_directory must not be the same as… | validation | critical | cassandra, configuration, directories |
| Materialized views are not supported on counter tables | validation | error | |
| Reverting to epoch | console | warning | recovery, cluster-metadata, destructive-operation |
| is not permitted to log in | exception | error | cassandra, authentication, roles |
| Unable to make inet address from | validation | error | cassandra, marshalling, inet, network |
| Unknown version: " + version | exception | error | versioning, accord, serialization |
| Can not add a new in-progress sequence for | exception | error | transformation-rejected, conflict, sequence, cluster-metadata |
| Cannot create materialized view | validation | error | |
| Cannot create table . with transactional mode with… | validation | error | cql, accord, schema, configuration |
| Cannot parse UDT value from | exception | error | |
| Cannot use CREATE TABLE LIKE on an index table | validation | error | cassandra, cql, create-table-like, index, unsupported-operation |
| commitlog_disk_access_mode = | validation | error | configuration, commitlog, compression, encryption |
| Counters are not allowed inside collections: | validation | error | cql, schema, counter, collection |
| Detected loop when processing key | validation | error | cassandra, configuration, yaml, cycle |
| Dictionary length mismatch for | exception | error | cassandra, compression, zstd-dictionary, corruption |
| Error while refreshing system.size_estimates | exception | error | jmx, nodetool, size-estimates, execution |
| Exception occurred updating coordinatorWriteLatency metric | console | warning | metrics, latency, logging |
| is not recommended | console | warning | guardrails, feature-flag, configuration |
| Frozen UDT column does not support field deletions | validation | error | cql, udt, frozen-type, unsupported-operation |
| Invalid ratio definition: | exception | error | cli, argument-validation, distribution |
| Invalid TTL value | validation | error | cql, ttl, type-mismatch |
| Node is not yet bootstrapped completely | exception | error | cassandra, startup, bootstrap |
| Non-system keyspaces don't have the same replication… | exception | warning | ownership, replication, nodetool |
| SSTable format name in | validation | error | sstable, configuration, plugin |
| Transient replication is not supported in mixed version… | validation | error | transient-replication, version-compatibility, cluster-upgrade |
| Unable to find class | exception | error | classpath, reflection, config |