apache/cassandra
Documented errors, page 11 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Storage-attached index is no longer queryable. Please… | console | warning | sai, index, queryability, restart-required |
| Token allocation failed: the number of racks | exception | error | token-allocation, replication-factor, racks |
| Unable to instantiate parameterized class | validation | error | configuration, reflection, instantiation |
| Within a transaction, SELECT statements must select a… | validation | error | cql, transactions, partition-key, validation |
| Can not initialize CMS without any seeds | exception | critical | tcm, seeds, configuration, startup |
| Can't enable audit log archiving via nodetool unless… | exception | error | security, configuration, audit-log, jmx |
| Cannot add field to type : a field with name already exists | validation | error | cql, udt, duplicate-field |
| cannot parse ' ' as hex bytes | validation | error | cassandra, marshal, collection, hex |
| Column ' ' doesn't exist | validation | error | cql, schema, alter-table |
| Error building row with data deserialized from | exception | error | |
| Error decoding JSON: | exception | error | json, deserialization, cassandra |
| failure for repair verb ; could not complete within attempts | console | warning | repair, messaging, retry-exhausted, network |
| Fast path strategy must either be 'keyspace', 'simple'… | validation | error | configuration, accord, fast-path |
| internode_max_message_size must no exceed… | validation | error | cassandra, configuration, internode |
| Invalid type for map value, expecting | exception | error | |
| Invalid value for the paging state | exception | error | protocol, paging, deserialization, client-request |
| Length must not be negative | validation | error | io, mmap, validation |
| No ORDER BY clause allowed within a transaction; | validation | error | cql, transactions, accord, validation |
| Node has host id in system.local, but is not present in… | exception | error | cluster-membership, stale-state, bootstrap |
| Out of order partition detected | console | warning | scrub, out-of-order, sstable, data-integrity |
| Ownership values for keyspaces with LocalStrategy are… | exception | error | ownership, system-keyspace, nodetool |
| SyncException (wraps IOException from disk writer… | exception | critical | disk, io, sstable, write, bulk-load |
| Unable to parse token range from ; format is left,right but… | validation | error | cli, argument-parsing, offline-tools |
| Used sytem property variable | console | warning | configuration, jvm, system-properties, typo |
| You must supply a table name | validation | error | snapshot, table, argument-validation |
| At most bytes may be in a compaction level; your… | validation | error | compaction, configuration, overflow |
| Cannot initialize class | validation | error | compression, class-initialization, native-library |
| Cannot parse UDT value from | exception | error | |
| Cannot specify as a CUSTOM option | validation | error | cql, index, reserved-keyword |
| Client driver , version is below recommended minimum version | console | warning | cassandra, guardrails, driver, version, upgrade |
| Duplicate column ' ' in CLUSTERING ORDER BY clause for view | validation | error | cql, materialized-view, clustering-order, duplicate-column |
| Error seeking to index offset for ordinal | exception | critical | cassandra, sai, vector-index, io |
| Exception occurred while writing to | exception | error | sstable, toc, filesystem, io |
| Failed to delete | console | warning | cache, filesystem, cleanup, permissions |
| Failed to import sstable | exception | error | sstable, import, corruption, io |
| Failed to read from | exception | critical | accord, journal, storage, io |
| Illegal file to fetch: | exception | error | security, path-traversal, jmx |
| Invalid bytes remaining after an end-of-component at… | validation | error | serialization, composite-type, data-corruption |
| Invalid node identifier supplied: | exception | error | cli, topology, dns, argument-parsing |
| Invalid null value of timestamp | validation | error | cql, timestamp, invalid-request |
| Keyspace [ ] does not exist. | validation | error | nodetool, keyspace, validation, cli |
| Not enough bytes to deserialize a tuple | exception | error | deserialization, tuple, cql |
| Not enough bytes to read a + name | validation | error | serialization, marshal, collection, corrupt-data |
| Not yet safe to use NON_DURABLE ReplayMode | exception | error | accord, journal, unsupported-operation |
| Receiving type does not match | validation | error | accord, type-mismatch, transaction-references |
| Timeout - task did not finish in | exception | error | timeout, future, async |
| Truncate timed out - received only | exception | error | timeout, truncate, replica-consistency, distributed |
| accord.working_set_size option was set incorrectly to | validation | error | config, startup, validation |
| Can't proceed from the state | exception | error | tcm, startup, state-machine |
| Commit log position must be given as | validation | error | commitlog, parsing, configuration, format |
| Could not find range for token in ReplicaGroups: | exception | error | tcm, ownership, token-metadata, illegal-state |
| Gossip not settled but startup forced by… | console | warning | cassandra, gossip, startup, jvm-flag |
| Invalid IP | validation | error | auth, cidr, ip-address, invalid-argument |
| Invalid sstable file | exception | critical | sstable, descriptor, version, filename-parsing |
| Keyspace and table of a dictionary to import | validation | error | compression, dictionary-import, argument-mismatch |
| metadata + " only supports single partition key queries" | validation | error | query-constraint, partition-key, virtual-table, accord-debug |
| Migration already initiated by | exception | error | cassandra, tcm, concurrency |
| must provide eventLoop | exception | error | network, netty, null-argument, bootstrap |
| Not currently a member of the CMS, can't commit | exception | error | tcm, cms, membership, commit, routing |
| The data cannot be deserialized as a list | validation | error | cassandra, serialization, collections, deserialization |
| Token " + token + " contains non-hex digits | validation | error | token, hex, configuration, validation |
| Too many nodes are currently DOWN to safely perform the… | exception | error | cluster-metadata, quorum, reconfiguration |
| Tried to hard link to file that does not exist | exception | error | io, hardlink, file-not-found |
| Unable to parse value | console | warning | config, guardrails, type-mismatch |
| Unable to retrieve initial location from cloud metadata… | validation | error | azure, cloud-metadata, snitch, configuration |
| Username provided but no password | exception | error | cli, configuration, credentials |
| is in use by another process. Change… | exception | critical | network, bind, port-conflict, configuration |
| Cannot parse tuple value from | exception | error | parsing, cql-literal, tuple |
| Cannot use CREATE TABLE LIKE on a materialized view | validation | error | cassandra, cql, create-table-like, materialized-view, unsupported-operation |
| case_sensitive option cannot be specified together with… | validation | error | sasi, index-options, conflicting-options, configuration |
| Commit log flush interval must be positive: %fms | exception | critical | commitlog, configuration, startup, validation |
| Could not copy file to | exception | critical | io, file-copy, filesystem |
| Error while getting seed node list | console | warning | cassandra, gossip, seeds, configuration, seed-provider |
| Final function doesn't exist | validation | error | cql, user-defined-function, schema |
| HintsService is shut down and cannot be restarted | exception | error | lifecycle, shutdown, dispatch, hints |
| Invalid compression dictionary kind | exception | error | cassandra, compression, deserialization, zstd-dictionary |
| Invalid specifier in | validation | error | accord, parsing, argument-format |
| No JmxConnect command found in the top-level hierarchy | console | error | cli, picocli, initialization |
| Not enough bytes to read a list | validation | error | cassandra, serialization, collections, list |
| Specified hosts do not share range needed for repair… | exception | error | repair, topology, hosts |
| Unknown commitlog version | exception | critical | commitlog, version-mismatch, replay |
| Unlogged batch covering | console | warning | cassandra, batch, performance, client-warning |
| Unrecognized fast path options provided: | validation | error | configuration, validation, accord |
| Unsupported collection type: | exception | error | accord, serialization, cql, types |
| CAS is supported only for type 'samerow' | validation | error | cli, lwt, configuration |
| Column was not found in table | validation | error | cql, schema, alter-table, column-not-found |
| Configuration contains options of unknown sstable formats | validation | error | configuration, sstable, cassandra-yaml |
| out of order partition (or partitions without of order… | console | warning | scrub, sstable, out-of-order, data-integrity |
| dc name must not be empty | validation | error | cassandra, accord, configuration, datacenter |
| Expected a long or a datestring representation of a date… | validation | error | json, date, marshal |
| Function ' ' must have directive | validation | error | cql, udf, or-replace, null-input |
| HostId read from local system table does not match the one… | exception | critical | upgrade, host-id-mismatch, cluster-metadata |
| Initiator schema different from our | console | warning | schema, distributed-consistency, migration, version-skew |
| Invalid timestamp value | validation | error | cql, timestamp, type-mismatch |
| Must provide outbound_keystore or outbound_private_key in… | exception | error | |
| Null MBeanServer | exception | error | jmx, null-argument, bootstrap |
| Postings list # block is corrupted. Bits per value should… | exception | error | cassandra, sai, index-corruption, postings |
| Selected sstable format | validation | error | configuration, sstable-format, upgrade-compatibility |
| There are multiple appenders of class | exception | error | logging, logback, configuration, startup |
| Transient replication is not supported with vnodes yet | validation | error | replication, vnodes, transient-replication, configuration |