apache/cassandra
Documented errors, page 15 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Trying to stream from wrong endpoint. Range: in keyspace … | exception | error | streaming, internal-bug, metadata |
| Unexpected characters between pos | validation | error | parsing, number-format |
| Unexpected extraneous bytes after set value | validation | error | cassandra, serialization, set, validation |
| Ambiguous call to function | validation | error | cql, function-resolution, ambiguity |
| Can't apply a ClusterMetadata from gossip when CMSState is… | exception | error | cluster-metadata, gossip-migration, service-state, precondition |
| CasWriteTimeoutException | exception | error | timeout, paxos, contention, lightweight-transactions |
| Event not valid for protocol version | exception | error | cql, protocol-version, events, register |
| Expected an int value, but got a | validation | error | cassandra, marshalling, json, int |
| Failed to load Bloom filter for SSTable: | exception | error | sstable, bloom-filter, corruption, io |
| Fast path strategy must either be 'simple', 'up' or a map… | validation | error | configuration, accord, fast-path |
| Function does not declare an argument named | exception | error | udf, java, argument-name |
| Invalid set literal for | validation | error | |
| Invalid sstable file | validation | error | sstable, filesystem, path |
| Empty keyspace, skipping repair | exception | warning | repair, skip, schema |
| Target Keyspace ' ' doesn't exist | validation | error | cassandra, cql, create-table-like, keyspace-not-found |
| The length of given vector value | validation | error | cqlsh, copy, vector, validation |
| The page size cannot be 0 | exception | error | cql, paging, protocol, invalid-request |
| The specified 'key' is not within the provided token value… | validation | error | cassandra, virtual-table, token, bounds |
| To be able to set enable_user_defined_functions_threads… | validation | error | config, udf, security |
| Unable to obtain private address for node from cloud… | validation | error | ec2, network, metadata-service, dns, startup |
| Unable to start GCInspector (currently only supported on… | console | warning | jvm, gc, monitoring |
| You have to enable role_name_policy and its… | validation | error | guardrails, config, roles |
| Can't abort bootstrap for node since the state is | exception | error | nodetool, bootstrap, node-state, node-lifecycle |
| Can't add full replicas if there are any transient… | validation | error | configuration, transient-replication, replication-factor, alter-keyspace |
| Can't enable full query log archiving via nodetool unless… | exception | error | security, configuration, fql, jmx |
| Cannot execute this query as it might involve data… | validation | error | cql, cassandra, filtering, indexing |
| Cannot set on non-regular table ' . | validation | error | cql, schema, invalid-request |
| Did not get response from | exception | error | cassandra, tcm, network |
| Error during joining the ring | console | critical | bootstrap, cluster, io |
| Failed to build trust manager store for secure connections | exception | error | |
| Invalid netmask for IP | validation | error | network, cidr, invalid-argument |
| Missing component | console | warning | cassandra, sstable, scrub, missing-file |
| Missing SAI index to import for index | exception | error | sai, sstable, import, index-build |
| Not running paxos repair for topology change because there… | console | warning | paxos, repair, topology-change, token-ranges |
| Rebuilding index summary because offset value | exception | warning | io, sstable, index-summary, endianness |
| SPARSE mode is only supported on non-literal columns. | validation | error | sasi, invalid-config-value, mode-mismatch, cassandra |
| The keyspace , does not exist | exception | error | keyspace, not-found, nodetool |
| Unable to initialize analyzer class option specified | validation | error | sasi, reflection, analyzer, configuration |
| Unrecognized strategy option | validation | error | configuration, replication, validation |
| Unsupported disk access mode for… | validation | error | configuration, storage, startup |
| vectorsByKey is not initialized | exception | error | vector-search, sai, illegal-state, internal |
| You shouldn't wrap the DynamicEndpointSnitch (within itself… | exception | error | snitch, unsupported-operation, configuration, routing |
| Can't commit transformations when running in gossip mode… | exception | error | cassandra, tcm, gossip |
| Commitlog segment is too old to open; upgrade to 1.2.5+… | exception | critical | commitlog, legacy, upgrade, filename |
| compressed_read_ahead_buffer_size must be at least 256KiB… | validation | error | cassandra, configuration, compression |
| Directory doesn't exist | console | error | startup, filesystem, directories, permissions |
| Failed to save Bloom filter for SSTable: | exception | error | io, sstable, bloom-filter, disk |
| GRANT operation is not supported by AllowAllAuthorizer | exception | error | cassandra, cql, ddl, user-type, name-conflict |
| Invalid map literal for | validation | error | cql, map, type-mismatch, validation |
| Invalid value for data_disk_usage_max_disk_size: 0 is not… | validation | error | config, guardrails, disk-usage |
| Invalid value for environment variable | exception | error | configuration, environment, enum |
| Only superusers can bind identities to a role with… | validation | error | auth, security, roles |
| Unable to recover partitions that were skipped. You can… | console | error | scrub, data-corruption, repair, data-loss |
| Unknown direction | exception | error | cqlsh, syntax-error, cli, copy-command |
| Allowing java.lang.System.* access in UDFs is dangerous and… | console | warning | cassandra, configuration, security, udf |
| Amount of transient nodes should be strictly positive, but… | validation | error | transient-replication, invalid-value, configuration |
| Bloom filter size is > 16GB, reduce the… | exception | error | bloom-filter, memory, configuration, cassandra |
| Cannot filter this table by partial partition key | validation | error | virtual-table, partition-key, accord, invalid-request, cassandra |
| Cannot parse 8-bits int value from | validation | error | parsing, tinyint, range, type-codec |
| Compression dictionary checksum does not match. Expected | exception | error | cassandra, compression, corruption, checksum |
| Concurrent accord operations must be non-negative | validation | error | configuration, validation, accord |
| Dictionary to import has older dictionary id | validation | error | compression, dictionary-import, versioning |
| Failed to create for . , reason | console | warning | cassandra, zstd, compression, dictionary-training |
| Failure validating the %dth field | validation | error | |
| MutualTlsInternodeAuthenticator requires… | exception | error | tls, mtls, configuration, internode-authentication |
| Non-fatal checksum error reading saved cache | console | warning | cache, corruption, startup, restart |
| prepared statements discarded in the last minute because… | console | warning | cql, cache, prepared-statements, capacity |
| Table . does not support dictionary compression | exception | error | compression, training, unsupported-operation |
| The min_compaction_threshold cannot be larger than the… | exception | error | cassandra, compaction, jmx, thresholds |
| Unknown parameter: | validation | error | nodetool, cli, validation |
| Unsupported SSTable version / | exception | error | sstable, versioning, offline-tools, io |
| Can not alter a keyspace to use MetaReplicationStrategy | validation | error | cql, keyspace, replication, schema |
| Can't open incompatible SSTable! Current version | exception | error | sstable, version-compatibility, upgrade |
| Cannot parse tuple value from | exception | error | parsing, tuple, cql-literal, syntax |
| Cannot specify tokens without keyspace. | console | error | nodetool, cli, argument-validation, rebuild |
| cdc_raw_directory must be specified | validation | error | config, cdc, startup |
| Column family not found | exception | error | cassandra, cqlsh, table, schema-metadata, not-found |
| commitlog_directory must be specified | validation | critical | configuration, commitlog, startup |
| default_keyspace_rf to be set | validation | error | configuration, guardrails, replication |
| Error decoding JSON value for | validation | error | cql, json, type-mismatch |
| Incomplete file: header stipulated | exception | error | io, eof, file-corruption, compression |
| Invalid key order: current | exception | critical | sstable, corruption, iteration |
| Materialized View failed to complete, sleeping 5 minutes… | console | warning | materialized-view, background-build, retry |
| Max profiling duration is | validation | error | validation, duration, async-profiler |
| no tracestate | exception | warning | tracing, timeout, session-expired |
| Value ' ' is not a valid blob representation | validation | error | cassandra, marshal, json, blob |
| Can not parse replication factor | validation | error | nodetool, cli, validation, replication |
| Cluster metadata is already initialized to | exception | error | cassandra, tcm, singleton, initialization |
| Could not reconfigure CMS, operator should run `nodetool… | console | warning | cms, topology, operator-action |
| Failed to submit background compaction task | exception | warning | compaction, executor, shutdown |
| Incremental repair session | exception | error | repair, incremental-repair, distributed-consensus, cassandra |
| Invalid datacenter:rack - | exception | error | cassandra, tcm, parsing |
| Invalid null key in map | validation | error | cassandra, json, map, null |
| Invalid remaining data after end of tuple value | validation | error | |
| Invalid value for CQL type | exception | error | udf, java, type-mismatch, serialization |
| Keyspace doesn't exist | validation | error | cassandra, cql, schema, keyspace, not-found |
| mTLS Authenticator only supports certificate based… | exception | error | unsupported-operation, mtls, api-usage |
| Non-hex characters in | validation | error | blob, hex, validation |
| null is not supported inside collections | validation | error | cassandra, serialization, collections, null-value |
| Queue is empty | exception | warning | queue, concurrency, no-such-element |