kubernetes/kops

Documented errors, page 21 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
error removing cluster from state store
console error state-store, s3, permissions
error rendering SSH key data
exception error linode, akamai, sshkey, resource-rendering
failed to load default aws config for STS client
exception error aws, route53, sts, config
found multiple routers with name
exception error openstack, neutron, router
loadbalancer support not available in this deployment
exception error
no container specified in
validation error azure, vfs, configuration, url-parsing
reading tree
exception error kops, vfs, readtree, permissions
SCW_ACCESS_KEY is required
validation error
Subnet did not have CIDR
exception error subnet, cidr, ipv6, aws
unexpected IP address type
exception error subnet, ipv4, ipv6
building yaml
exception warning yaml, marshaling, code-generation
creating NLB target group
exception error aws, elbv2, target-group, api-error
deleting load-balancer IP
exception error
DNSZone not set
validation error dns, validation, cluster-spec
error encoding public key
exception error
error getting IAM policy for project
exception error
error listing elb Tags
exception error aws, elb, tags, listing
error waiting for Subnet creation to complete
exception error
error writing file
exception error
expected exactly one subnet for GCE, got
validation error
Failed to create floating IP
exception error openstack, neutron, floating-ip, quota, create
failed to list cluster volumes
exception error scaleway, volumes, api-error, cloud-provider
found multiple Volumes with name
validation error aws, ec2, ebs, tags
hetzner cloud provider does not implement FindVPCInfo at…
error_code error
invalid google cloud URL (schema / host)
exception error
K8sClient not set
exception error kubernetes, client, drain, configuration
MockRoute53 not set
exception error testing, mock, route53, aws
reading private key
error_code error kops, ssh, file-io
unable to determine gcp project for cluster
exception error gcp, clusterapi, config-missing
unsupported cloud provider
console error ipv6, aws, nodeup, cloud-provider
already closed
exception error opentelemetry, lifecycle, file-io
could not determine any subnets for SpotInstanceGroup
validation error aws, spotinst, subnets, network
error building Akamai (Linode) tag filter
exception error
error building user data
exception error user-data, spotinst, bootstrap
error checking for existing RouteTableAssociation
exception error aws, route-table, reconciliation, wrapper-error
error listening on
exception error network, listen, port-in-use, grpc, server
error listing ELBs
error_code error aws, elb, classic-load-balancer, api-error
error modifying volume
error_code error aws, ec2, ebs, volume-resize
error reading from AWS metadata service
exception error aws, imds, metadata, network
error untagging IAMRole
exception error aws, iam, go, tags
failed to sign token data
error_code error gcp, tpm, signing, crypto
found multiple matches for asset
exception error asset-resolution, ambiguity, hash
getting process name
exception error otel, telemetry, linux, binary
getting VMSS VM
exception error azure, api, vmss, permissions
image has no root device name
validation error aws, ec2, ami, block-device, karpenter
instance group must have the same min and max size in…
validation error azure, autoscaling, instancegroup, vmss
InstanceGroupVFS Patch not implemented for vfs store
exception error vfs, patch, unimplemented, instancegroup
invalid google cloud URL (not compute)
exception error
IP version is incorrect
validation error aws, autoscaling, discovery, iam
locationStore= is only supported in tests
validation error config, memfs, tests, service-account
name is required
validation error cli, validation, missing-argument
Network with name not found
exception error
reading certificate
exception critical pki, filesystem, certificate, startup, kops-controller
SpotInstanceGroup cannot be in subnets of different Type
validation error aws, spotinst, subnets, network
the image for the hook exec action not set
validation error aws, autoscaling, detach
unable to determine architecture info for instance type
exception error aws, ec2, architecture
unknown zone for hetzner cloud, known zones are fsn1, nbg1…
validation error hetzner, zone, configuration
VMScaleSetVM is missing ID
exception error
VPC ID is required when InternetGateway is shared
validation error aws, internet-gateway, validation, config
building dynamic client
exception error kubernetes, dynamic-client, client-init, kubeconfig
cannot apply changes to TargetPool
exception error gcp, gce, targetpool, drift
creating resource group client
exception error azure, client-construction, configuration
error hashing data
exception error hashing, io, copy
error listing ports
exception error openstack, neutron, port-list, api
error looking up machine type info
exception error kops, aws, gpu, ec2, api
error reading user provided private key
console error filesystem, private-key, cli, kops
invalid addon location
validation error clusteraddons, url, parsing, validation
invalid google cloud URL (unexpected end)
exception error
metadata token was empty
exception error
no zones found in instance groups in cluster
exception error kops, cluster-api, zones, instance-groups
ResourceVersion not supported in InstanceGroupVFS::Get
exception error go, kops, vfs, invalid-options
writing header
exception error opentelemetry, file-io, disk
deleting role assignment
exception error azure, rbac, role-assignments, delete
error building IAM API client
exception error
error building storage API client
exception error
error creating Subnet
exception error
error deleting node
exception error kubernetes, node-deletion, rolling-update
error detaching instance
exception error cloud, detach, rolling-update
error encoding %T with structured encoder
exception error
error listing DNS zones
exception error dns, api-error, permissions, zone-lookup
error parsing BootConfig config response
exception error go, nodeup, yaml, schema
failed to get from ec2 meta-data
console error aws, imds, networking, ec2
fetching intermediate certificate from
http error http, azure, tls, aia-fetch, http-status
getting IP of server
exception error scaleway, instances, networking, api-error
no image found with name
exception error
no secrets found
exception error cli, kops, empty-result, not-found
role name length must be equal to 64 or less
validation error aws, iam, naming, validation, limits
secrets path is not cluster readable
exception error vfs, secrets, storage-permissions
unable to determine machine architecture for InstanceGroup
exception error kops, instancegroup, architecture, image
unable to resolve image
exception error aws, ec2, image-resolution, karpenter
Address was not found
exception error gce, load-balancer, address, not-found
creating metal IPAM controller
exception error metal, bare-metal, ipam, controller-runtime, startup
different types for copy target
exception error assets, files, type-conflict
Error appending tag to network
exception error openstack, neutron, tagging, network
error deleting LaunchTemplate
exception error aws, ec2, launch-template, deletion
error describing launch templates
exception error
error listing Nat Gateways
exception error aws, ec2, nat-gateway, api
error listing tags for EventBridge rule
exception error aws, eventbridge, iam, tags
error loading cloud
exception error
error reading SSH public key
exception error