kubernetes/kops
Documented errors, page 14 of 33. Back to kubernetes/kops
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to update /etc/hosts | console | error | nodeup, etc-hosts, filesystem, permissions |
| found multiple public subnets in zone | exception | error | kops, aws, subnet, topology, zone |
| getting info for | exception | error | |
| method CreateCluster not supported in server-side client | exception | error | go, unsupported-operation, kops, server-side-client |
| parsing private key | error_code | error | kops, ssh, key-parsing |
| renaming sftp file -> (with posix rename) | exception | error | ssh, sftp, rename, concurrency |
| unable to fetch Akamai (Linode) instance id | exception | error | |
| unable to run blkid | exception | error | openstack, config-drive, blkid, metadata |
| unhandled token type %T | exception | error | json, type-mismatch, streaming |
| writing body | exception | error | opentelemetry, file-io, disk |
| BuildFlagsList of value type not handled: %T | exception | error | reflection, flagbuilder, unsupported-type |
| cannot find DNS Zone | exception | error | dns, zone-not-found, configuration, route53 |
| delete server : waiting for instance after termination | exception | error | |
| error building kube-controller-manager pod | exception | error | |
| error fetching GCE managed instance group | exception | error | gce, node-identity, mig, api-error |
| error finding matching instance types | exception | error | instance-selector, filtering, aws |
| error listing EgressOnlyInternetGateways | error_code | error | aws, ec2, ipv6, networking |
| error parsing target group ARN | exception | error | aws, elbv2, arn-parsing, config |
| error reading expected RolePolicyDocument for IAMRole | exception | error | aws, iam, resource-read, state-store |
| failed to delete instance IP | exception | error | scaleway, delete, api-error, permissions |
| failed to find instance type details on | exception | error | aws, ec2, instance-types, configuration |
| failed to find network for server group | exception | error | hetzner, network, servergroup, config, nil-reference |
| MockAWSCloud DefaultInstanceType does not handle | exception | error | testing, mock, instancegroup, configuration |
| Multiple servers found with name | exception | error | |
| no keypairs found | console | error | keypairs, empty-result, cli |
| unable to determine IP address for kube-apiserver | exception | error | kops, kube-apiserver, load-balancer, dns, ip-address |
| cannot parse VFS path | exception | error | aws, s3, vfs, kops, url-parsing |
| cannot set field | exception | error | reflection, type-conversion, setstring |
| could not get name from ClusterPackage | validation | error | go, kops, clusterpackage, validation, model-builder |
| discovery CA creation failed | exception | error | pki, ca, keystore |
| error creating IAMRole | exception | error | aws, iam, go, kops |
| error creating keyset | exception | error | go, kubernetes, api-server, keyset, create |
| error creating/updating IAMRolePolicy | exception | error | aws, iam, api-error, kops-apply |
| error marshaling yaml | error_code | error | cli, serialization, yaml, dump |
| error parsing Cluster | console | error | serialization, cluster-spec, codec |
| failed to list ssh keys | exception | error | digitalocean, ssh, api-error, list-operation |
| found VMSS without IP config subnet | exception | error | azure, vmss, subnet |
| keyset not found | exception | error | keyset, not-found, cli, validation |
| Openstack cloud pools with multiple loadbalancers not yet… | exception | error | openstack, octavia, loadbalancer-pool, unsupported |
| resolving root device for | exception | error | karpenter, root-device, ami, kops |
| SCW_DEFAULT_PROJECT_ID has to be set | validation | error | |
| server-side addons client does not support Addons::Replace | exception | error | addons, clientset, unsupported-operation |
| unable to parse Non Masquerade CIDR | validation | error | networking, cidr, validation, proxy |
| AsBytes called on nil Certificate | exception | error | |
| building | exception | error | nodeup, model-builder, configuration |
| Error creating router interface | exception | error | openstack, router-interface, neutron, api-error |
| error during apply | exception | error | kops, apply, dry-run, asset-builder |
| error loading default AWS config | exception | error | aws, credentials, aws-sdk-go-v2, controller |
| error parsing RecommendedVersion | exception | error | kops, channel, version-parsing |
| error reading ' ' on config drive | exception | error | openstack, config-drive, file-read, metadata |
| failed to build ephemeral devices | exception | error | aws, launch-template, ephemeral-storage, instance-type |
| found multiple Instances with name | exception | error | aws, ec2, duplicate-resources, tagging |
| found no ElasticIPs for | exception | error | aws, ec2, elastic-ip, not-found |
| No suitable flavor for role | exception | error | openstack, nova, flavor, instance-type |
| not all objects were applied | exception | error | kubernetes, apply, applyset, partial-failure |
| SSH key task has unexpected type %T | exception | error | type-assertion, hetzner, sshkey, kops |
| unable to hash file downloaded | exception | warning | go, sha, hashing, asset-copy |
| updating encryptionconfig secret | console | error | cli, storage, secret, state-store, kops |
| waiting for resource group deletion completion | exception | error | azure, long-running-operation, resource-groups, polling |
| waiting for VMSS create/update | exception | error | azure, go, vmss, compute, long-running-operation |
| challenge.ca not set | exception | error | bootstrap, validation, tls, missing-config |
| error deleting node | exception | error | kubernetes, node-delete, api, rolling-update |
| error deleting Subnet | exception | error | aws, ec2, vpc, subnet-deletion |
| error opening file | exception | error | hashing, filesystem, permissions |
| error reading tag file | exception | error | network, http, kubernetes-version, vfs |
| error rendering PolicyDocument | exception | error | iam, policy-document, size-limit |
| error writing temp file | exception | error | filesystem, temp-file, disk-full, os |
| failed to create certificate | exception | error | tls, x509, certificate, challenge |
| failed to parse objects | exception | error | yaml, manifest, parsing, validation |
| found multiple RouteTables matching tags | exception | error | aws, ec2, routetableassociation, invariant |
| KubernetesPath::RemoveAll not supported | exception | error | |
| reading data | exception | error | |
| role does not have ServiceAccount | validation | error | |
| unable to configuration file | exception | error | cli, filesystem, missing-file |
| unexpected IP address type for ServiceClusterIPRange | validation | error | networking, ipv6, cidr |
| determining certificate alternate names for node | exception | error | |
| error finding port | exception | error | |
| error listing Pods | exception | error | go, kubernetes, pods, rbac, kops |
| error opening file over sftp | exception | error | ssh, sftp, file-not-found, vfs |
| error reading etcd manifest | exception | error | nodeup, etcd, vfs, s3, manifest |
| error removing file/marker versions | exception | error | aws, s3, versioning, object-lock, partial-failure |
| error rendering instances | exception | error | |
| error storing user provided keys | console | error | keystore, state-store, write-failure |
| error writing to stdout | exception | error | io, stdout, broken-pipe |
| failed to build manifest path. Path was empty | exception | error | kubelet, static-pods, config-validation |
| found forwardingRule | exception | error | |
| KubernetesPath::ReadTree not supported | exception | error | |
| must specify a unique zone for instancegroup | validation | error | |
| snippet cannot have the same name as the template | validation | error | templating, naming-conflict |
| subnet has unexpected CIDR | validation | error | network, cidr, validation, kops |
| subnet has unknown type | validation | error | network, subnet, configuration, kops |
| unknown arch for CNI plugin binaries asset | exception | error | kops, cni, architecture, unsupported-platform |
| unknown providerID | exception | error | azure, providerid, validation, node |
| Azure subscription ID is empty | validation | error | |
| building kube client | exception | error | kubernetes, client-init, kubeconfig, tls |
| cannot allocate CIDR of size | exception | error | cidr, network, capacity |
| could not get cloud tags for instance group | exception | error | |
| error building Akamai (Linode) SSH key task | exception | error | linode, ssh, model-builder |
| error building compute API client | error_code | critical | gcp, gce, api-client, credentials |
| error creating secret | exception | error | secrets, crypto, entropy |