kubernetes/kops
Documented errors, page 12 of 33. Back to kubernetes/kops
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| loading Scaleway config file | exception | error | |
| spotinst: unable to resolve image | exception | error | spotinst, aws, ami, image-resolution |
| subnet and have the same zone | validation | error | aws, subnet, availability-zone, validation, cluster-creation |
| unable to remap asset | exception | error | containerd, asset-remap, mirroring |
| unhandled type | exception | error | go, reflection, unsupported-type |
| waiting for public ip address deletion completion | exception | error | azure, long-running-operation, delete, polling |
| checking user-data differences in server | exception | error | |
| cloud cannot be nil | exception | error | |
| error deregistering target | exception | error | aws, elbv2, target-group, deregister |
| error listing Akamai (Linode) VPCs | exception | error | linode, vpc, list, api-error, network |
| error serializing keyset | exception | error | serialization, keystore, yaml, kops-api |
| Error updating security groups on Load Balancer | exception | error | aws, elbv2, load-balancer, security-group |
| failed to apply resource record set | exception | error | |
| failed to delete network | exception | error | hetzner, network, deletion, cloud-api |
| failed to parse GetCallerIdentity ARN | exception | error | aws, sts, arn, parsing |
| featureGates | exception | error | kubelet, feature-gates, config-parsing |
| found multiple packages in channel for name= | exception | error | kops, channel, addons, duplicate-package |
| generating ecdsa key | exception | error | crypto, tls, key-generation, entropy |
| got retryable error while deleting tags on | exception | warning | aws, ec2, tags, eventual-consistency, retry-exhausted |
| KubernetesPath::WriteFile not supported | exception | error | |
| querying IMDS | exception | critical | azure, imds, network, connection-refused, timeout |
| spotinst: failed to update ocean | exception | error | spotinst, aws, cluster-update, api-error |
| unable to fetch metadata | exception | error | openstack, metadata, authentication, instance |
| unsupported legacy containerd version | exception | error | containerd, version-support, upgrade |
| creating/updating route table | exception | error | azure, network, route-table |
| encoding public key | exception | warning | pki, pem, keyset |
| Error creating keypair | exception | error | openstack, keypair, nova, api-error |
| error getting Instance | exception | error | gce, gcp, instances, api-error, kops |
| error marshaling kubeconfig to yaml | exception | error | nodeup, kubeconfig, yaml |
| error parsing | exception | error | codec, deserialization, cluster-config, yaml |
| failed to delete droplet | exception | error | digitalocean, droplet, api-error |
| Failed to get fixed ip for associated pool | exception | error | openstack, nova, neutron, loadbalancer, retry |
| failed to get info for load balancer | exception | error | hetzner, load-balancer, api |
| field Name not found in %T | exception | error | reflection, struct-field, go |
| public IP address referenced by security rule does not have… | validation | error | |
| unexpected number of frontend configs found for LoadBalancer | exception | error | |
| unknown output format | exception | warning | io, json, output |
| cannot determine hash for | exception | error | assets, hashing, download, kubernetes-release |
| disk not found | exception | error | gce, disk, not-found |
| error parsing ManagedFile Base | exception | error | vfs, parsing, config |
| Failed to create new Network object | exception | error | openstack, neutron, network, task-construction |
| KubernetesPath::Remove not supported | exception | error | |
| linode subnets and normalize to the same label | validation | error | linode, subnet, naming, label-normalization |
| listing nodes in cluster | console | error | kubernetes, api-server, network, connectivity |
| %T is not a *compute.BackendService | exception | error | gce, type-assertion, backend-service, internal-invariant |
| unable to locate asset | exception | error | nodeup, assets, kubectl |
| unexpected error fetching tags for resource | exception | error | aws, elbv2, tags |
| unhandled type | exception | error | go, reflection, unsupported-type |
| different sources for same image target | exception | error | assets, images, deduplication |
| error creating temp file in | error_code | error | filesystem, vfs, permissions |
| error fetching | exception | error | network, http, fetch |
| error listing tags | exception | error | aws, ec2, nat-gateway, tags, discovery |
| error parsing configStore.base | exception | critical | config, state-store, vfs, parsing |
| error updating Healthcheck | exception | error | gce, healthcheck, operation-wait |
| failed to list cluster ssh keys | exception | error | scaleway, iam, ssh-keys, api-error |
| failed to list domains | exception | error | digitalocean, dns, api-authentication |
| failed to list storage availability zones | exception | error | openstack, availability-zones, api-error |
| Forbidden: cannot register node name | http | error | http, authz, mtls, forbidden, naming |
| found group with unexpected name | exception | error | instancegroups, delete, cloud-api, name-mismatch |
| found server ( ) with unexpected state | exception | error | scaleway, node-identity, instance-state |
| lifecycle set to ExistsAndValidates, but object did not… | exception | error | lifecycle, drift, task-engine, exists-and-validates |
| must update terraform state for 0.12, and then pass… | error_code | error | terraform, ebs, state-migration, env-var |
| PKCS7 signer certificate not found | validation | error | azure, pkcs7, certificate, attestation |
| timed out waiting for instances in MIG | exception | error | gce, instance-groups, timeout, mig |
| unexpected response from | http | error | |
| cannot parse file mode | validation | error | |
| could not find instance | console | error | kops, instance-groups, cli, identifier-not-found |
| DIGITALOCEAN_ACCESS_TOKEN is required | error_code | error | aws, ec2, autoscaling, tagging |
| error adding audience | exception | error | aws, iam, oidc, reconcile |
| error building DNS API client | exception | error | |
| error building kubelet flags | exception | error | kubelet, flags, nodeup, systemd |
| error converting public key to x509 | exception | error | crypto, x509, pki, key-format |
| error creating sftp client (at stdout pipe) | exception | error | |
| error finding deletions | exception | error | cloud-api, iam, lifecycle |
| error finding launch template or configuration for… | exception | error | |
| error reading addon manifest | exception | error | addons, bootstrap-channel, io |
| failed to initialize digitalocean cloud | exception | error | digitalocean, authentication, api-token, configuration, kops |
| failed to list layer 3 floating ips | exception | error | openstack, neutron, floating-ip, list, reconcile |
| unexpected object type: %T | console | error | yaml, type-assertion, cli |
| applying kubeconfig secret to cluster | exception | error | kubernetes, rbac, server-side-apply, secret |
| cannot use both --admin and --user | validation | error | cli, flags, kubeconfig |
| cluster DeleteCollection not implemented for vfs store | exception | error | vfs, unimplemented, deletecollection, clientset |
| EgressOnlyInternetGateway, InternetGateway, Instance… | validation | error | aws, route, validation, missing-target |
| error querying EC2 for user metadata for instance | exception | error | aws, ec2, iam-permissions, api-error |
| error reading target-lifecycle-state from instance metadata | exception | error | aws, metadata, nodeup |
| error updating AutoscalingGroup | exception | error | aws, autoscaling, cloud-api, kops |
| failed to list load balancers | exception | error | hetzner, load-balancer, api, cloud-provider |
| found VMSS without Linux config | exception | error | azure, vmss, osprofile, ssh |
| instancegroup not found | console | error | |
| listing IPs for deletion | exception | error | scaleway, api-error, network, credentials |
| ResolveS3Region must be called before building a nodeup… | exception | error | s3, region, initialization-order, nodeup |
| already started | exception | error | opentelemetry, lifecycle, exporter |
| creating public ip addresses client | exception | error | azure, client-construction, configuration |
| error creating ForwardingRule | exception | error | gce, forwarding-rule, api-error, creation |
| error creating ServiceAccount | exception | error | gce, gcp, iam, service-account, api-error |
| error deleting loadbalancer | exception | error | openstack, octavia, loadbalancer, api-error |
| error getting IAMInstanceProfile | exception | error | aws, iam, kops, lookup |
| error parsing channel | exception | error | kops, channel, yaml, parsing |
| failed to list firewalls | exception | error | hetzner, firewall, api, cloud-provider |
| failed to list volumes | exception | error |