benbjohnson/litestream

Documented errors, page 5 of 6. Back to benbjohnson/litestream

Code / MessageTypeSeverityTags
write page to hydrated file
exception error io, filesystem, disk, vfs
apply ltx to hydrated file
exception error replication, ltx, apply
failed to access object store bucket
exception error nats, jetstream, object-store, resource-not-found
find LTX snapshot
exception error restore, ltx, snapshot-selection, pitr
host required for sftp replica
validation error config, sftp, litestream, ssh
remove expired l0 files
exception error storage, deletion, l0-retention
cannot parse exec command
exception error exec, parsing, config
database does not exist
console error
enforce retention for
console error
failed to expand meta dir for
exception error config, litestream, env-var, expansion
stage-open
: (ErrDiskFull)
error_code critical disk-full, filesystem, staging
write txid file
exception error
parse hydration meta
exception warning parsing, filesystem, hydration
s3: cannot use both sse-customer-key and sse-kms-key-id…
validation error
cannot write to lock page
exception error write-path, lock-page, sqlite-internals, litestream
failed to delete object
exception error
invalid wal header magic
exception error sqlite, wal, corruption, magic-number
decode ltx page
exception error ltx, decode, page, corruption
enable database
exception error context, cancellation, database
http request
exception warning http, network, heartbeat, timeout
s3: get object
exception error
webdav: cannot create temp file
exception error filesystem, temp-file, disk
cannot specify -enforce-retention flag without -once
validation error cli, flags, validation
s3: cannot load aws config for region lookup
exception error
cannot specify 'replica' and 'replicas' on a database
validation error config, replica, deprecated, litestream
ltx files
exception error storage, replica-client, list-files
new wal reader
exception error sqlite, wal, corruption
read ltx header
exception error ltx, header, storage
abs: cannot create shared key credential
exception error abs, azure, shared-key, credentials
bucket required for s3 replica URL
validation error
cannot read wal header
exception error wal, header, salt, read
marshal lock file
exception error
poll L0
exception error storage, replication, polling
age encryption is not currently supported, if you need…
validation error config, encryption, deprecated, replica
failed to discard offset bytes
exception error
parse replica url
exception error config, url, parsing
sync
exception error
close ltx file
exception error close, io-error, filesystem
ensure wal exists
exception error
sync temp meta file
exception warning fsync, filesystem, durability
begin passive checkpoint barrier
exception error sqlite, checkpoint, database-locked, transaction
cannot resume follow mode: database exists but no -txid…
exception error
delete lease
exception error
failed to list objects
exception error
rename L0 file
exception error litestream, filesystem, rename, atomic, l0
stage-mkdir
: (ErrDiskFull)
error_code critical disk-full, filesystem, staging
close level 0 ltx iterator
exception error
invalid scheme for NATS replica
validation error config, nats, url, litestream
multiple replicas on a single database are no longer…
validation error config, replica, deprecated, migration, litestream
stat wal before sync
exception error
cannot resume follow mode: saved TXID
exception error
create table
exception error sqlite, sql, ddl
page map
exception error sqlite, wal, page-map
cannot specify url & webdav-url for webdav replica
validation error config, webdav, litestream, validation
db path required
exception error api, path, validation, store
invalid poll_interval
validation error go, config, duration, validation
invalid value for query parameter
validation error
no snapshots available
error_code error restore, snapshot, replica, storage
webdav: cannot create parent directory
exception error webdav, mkdir, permissions
apply ltx file (level= , min= , max= )
exception error
cannot specify url & path for webdav replica
validation error config, webdav, litestream, validation
get lock file
exception error
invalid timestamp (expected RFC3339 or relative time like…
validation error
abs: account name is required when endpoint is not specified
validation error abs, azure, configuration, endpoint
find LTX snapshots
exception error restore, ltx, snapshot-selection, storage-backend
restore failed
console error
sync L0 file
exception error litestream, filesystem, fsync, disk-full, durability
webdav: cannot copy to temp file
exception error filesystem, io, stream
webdav-url required for webdav replica
validation error config, webdav, litestream, validation
cannot verify wal state
exception error
read existing lease
exception error
cannot specify -force-snapshot flag without -once
validation error cli, flags, validation
database already enabled
exception warning database, state, duplicate-operation
database config # : cannot specify both 'meta-path' and…
validation error config, validation, litestream
failed to expand meta path
exception error config, env, litestream
bucket required for abs replica URL
validation error abs, azure, url, configuration
cannot specify url & path for oss replica
validation error oss, config, ambiguous
invalid -timestamp, must specify in ISO 8601 format (e.g…
validation error cli, timestamp, restore, validation
invalid unlock target
exception error
bucket required for gs replica URL
validation error config, url, gcs, validation
copy L0 file
exception error litestream, network, io, ltx, object-storage
fetch l0 files
exception error storage, retention, listing, network
list ltx files for catch-up
exception error network, storage, replication
read ltx page frame
exception error storage, ltx, io, network
s3: sse-customer-key must be valid base64
validation error
cannot expand path , no home directory available
exception error path, home-directory, config, unix
cannot read last synced wal page
exception error wal, frame, read, offset
poll L1
exception error storage, replication, polling
cannot create replica for restore
console error
cannot read sse-customer-key-path
exception error
invalid txid format
validation error cli, txid, hex, flag-parsing
_litestream_lock
exception error sqlite, checkpoint, lock-table, sql
write updated page
exception error io, filesystem, disk, vfs
acquire exclusive lock
exception error
begin transaction
exception error sqlite, transaction, database
user required for sftp replica
validation error config, sftp, litestream, authentication
abs: cannot start new reader for
exception error
cannot specify url & host for sftp replica
validation error config, sftp, litestream, validation
decode ltx header
exception error vfs, ltx, corruption, header
read txid file for crash recovery
exception error