ErrLookup › benbjohnson/litestream
benbjohnson/litestream
Streaming replication for SQLite. · Go · 74 source files
Analyzed at 4ed7a308f6 on 2026-09-06. 554 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| driver does not implement FileControl | exception | error | sqlite, driver, type-assertion, dependency-version |
| FileControlPersistWAL | exception | error | sqlite, file-control, persist-wal, driver |
| could not parse time | validation | error | go, sqlite, vfs, pragma, time-parsing |
| cannot create database from config | console | error | cli, config, reset |
| rollback passive checkpoint barrier | exception | error | sqlite, checkpoint, transaction, rollback |
| cannot access SQLite sidecar path | console | error | filesystem, permissions, restore, sqlite |
| s3: cannot lookup bucket region | exception | error | |
| init per-connection replica client | exception | critical | replica-client, initialization-failure, cloud-storage, resource-cleanup |
| get initial size | exception | error | filesystem, sqlite, stat |
| snapshot interval must be greater than 0 | validation | error | go, configuration, validation, snapshot |
| set PERSIST_WAL | exception | error | sqlite, init, persist-wal, error-wrapping |
| failed to create GCS client | exception | critical | gcs, authentication, cloud-storage, initialization |
| failed to marshal request | console | error | json, ipc, cli, internal |
| max retries exceeded reading ltx file | exception | error | storage, retry, replication, throttling |
| open db file descriptor | exception | error | filesystem, file-descriptor, permissions, locking |
| invalid v0.3.x snapshot filename | exception | error | filename-parsing, v0-3-migration, validation |
| remove existing output path | console | error | filesystem, permissions, restore, sqlite |
| : expected TXID but remote has | exception | critical | go, conflict, replication, distributed |
| get connection | exception | error | database, connection-pool, context, sqlite |
| no replica client configured: set LITESTREAM_REPLICA_URL… | exception | critical | vfs, configuration, missing-config, replica-client |
| cannot use -dry-run with -f | validation | error | cli, flags, restore |
| database config required | validation | error | go, configuration, nil-argument, directory-monitor |
| write to buffer | exception | critical | go, storage, write-buffer, disk-full, sqlite-vfs |
| disk full | error_code | critical | disk-space, filesystem, replication, enospc |
| write snapshot ltx | exception | error | go, sqlite, ltx, snapshot, file-io |
| count rows | exception | error | sqlite, sql, database, test-tooling |
| %w: %s | validation | error | config, file, startup |
| snapshot wal read exceeded bound: max offset | exception | error | go, sqlite, wal, race-condition, invariant |
| open database | exception | critical | sqlite, cgo, driver, database-open |
| set page size | exception | error | sqlite, pragma, cli |
| cannot run windows service as unix process | panic | critical | windows, platform, panic, cli |
| webdav: cannot delete ltx file | error_code | error | webdav, storage, deletion, network |
| wait for replica sync | exception | error | replication, context-cancelled, concurrency |
| abs: cannot delete ltx file | exception | error | azure, storage, delete, network, permissions |
| create temp dir for hydration | exception | error | go, filesystem, temp-directory, vfs |
| failed to configure replica | exception | error | config, replica, startup, deprecated |
| cannot delete vfs file | exception | error | go, vfs, file-delete, sqlite |
| enable wal failed, mode= | exception | error | sqlite, wal, pragma, journal-mode |
| cannot access output path | console | error | filesystem, permissions, restore |
| decode page | exception | error | ltx, corruption, replication, restore |
stage-sync : (ErrDiskFull) | error_code | critical | disk-full, filesystem, fsync, storage |
| sync hydration meta directory | exception | error | filesystem, fsync, durability, hydration |
| list v0.3.x snapshots for generation | exception | error | restore, v0-3-compat, storage-backend, snapshot-listing |
| dry run failed | console | error | cli, filesystem, dry-run |
| failed to connect to control socket | console | error | network, ipc, unix-socket, cli |
| local position | exception | error | database, sqlite, error-wrapping, position |
| get database position | exception | error | litestream, ltx, filesystem, position |
| invalid v0.3.x WAL segment filename | exception | error | filename-parsing, wal, v0-3-migration |
| reset failed | console | error | cli, filesystem, destructive-operation |
| read header | exception | error | sqlite, wal, file-io, checksum |
| validate level for | exception | error | go, litestream, validation, storage |
| reacquire read lock | exception | error | read-lock, checkpoint, sqlite-busy, locking |
| snapshot retention must be greater than 0 | validation | error | go, configuration, validation, retention |
| vacuum | exception | error | sqlite, vacuum, disk-space, locking |
| delete rows | exception | error | sqlite, delete, database-locked, test-tooling |
| failed to format response | exception | error | json, serialization, cli, litestream |
| open ltx file | exception | error | storage, replica-client, restore, file-not-found |
| close iterator | exception | error | storage, ltx, iteration, network |
| remote has newer transactions than expected | error_code | error | conflict, vfs, replication, stale-state |
| clear write buffer | exception | error | go, vfs, write-buffer, disk-io |
| create _litestream_seq table | exception | error | sqlite, database, init, sql |
| validation failed | exception | error | replication, integrity, validation, disaster-recovery |
| cannot determine current position | exception | error | replication, database, sync |
| create per-connection replica client | exception | critical | replica-client, url-parsing, vfs, configuration |
| checkpoint | exception | error | sqlite, wal, checkpoint, pragma |
| no matching backup files available | console | error | restore, backup, point-in-time, empty-result |
| rollback post-checkpoint tx | exception | warning | sqlite, transaction, rollback, checkpoint |
| replica required before opening database | exception | error | database, replication, validation, configuration |
| no backups found | exception | error | restore, no-backups, empty-replica |
| sync txid file | exception | error | filesystem, fsync, durability, litestream |
| hash temp name | exception | info | go, hashing, defensive-code, vfs |
| cannot copy wal after passive checkpoint | exception | error | wal, checkpoint, sync, replication |
| remove stale hydration meta | exception | error | go, filesystem, hydration, cleanup |
| invalid snapshot path | exception | warning | integer-overflow, hex-parsing, v0-3-migration |
| webdav: cannot delete path | exception | error | webdav, delete, permissions, http |
| abs: cannot create default azure credential | exception | error | |
| close ltx snapshot encoder | exception | error | go, ltx, pipe, encoder, snapshot |
| open temp ltx file | exception | error | filesystem, ltx, replication |
| read position before sync | exception | error | go, litestream, database, sync |
| flag must be positioned before DB_PATH and REPLICA_URL… | validation | error | cli, flag-ordering, argument-parsing |
| enforce L retention | exception | error | go, litestream, retention, storage |
| read hydrated file | exception | error | io, filesystem, vfs, sqlite |
| sync before disable | exception | error | go, sqlite-vfs, sync, replication, network |
| close db | exception | error | database, close, lifecycle |
| database does not exist | validation | error | cli, sqlite, file-not-found |
| database not found in config | console | error | config, restore, cli, path |
| get size after delete | exception | error | filesystem, sqlite, stat |
| invalid connection mapping | exception | error | vfs, internal, type-mismatch |
| set journal mode | exception | error | sqlite, pragma, database |
| sync database | exception | error | go, litestream, sync, replication |
| after attempts | exception | warning | shutdown, signal, replication, retry |
| begin | exception | error | sqlite, transaction, checkpoint, context-timeout |
| database config # : 'watch' can only be enabled with a… | validation | error | config, validation, litestream |
| bucket required for abs replica | validation | error | config, azure, litestream, validation |
| close txid file | exception | error | filesystem, file-close, durability, litestream |
| failed to list objects in GCS bucket | exception | error | gcs, cloud-storage, permissions, listing |
| shutdown sync timeout after | exception | error | shutdown, timeout, replication, retry, network |
| sync interval must be greater than 0 | validation | error | go, configuration, validation, replication |
| create temp dir for write buffer | exception | error | filesystem, temp-dir, vfs, permissions |
| timestamp does not exist | exception | error | restore, timestamp, validation |