benbjohnson/litestream
Documented errors, page 4 of 6. Back to benbjohnson/litestream
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| sync ltx dir | exception | error | fsync, durability, filesystem, directory |
| write hydration meta | exception | warning | io, filesystem, hydration |
| write txid | exception | error | restore, filesystem, file-write, disk-full |
| context cancelled while waiting for transaction | exception | warning | go, context-cancellation, sqlite-vfs, shutdown |
| timeout waiting for transaction to complete | exception | warning | go, timeout, sqlite-vfs, transactions |
| replica path cannot be a url, please use the 'url' field… | validation | error | config, replica, url, migration |
| sync before truncate | exception | error | filesystem, fsync, durability, io |
| bucket required for nats replica URL | validation | error | nats, config, url |
| init write buffer | exception | error | go, file-open-failed, write-buffer, permissions, sqlite-vfs |
| verify | exception | critical | corruption, checksum, restore, ltx |
| create index | exception | error | sqlite, index, ddl |
| info failed | http | error | http, server-error, ipc |
| WALReader.ReadFrame(): buffer size | exception | error | sqlite, wal, buffer, page-size |
| database not found | exception | error | database, not-found, path |
| failed to create JetStream context | exception | error | nats, jetstream, config, server |
| fetch page | exception | error | go, storage, ltx, network |
| litestream_lag is read-only | exception | error | go, sqlite, pragma, read-only, replication-lag |
| output path required | exception | error | restore, validation, required-argument |
| invalid -integrity-check value | validation | error | cli, flags, enum, restore |
| last page match | exception | error | wal, ltx, verification, page-match |
| list level ltx files | exception | error | storage, s3, network, replication |
| no backup files available | exception | error | time-travel, restore-plan, retention, empty |
| s3: sse-customer-key requires HTTPS endpoint (HTTP only… | validation | error | |
| read wal header after expected truncation | exception | error | wal, checkpoint, truncation, header |
| webdav: cannot read directory | exception | error | webdav, directory, list, http |
| failed to parse response | exception | error | json, http, version-mismatch |
| new ltx compactor | exception | error | ltx, compaction, invalid-argument |
| open remote L0 file | exception | error | litestream, replica, object-storage, network, ltx |
| rename to output path | exception | error | go, restore, filesystem, rename, atomic |
| ltx file corrupted | error_code | critical | ltx, corruption, ltx-format, recovery |
| must specify replica for database | validation | error | config, replica, litestream |
| webdav: cannot connect to server | exception | error | webdav, network, connectivity, http |
| write ltx from db | exception | error | ltx, snapshot, io-error, replication |
| bucket required for gs replica | validation | error | |
| close database | exception | error | database, close, cancellation |
| close l1 iterator | exception | error | iterator, storage, listing, pagination |
| detect full checkpoint | exception | error | wal, checkpoint, salt, detection |
| new wal reader with offset | exception | error | sqlite, wal, offset |
| bucket required for NATS replica | validation | error | nats, config, replica, missing-field |
| cannot expand home directory for sse-customer-key-path | exception | error | |
| cannot specify url & bucket for abs replica | validation | error | |
| invalid NATS URL | validation | error | config, nats, url, litestream |
| abs: container name is required | validation | error | abs, azure, configuration, container |
| create parent directory | exception | error | filesystem, mkdir, permissions |
| ltx file missing | error_code | error | ltx, missing-file, recovery, reset |
| file replica path required | validation | error | config, url, file-replica, validation |
| oss: delete batch of | exception | error | oss, delete, permissions, storage |
| remove ltx directory | exception | error | filesystem, permissions, reset, local-state |
| new wal reader, after reset | exception | error | sqlite, wal, corruption |
| check database behind replica | exception | error | |
| decode header | exception | error | ltx, decode, corruption |
| frame salts until | exception | error | sqlite, wal, io |
| non-contiguous ltx file: level= | exception | critical | replication, txid-gap, consistency |
| target time required | validation | error | time-travel, argument-validation, timestamp |
| connection not registered | exception | error | vfs, registration, connection |
| parse query string | exception | error | s3, url, query-string, parsing |
| s3: bucket name is required | validation | error | |
| s3: rewind ltx file | exception | error | s3, io, seek, file |
| fetch l1 files | exception | error | storage, compaction, retention, network |
| oss: get object | exception | error | oss, network, read, storage |
| oss: list objects page | exception | error | oss, list, pagination, storage |
| snapshot | console | error | |
| webdav: cannot write file | exception | error | webdav, upload, http |
| abs: cannot upload ltx file | exception | error | |
| failed to get object | exception | error | |
| client-cert and client-key must both be specified for… | validation | error | nats, tls, mutual-tls, config |
| failed to create DB for | exception | error | litestream, directory-replication, initialization |
| gs: cannot delete ltx file | exception | error | gcs, cloud-storage, retention, delete |
| oss: delete all batch of | exception | error | oss, delete, permissions, batch |
| recreate L0 directory | exception | error | litestream, filesystem, mkdir, permissions, l0 |
| db sync | exception | error | database, wal, error-wrapping |
| heartbeat interval must be at least 1 minute | validation | error | config, validation, duration |
| cannot specify both TXID & timestamp to restore | validation | error | restore, argument-validation, pitr, txid |
| failed to expand meta path for | exception | error | config, litestream, env-var, expansion |
| gs: cannot delete object | exception | error | gcs, cloud-storage, permissions, delete |
| must specify at least one replica URL for | validation | error | cli, arguments, replication |
| nats: failed to initialize object store | exception | error | nats, jetstream, object-store, config |
| truncate buffer | exception | error | |
| cannot determine L max ltx file for | exception | error | storage, lookup, replication, network |
| cannot read config | console | error | |
| cannot restore, output path already exists and is not empty | validation | error | filesystem, overwrite, restore |
| create page cache | exception | error | lru, cache, configuration |
| failed to connect to NATS server | exception | error | nats, network, connection, tcp |
| sync restore output dir | exception | error | |
| unknown config key | validation | error | go, config, uri, validation |
| create txid temp file | exception | error | restore, filesystem, file-write, temp-file |
| read ltx page index | exception | error | storage, ltx, io, network |
| replica URL or config file required | validation | error | cli, validation, missing-flag, litestream-test |
| bucket name is required | validation | error | nats, config, object-store |
| decode | exception | critical | ltx, corruption, decode, wal |
| abs: cannot create azure blob client with shared key | exception | error | abs, azure, shared-key, endpoint |
| s3: cannot load aws config | exception | error | |
| find v0.3.x snapshot | exception | error | restore, v0-3-compat, pitr, snapshot-selection |
| must specify port for bind address | validation | error | config, http, metrics |
| no backup files available | exception | warning | vfs, timeout, context, restore |
| database config # : 'meta-dir' can only be used with a… | validation | error | config, validation, litestream |
| invalid lock downgrade: current= | exception | error | |
| replica url scheme required | validation | error | config, url, validation |
| no replica configured | exception | error | configuration, replica, api-misuse |
| replica sync | exception | error | network, storage, replication, error-wrapping |