apache/hadoop
Documented errors, page 9 of 39. Back to apache/hadoop
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Parallel access to the create path detected. Failing… | exception | error | azure, abfs, concurrency, race-condition, create, blob-endpoint |
| Reached EOF when reading log header | exception | error | hdfs, edit-log, corruption, eof, namenode-startup |
| Too many bytes before newline: " + bytesConsumed | exception | error | hadoop, java, io, text-parsing, line-reader |
40 Failed to parse | exception | error | cli, xml, configuration, service-launcher, exit-code-40 |
| Cannot get access token since BlockKeyUpdater is not running | exception | warning | hdfs, balancer, security, block-token, shutdown-race |
| Cannot getLocatedBlocks through a symlink to a… | exception | error | hdfs, symlink, unsupported-operation, block-location, file-system |
| "concat: target file " + target + " is under construction" | exception | error | hdfs, concat, under-construction, lease, open-file |
| "concat: the src file " + src + " is the same with the… | exception | error | hdfs, concat, self-reference, precondition |
| getTrashRoot on path | exception | error | viewfs, hadoop, trash, mount-table, configuration |
| Incorrect data format. logVersion is | exception | critical | hdfs, namenode, edit-log, corruption, layout-version, data-format |
| Input/output error | exception | error | hadoop, delete, rm, io-error, permissions, shell |
| Invalid URI for NameNode address | exception | error | hdfs, namenode, uri, configuration, argument-validation |
| is not a super user | exception | error | hdfs, router, federation, superuser, permission-denied, access-control, admin-api |
| Stream closed | exception | error | hdfs, webhdfs, io, stream-lifecycle |
| Unexpected URISyntaxException | exception | error | hadoop, appendtofile, uri, shell, linux, syntax-error |
| has invalid authority. | exception | error | azure-abfs, uri, authority, configuration, fs-defaultfs |
| Already connected to Graphite | exception | warning | graphite, metrics2, state, api-misuse |
| Class-name comparators are not enabled (set… | exception | error | tfile, hadoop-common, comparator, security, configuration, class-loading |
| " " is not a valid value for a quota. | validation | error | hdfs, dfsadmin, quota, cli, argument-parsing, number-format |
| No KeyProvider is configured, cannot access an encrypted… | exception | error | hdfs, encryption, kms, key-provider, configuration |
| unable to load configuration for job | http | error | hadoop, mapreduce, jobhistory, rest, http-404, configuration, history-file |
| All merged files must be compressed or not. | exception | error | sequencefile, merge, compression, incompatible-inputs, hadoop |
| Bucket does not exist. Accessing with fs.s3a.endpoint set to | exception | critical | s3a, s3, bucket, unknown-store, initialization, configuration |
| Bucket doesn't match for source | exception | error | gcs, hadoop-gcp, compose, cross-bucket, validation |
| Cached State Store not initialized | exception | error | hdfs, router-based-federation, state-store, cache, startup-race |
| doesn't support createSnapshot | exception | error | hadoop, filesystem, hdfs, snapshot, unsupportedoperationexception, backup |
| Encoded SHA256 hash must be provided for global encryption | exception | critical | azure, abfs, encryption, client-side-encryption, sha256, configuration |
| Failed to complete SASL handshake | exception | error | hdfs, sasl, security, data-transfer-protection, authentication |
| Invalid buffer, not of length | exception | error | erasure-coding, buffer-validation, hadoop-common |
| Invalid path string | exception | error | windows, path-validation, invalid-path, mixed-separators, pathdata |
| Key '" + key + "' does not exist in BOS | exception | error | hadoop, rumen, unsupported-task-type, job-trace, task-attempt |
| Mkdirs failed to create " + parent.toString() | exception | error | hadoop, local-filesystem, mkdirs, permissions, create, parent-directory |
| previous and previous.tmp cannot exist together. | exception | error | hdfs, storage, upgrade, inconsistent-state, recovery, rename |
| Request must contain identifier | exception | error | hadoop, ipc, protobuf, refresh, dfsadmin, required-field |
| runtime classes not found | exception | error | hadoop-streaming, classpath, job-submission, jar-packaging, configuration |
S10 Service [ ] requires service [ ] | error_code | critical | httpfs, service-dependencies, configuration, startup |
42 No arguments provided | exception | error | cli, usage, s3a, s3guard, hadoop-aws, exit-code-42 |
| A Mapper can be added to the chain only after the Reducer… | exception | error | hadoop, mapreduce, chain, call-order, illegalstate |
| absolutePath + " is a file" | exception | error | hadoop, typedbytes, type-mismatch, arraywritable, serialization |
| configuration exception | exception | critical | hadoop-streaming, process-launch, permissions, configuration, subprocess |
| Error while running command to get file permissions : " +… | exception | error | hadoop, local-filesystem, windows, shell, permissions, winutils, runtimeexception |
| Failed to copy block file to | exception | error | hadoop, hdfs, datanode, fsdataset, lazy-persist, copy, block-file, disk-full |
| doesn't support truncate | exception | error | hadoop, truncate, unsupported-operation, filesystem, capability |
H08 {0} | error_code | error | httpfs, hdfs, filesystem, runtime, classpath |
| Incompatible version for state: expecting state version | exception | error | mapreduce, leveldb, state-store, versioning, migration |
| Invalid configuration: a shared edits dir must not be… | exception | error | hadoop, hdfs, namenode, configuration, high-availability, shared-edits |
| Invalid credentials | validation | critical | aliyun-oss, credentials, missing-configuration, hadoop-connector |
| Invalid scheme [ ] it should be 'webhdfs' or 'swebhdfs | exception | error | webhdfs, httpfs, uri-scheme, misconfiguration, illegalargument |
| offset: is out of range [ , ] | exception | error | read, buffer, index-out-of-bounds, argument-validation, input-stream |
| Only one of the following keys can be specified for a… | validation | error | mapreduce, resources, configuration, illegal-argument |
| Policy ' ' does not match any enabled erasure coding… | exception | error | hdfs, erasure-coding, ec-policy, hdfs-ec, hadoop-3 |
| Replica gen stamp < block genstamp, block= | exception | error | hdfs, datanode, read-path, generation-stamp, block-recovery |
| : mkdirs() returned false | exception | error | hadoop, manifest-committer, mkdirs, filesystem, permissions |
| Unable to refresh queues because queue-hierarchy changed… | exception | error | hadoop, mapreduce, queues, refresh, admin, config |
| Cannot find job submission directory! It should just be… | exception | error | staging-directory, race-condition, hdfs, job-submission, mapreduce |
EINVAL port was given, but URI ' ' already contains a port! | console | error | c, libhdfs, uri, configuration, einval, connection |
| Expected tag end event for | exception | error | hdfs, reversexml, mismatched-closing-tag, fsimage |
| Got unexpected checksum file EOF at | exception | error | hdfs, block-corruption, short-circuit-read, checksums, metadata-file |
| null hostname found | exception | warning | hostname, validation, null-check, hadoop-common |
| Only read diffs out of | exception | error | hdfs, oiv, fsimage, reversexml, snapshot-diff, count-mismatch |
| does not exist or is not file. | exception | error | hadoop, hdfs, filesystem, shell, concat, file-not-found, argument-validation |
| System property 'log4j.configuration' not defined | exception | critical | hadoop-kms, configuration, log4j, startup-failure, missing-system-property |
| Type mismatch in value from map: expected | exception | error | hadoop, mapreduce, mapper, serialization, type-mismatch, configuration |
| Unable to find SASL server implementation for | exception | error | sasl, jvm-providers, server-startup |
| "Unknown protocol: " + protocolName | exception | error | hadoop, ipc, authorization, class-not-found, classpath, version-mismatch |
| Block InputStream meta file has no FileChannel. | exception | error | hdfs, datanode, centralized-cache, filechannel, defensive-check |
| Call to JNI_CreateJavaVM failed with error | console | critical | libhdfs, jni, jvm, libhdfs-opts, jvm-options |
| Cannot start datanode because the configured max locked… | exception | critical | hadoop, hdfs, datanode, native-library, centralized-cache, startup |
| Destination is a non-empty directory | exception | warning | s3a, rename, directory-not-empty, posix-semantics |
| Failed to create temporary file for | exception | error | hdfs, datanode, temp-file, stale-state, block-write, crash-recovery |
| getErasureCodeCodecs is not supported for HttpFs on | exception | error | hdfs, httpfs, webhdfs, erasure-coding, fs-defaultfs, configuration, unsupported-operation |
| Incompatible EncryptionSecrets version | exception | error | aws, s3a, delegation-token, serialization, version-skew, encryption |
| Invalid size: for file metadata object | exception | error | hadoop, sequence-file, corruption, file-format |
| length can't be negative | validation | error | hadoop, mapreduce, skip-bad-records, validation, runtime-exception |
| Missing reduce spec | exception | error | hadoop, gridmix, sleep-job, reducer, data-contract |
| Native runtime library not loaded | exception | error | nativetask, native-library, jni, guard-clause |
| Parsing of XML List Response Failed in BlobClient. | exception | error | azure, abfs, xml, parsing, list-blobs, blob-endpoint |
| Proxy error: incorrect fs.s3a.proxy.host or… | exception | error | s3a, proxy, uri-parsing, configuration |
| Replica was found but missing fields. | exception | error | hdfs, block-recovery, lease-recovery, datanode, protobuf, rpc |
| Unable to rename to | exception | error | hadoop, hdfs, namenode, checkpoint-recovery, file-rename, legacy-format |
| Unknown method called on protocol. | exception | error | hadoop, ipc, rpc, protobuf, version-mismatch, server |
| Client does not support specified CryptoProtocolVersion | exception | error | hdfs, encryption, hdfs-encryption-zones, version-mismatch, kms |
| expected <EDITS/> | validation | error | hdfs, offline-edits-viewer, oev, edit-log, xml, sax |
| Failed to find < >; got instead. | exception | error | hdfs, reversexml, xml-tag-mismatch, fsimage |
| , which is located at , is not a descendant of | exception | error | network-topology, rack, inner-node, hadoop-common, validation |
| Number out of range: threshold = | validation | error | hdfs, balancer, cli, argument-validation, range-check |
| Service is in wrong state | exception | error | registry, zookeeper, service-lifecycle, state-machine, hadoop-registry |
| Target path does not exist or is not file. | exception | error | hadoop, hdfs, concat, file-validation, shell, java |
| Attempted to seek or read past the end of the file " +… | exception | error | bos, input-stream, seek, eof, hadoop |
| "Could not parse file encryption info for inode " +… | exception | critical | hdfs, encryption-zone, xattr, protobuf, corruption, reencryption |
| Failed to unmarshall token for | exception | error | aws, s3a, delegation-token, deserialization, token-decode |
| Identifier ' ' does not exist in RefreshRegistry. Valid… | exception | error | refresh, registry, admin, dispatch, identifier |
| ipAddress is null. | exception | error | hadoop, java, acl, null-check, host-filter |
| Meta file for not found. | exception | error | hdfs, datanode, metadata-file, checksum, block-corruption, filenotfound |
| Missing directory | exception | critical | hdfs, name-node, startup, edits-dir, filesystem, mount, resource-checker |
| modifyAclEntries is only supported by storage accounts with… | exception | error | azure-abfs, acl, hierarchical-namespace, unsupported-operation |
| No image processor to read version | exception | error | hdfs, oiv-legacy, fsimage, version-mismatch |
| No nodetype for " + ident | exception | error | hadoop, mapreduce, join, parser, unknown-identifier |
| Output Format not set for LazyOutputFormat | exception | error | hadoop, mapreduce, lazy-output-format, output-format, configuration |
| status code 429 !!!" + e.getCause() | exception | error | bos, rate-limit, http-429, throttling, cloud-storage, hadoop |