apache/hadoop

Documented errors, page 11 of 39. Back to apache/hadoop

Code / MessageTypeSeverityTags
Invalid values: dfs.bytes-per-checksum
validation error hdfs, hdfs-client, config, block-size, checksum, validation
IPC's epoch is not the current writer epoch ; journal id
exception error qjm, epoch, writer-fencing, session-handshake, edit-log
lz4-java library is not available: Lz4Decompressor has not…
exception error lz4, compression, classpath, missing-dependency, hadoop, native-library
Missing username
exception error hadoop, gridmix, user-resolver, config-file, parse-error
MR AM not authorized to issue delegation token
exception error mapreduce, delegation-token, security, application-master
The mount point doesn't exist. path=" + fedPath
validation error hadoop, rbf, fedbalance, mount-table, cli, client-side
The permission can't be null
validation error azure-abfs, setpermission, illegal-argument, hns
URI: is not in the expected format
exception error hdfs, datanode, storage, uri, config, illegal-argument
Block IDs mismatched: block
exception error hdfs, erasure-coding, striped-blocks, block-id, write-path
Datanode unreachable.
exception error hdfs, dfsadmin, datanode, rpc, connection, balancer-bandwidth
H10
Hadoop config directory not found
error_code critical httpfs, hadoop-conf, configuration, startup, filesystem
hdfsThreadDestructor: GetJavaVM failed with error
console warning libhdfs, jni, thread-exit, tls-destructor, getjavavm
Invalid URI for NameNode address
exception error hdfs, namenode, uri, scheme, configuration, argument-validation
mark()/reset() not supported on this stream
exception error azure-blob, abfs, unsupported-operation, mark-reset, hadoop
No fencer configured for
exception error hadoop, hdfs, ha, fencing, failover, configuration
Not replicated yet
exception error hdfs, block-allocation, replication, datanode-health, transient
Observer Node is too far behind: serverStateId =
exception warning hdfs, observer, ha, replication-lag, retry, read-your-writes
Path points to dir not a file
exception error viewfs, mount-table, block-locations, file-not-found, hadoop-common
RequestRateLimitExceeded
trigger bos object rate limit !!!
exception error bos, rate-limit, http-429, hot-object, cloud-storage, hadoop
writeChunk() checksum size is supposed to be
exception error hdfs, hdfs-client, write, checksum, chunk
Cannot get FileChannel from Block InputStream meta file.
exception error hdfs, datanode, pmem, centralized-cache, filechannel, defensive-check
Changing storage type is not allowed.
exception error hadoop, hdfs, datanode, volume-management, storage-type, reconfiguration
E_NO_SPARK_UUID
Job/task context does not contain a unique ID in spark.sql.sources.writeJobUUID
exception error aws, s3a, committer, spark, uuid, fail-fast
Expected to parse in parallel, but parsed . The image may…
exception error hdfs, offline-image-viewer, fsimage, data-corruption, multithreaded
' ' is not an HDFS URI.
validation error hdfs, admin, uri, filesystem-scheme
mutexLock: pthread_mutex_lock failed with error
console error libhdfs, pthread, mutex, posix, synchronization
NativeIO is not available.
exception error hdfs, short-circuit-read, native-library, jni, nativeio, libhadoop
String length exceeds the limit of
exception error tfile, data-corruption, oom-guard, hadoop-common
too many temporary directories.
exception error hdfs, storage, upgrade, rollback, inconsistent-state, recovery
User [ ] is not authorized to perform [ ] on key with ACL…
exception error hadoop-kms, authorization, http-403, key-acl, security, key-management
waitCallReturn timed out
exception error async-rpc, timeout, retry, hadoop-common
Error loading token master key from
exception error mapreduce, job-history-server, leveldb, state-store, data-corruption
Failed to create output dir
exception error fs2img, image-writer, mkdir-failed, output-path, permissions
Failed to mkdirs
exception error hdfs, datanode, upgrade, block-id-layout, mkdirs, hardlink
Fewer lines of output than expected
exception error hadoop, disk, df, system-command, environment, container
Filesystem is configured to use unknown S3Guard store " +…
exception error hadoop-aws, s3guard, configuration, hadoop-3-4-upgrade, unknown-class
Illegal tag pattern
exception error hadoop, metrics2, configuration, filter, regex
KeyVersion ' ' does not belong to the key
exception error hadoop-kms, key-version, http-400, data-integrity, key-management
Native output collector cannot be loaded;
exception error nativetask, jni, error-chaining, initialization
Native output collector doesn't support this key, this key…
exception error nativetask, serialization, comparable, sorting, job-configuration
No link found for the given path. on path
exception error viewfs, overload-scheme, mount-table, hadoop-common, java
SimpleAWSCredentialsProvider: No AWS credentials in the…
exception error s3a, hadoop-aws, credentials, authentication, configuration
The quota system is disabled in Router.
exception error hadoop, hdfs, rbf, quota, configuration, async-rpc
Can't read FileStatusProto with negative size of
exception error hadoop, serialization, protobuf, filestatus, corruption
Directory does not exist
exception error hdfs, namenode, namespace, file-not-found, race-condition
FATAL_INVALID_RPC_HEADER
Server is not wrapping data
exception critical rpc, sasl, security, qop, protocol-mismatch
Initialization of all the collectors failed.
exception error
Invalid output collector class
exception error
Job in state instead of
exception error lifecycle, state-machine, illegal-state, job-submission, mapreduce
No data exists for block
exception error hadoop, hdfs, datanode, fsdataset, read-path, replica, block-not-found
Number of thresholds should be
validation error hadoop, ipc, decay-scheduler, thresholds, config, validation
position is negative
exception error hadoop-tos, object-storage, input-stream, positioned-read, negative-offset
Symlinks unsupported
exception error setrep, symlink, unsupported-operation, hadoop-shell
The parse failed because of bad layoutversion value
validation error hdfs, erasure-coding, ec-policy, xml, layout-version, version-mismatch
Unsupported name: has scheme but relative path-part
exception error path, uri, scheme, invalid-path, hadoop
[ ] = [ ] must be
validation error java, hadoop, httpfs, validation, regex, identifier
Failed update mount table " + mount + " with readonly=" +…
exception error hadoop, rbf, fedbalance, mount-table, readonly, state-store, update-failed
Found duplicated storage UUID
exception critical hadoop, hdfs, datanode, fsdataset, storage-uuid, duplicate-config
Invalid hostname provided
exception error nfs, hostname, exports, validation
Invalid input, there are duplicated files in the sources
validation error distch, hadoop-extras, duplicate-source, input-validation, sequence-file
NameNode specified unknown CipherSuite with ID
exception error hdfs, encryption, cipher-suite, version-mismatch, classpath
Owner ' ' for path did not match expected owner
exception error hadoop, file-ownership, security, posix
Rename unsuccessful : ' ' to
exception error java, hadoop, filesystem, key-provider, flush, rename
Spill thread failed to initialize
exception error hadoop, mapreduce, maptask, spill, threading, interrupted
Unable to initialize WebAppContext
exception error hadoop, http-server, jetty, servlet, webxml, startup
Unrecognized job state
exception error hadoop, mapreduce, yarn, job-state, enum-conversion, version-mismatch
Can't write: as
exception error serialization, object-writable, writable, rpc, hadoop-common
: No AWS credentials
exception error s3a, hadoop-aws, credentials, authentication, delegation-token
Configuration has multiple addresses that match local…
validation error hdfs, ha, configuration, namenode, address-matching, startup
" + idHelpText + " mismatch: previously connected to " +…
exception critical hdfs, datanode, namenode, clusterid, namespaceid, ha, reformat
INVALID_PLAN_HASH
Invalid or mis-matched hash.
exception error hdfs, diskbalancer, sha1, integrity-check, plan-hash
Invalid values for quota
validation error webhdfs, quota, argument-validation, hdfs
is not a valid Inet address
exception warning hostname, validation, uri-parsing, hadoop-common
Not an abfs filesystem
exception error azure, abfs, output-committer, manifest, filesystem-binding, wiring
null component type not allowed
exception error hadoop, serialization, writable, validation, null-check
Problem getting input split size
exception error
S11
Service [ ] exception during status change to [ ] -server shutting down
error_code critical httpfs, server-lifecycle, service-failure, startup-failure, shutdown
The length to read exceeds the file length
exception error java, hadoop, webhdfs, eof, positioned-read
Token mismatch: expected token for
exception error aws, s3a, delegation-token, token-binding, authentication
Unable to create OutputStream with the given multipart…
exception error s3a, hadoop-aws, configuration, output-stream, multipart-upload, pathioexception
Unexpected ZooKeeper issue fetching active node info
exception error hadoop, ha, zookeeper, zkfc, failover, network
Cannot parse nsQuota
validation error hdfs, rbf, federation, quota, cli, number-format
stream does not support setting the drop-behind caching…
exception error crypto, stream, drop-behind, performance, hadoop
Data in file has been corrupted.
exception critical hadoop, yarn, disk-check, hardware, data-corruption
Decay Factor must be between 0 and 1
validation error hadoop, ipc, decay-scheduler, config, validation, startup
Deleting resource failed.
exception error gcs, hadoop-gcp, delete, generation-mismatch, storageexception
Error parsing libjars argument. Argument must be a valid URI
exception error distributed-cache, uri, libjars, classpath, job-submission
Got unexpected end event while looking for
exception error hdfs, reversexml, xml-structure, fsimage
Invalid registration, no nameservice specified
validation error hdfs, router-based-federation, state-store, membership, record-validation
Missing ')'
exception error hadoop, mapreduce, join, parser, parentheses, syntax
Missing keyfile property
exception error authentication, gcs, hadoop, configuration, service-account
No scheme in default FS
validation error hadoop, configuration, core-site, uri, fs-defaultfs
PLAN_ALREADY_IN_PROGRESS
Executing another plan
exception error hdfs, diskbalancer, plan-execution, concurrency, dfsadmin
SetOwner operation is only supported on HNS enabled…
exception error azure, abfs, unsupported-operation, hns, acl, ownership
The xattr 'security.hdfs.unreadable.by.superuser' can not…
exception error hdfs, xattr, security, access-control, protected-attribute
tried to deserialize
exception error text, writable, deserialization, data-corruption, hadoop
Tried to skip bytes past the limit at offset
exception error hdfs, namenode, edit-log, corruption, max-op-size, stream-limit
Unsupported scheme
exception error hdfs, webhdfs, scheme, argument-validation, configuration
44
Not found
error_code error s3a, path-not-found, directory-markers, exit-code-44
Error creating file descriptor in
exception error short-circuit-reads, shared-memory, dev-shm, permissions, containers