apache/hadoop

Documented errors, page 7 of 39. Back to apache/hadoop

Code / MessageTypeSeverityTags
Could not load truststore (keep using existing one) :
exception warning ssl, tls, truststore, reload, cert-rotation, hadoop
Expected to read bytes from offset but reached end of file.
exception error hdfs, datanode, checksum, truncation, corruption
Failed to fully delete compressed aliasmap
exception warning hdfs, provided-storage, aliasmap, cleanup, file-delete
JobStory not available for job
exception error hadoop, gridmix, statistics, internal-invariant, job-trace
Recursive load of credential provider; if loading a JCEKS…
exception error hadoop, credential-provider, recursive-load, circular-dependency, configuration
RPC response has a length of
exception error hadoop, ipc, rpc, response-size, limit, oom-protection
BlockReader: error in first chunk offset
exception error hdfs, data-transfer, chunk-offset, block-read
Can't load state from image in a running SecretManager.
exception error hdfs, delegation-token, security, lifecycle, fsimage
Cannot create file because parent folder does not exist.
exception error azure, abfs, blob-endpoint, create, file-not-found, hadoop
Checksum error: at
exception critical hadoop, filesystem, checksum, local-filesystem, data-corruption
"Couldn't rename " + mapOutIndex
exception error mapreduce, yarn, uber-mode, rename, local-filesystem, partial-state
Counters version mismatch, expected
exception error hadoop, mapreduce, counters, serialization, version-mismatch, ioexception
Error parsing local resource path. Path was not able to be…
exception error hadoop, mapreduce, yarn, local-resource, uri, distributed-cache, escaping
Failed to get method
exception error sasl, reflection, configuration, callback, hadoop
Failed to parse " " to Boolean.
validation error webhdfs, query-param, boolean-parsing, rest
Interrupted while serving request. Aborting.
exception warning hdfs, dataxceiver, shutdown, interrupted, block-pool
Name cannot be NULL or emtpy
validation error hadoop, mapreduce, multiple-outputs, validation, naming
Native object create failed, class
exception error native, jni, nativetask, environment, version-mismatch
Not enough arguments: expected
exception error hadoop, hdfs, cli, argument-validation, shell, java
Unknown nameservice
exception error hdfs, configuration, federation, nameservice, namenode, journalnode, startup
User doesn't have permission to call
exception error mapreduce, job-history-server, acl, authorization, access-control
Wrong FileSystem: " + stat.getPath()
validation error hadoop, local-filesystem, pathhandle, uri-mismatch
Can't get Master Kerberos principal for use as renewer
exception error mapreduce, security, kerberos, delegation-token, job-submission, configuration
Cannot find any path capability
exception error hadoop-compat-bench, path-capability, filesystem, connector
Checksum not matched for file at position : expected= but…
exception critical checksum, data-corruption, local-filesystem, crc, checksum-exception
concat can not be called for files in an encryption zone.
exception error hdfs, concat, encryption-zone, unsupported-operation
Does not contain a valid host:port authority
exception error configuration, socket-address, uri-parsing, hadoop-common, validation
failed to allocate new BlockReader at position
exception error hdfs, hdfs-client, block-reader, datanode, connectivity, short-circuit
Failed to rename to , file already exists or not empty!
exception error hadoop, rumen, null-check, job-trace, constructor-validation
Possible disk error: Failed to create
exception error hdfs, datanode, disk-error, enospc, permissions, volume-health
Too many distribution intervals
exception error hdfs, offline-image-viewer, fsimage, file-distribution, input-validation
Configured cluster topology should be…
exception critical hdfs, block-placement, network-topology, configuration, namenode-startup
Failed to move meta file for
exception error hadoop, hdfs, datanode, fsdataset, mover, rename, metadata-file, io
FATAL_UNAUTHORIZED
"Authenticated user (" + user + ") doesn't match what the client claims to be…
exception error authorization, delegation-token, proxy-user, security, hadoop-ipc
For enabling or disabling storage policy satisfier, must…
exception error hdfs, name-node, reconfig, storage-policy-satisfier, sps, dfsadmin, enum-value
Incorrect state to start a new key
exception error hadoop, tfile, state-machine, writer
Invalid configuration: maxSingleShuffleLimit should be less…
exception error hadoop, mapreduce, shuffle, config, memory, merge, validation
Journal dir ' ' should be an absolute path
validation error hdfs, qjournal, configuration, path, startup
${message}: ${currentFilePath}
exception error metrics2, rolling-file-sink, disk-full, write-failure, printstream
Must specify either create or append
exception error hdfs, distributed-filesystem, builder-pattern, file-write, invalid-argument
Name output ' ' has not been defined as multi
validation error hadoop, mapreduce, multiple-outputs, multi-output, api-misuse
No more items in iterator
exception error hadoop, filesystem, remote-iterator, nosuchelementexception, batch-listing, iterator-misuse
Range starts beyond the file length
validation error vectored-io, file-range, eof, hadoop-common
Tried to read byte(s) past the limit at offset
exception error hdfs, namenode, edit-log, corruption, max-op-size, oom-guard, stream-limit
Access denied for user
exception error hdfs, authorization, superuser, permissions, rbf
Cannot find locations for
exception error hadoop, rbf, router, mount-table, path-resolution, configuration
doesn't support setAcl
exception error acl, unsupported-feature, object-store, permissions, hadoop-fs
{}
exception error hdfs, authorization, audit, permissions, access-denied
is not an ancestor of
exception error network-topology, rack, inner-node, hadoop-common, validation
Only a Finalized replica can be appended to; Replica with…
exception error hdfs, datanode, append, replica-state, race-condition
Only one of the following keys can be specified for a…
exception error configuration, resources, yarn, mapreduce, appmaster
The Reducer output key class does not match the Mapper…
exception error hadoop, mapreduce, chain, type-mismatch, generics, illegalargument
Unexpected configuration parameters…
validation error hdfs, namenode, configuration, maintenance, replication, startup-check
User is not authorized for protocol
exception error authorization, acl, rpc, kerberos, hadoop-policy, hadoop, security
Zookeeper client is null
exception error hdfs, router-based-federation, delegation-token, zookeeper, curator
A directory with that name exists
exception error gcs, create, file-exists, directory-conflict, implicit-directory
Bad EC policy configuration file: no
validation error hdfs, erasure-coding, ec-policy, xml, configuration
Can't add persisted delegation token to a running…
exception error hdfs, delegation-token, security, edit-log, lifecycle
Error in instantiating YarnClient
exception critical hadoop, mapreduce, yarn, filesystem, configuration, classpath, client-setup
Failed to recover the block
exception error hdfs, datanode, pmem, cache-recovery, native-io
Flush without blockIds not supported on Blob Endpoint
exception error azure, abfs, unsupported-operation, flush, blob-endpoint
INVALID_PLAN_VERSION
Invalid plan version.
exception error hdfs, diskbalancer, plan-version, version-mismatch, rolling-upgrade
Invalid URI
exception critical azure, abfs, uri, configuration, client-init
Invalid UTF8 at
exception error utf8, encoding, serialization, text, corrupted-data
source and dest refer to the same file or directory
exception info s3a, rename, no-op, idempotency
State Store does not have an interface for
exception error hadoop, rbf, state-store, resolver, configuration, startup
Unresolved host
exception error ganglia, metrics2, dns, unknown-host, hadoop-common
Failed to rename to
exception critical hadoop, mapreduce, output-committer, commit-phase, rename
rename from to failed.
exception error hdfs, rename, race-condition, transaction-rollback
ShuffleProvider Service
exception error mapreduce, shuffle, aux-services, yarn, configuration
This operation is not supported across two different…
exception error gcs, copy, storage-class, cross-bucket, unsupported-operation
Unable to add to namespace
exception error hdfs, create, race-condition, namespace
Another reconfiguration task is running.
exception warning reconfiguration, concurrency, configuration, hadoop
Error creating
exception error metrics2, file-sink, permissions, configuration
Error processing URI
exception error uri, distributed-cache, path-normalization, job-submission, mapreduce
Failed to checkpoint trash
exception error hadoop, trash, checkpoint, rename
Null protocol not authorized
exception error hadoop, ipc, authorization, acl, security, connection-header
output buffer not set
exception error nativetask, buffer-management, initialization, internal-api
url must be for a HTTP or HTTPS resource
exception error authentication, url, protocol-validation, hadoop-auth, webhdfs
user requested stop
exception info hdfs, recovery, editlog, cli, control-flow
allowSnapshot is not supported for HttpFs on
exception error httpfs, webhdfs, snapshot, unsupported-operation, fs-defaultfs
Block pool IDs mismatched: block
exception error hdfs, erasure-coding, striped-blocks, block-pool, write-path
Credential does not exist in
exception error credentials, credential-provider, security, hadoop, user-provider
DISK_BALANCER_NOT_ENABLED
Disk Balancer is not enabled.
exception error hdfs, diskbalancer, configuration, feature-flag, dfsadmin
Error executing command.
exception error untar, subprocess, exit-code, corrupt-archive, archive-extraction
Expected tag end event for
exception error hdfs, reversexml, xml-tag-mismatch, fsimage
LazyWriter fail to find or create lazy persist dir
exception error hdfs, datanode, lazy-persist, ram-disk, mkdir
NativeRuntime cannot be loaded, please check that…
exception error nativetask, native-library, environment, deployment
Not a file
exception error s3a, committer, local-file, staging
Not ready to serve the block pool
exception error hdfs, datanode, block-pool, registration, namenode, timeout
Parameter [ ], it's length must be at least 1
validation error webhdfs, user-param, authentication, validation, hdfs
Unknown BlockChecksumType
exception error hdfs, checksum, classpath, enum, version-conflict
Although a UNIX domain socket path is configured as
exception critical hadoop, hdfs, datanode, native-library, short-circuit-reads, unix-socket, startup
Balancer without BlockPlacementPolicyDefault
validation error hdfs, balancer, block-placement, configuration, startup-check
Channel is null. Check how the channel or socket is created.
exception error hadoop-common, network, nio, sockets, java
getCredentials failed
exception error s3a, hadoop-aws, credentials, assumed-role, sts, network
H03
FileSystemExecutor error
error_code error httpfs, hdfs, filesystem, io, wrapper
Handler returned null.
exception error refresh, handler, null-return, admin
Incompatible layout (expected )
exception error fs2img, layout-version, version-mismatch, fsimage, hadoop-version
JobId string : is not properly formed
exception error job-id, parsing, argument-validation, mapreduce