vitessio/vitess

Documented errors, page 7 of 13. Back to vitessio/vitess

Code / MessageTypeSeverityTags
failed parsing primary_term_start_time
validation error vtadmin, time-parsing, rfc3339, tablet
failed to create file-based writer for --opentsdb-uri
exception error go, opentsdb, filesystem, configuration
GetWorkflows(keyspace = , active_only = ) failed
exception error vtadmin, vtctld, vreplication, rpc
len(p.Patch)%3
panic error panic, collations, codegen, data-integrity
schema diffs
validation error vitess, schema-drift, schema-validation
: keyspace name is required
validation error vtadmin, validation, invalid-request, keyspace
failed to get source keyspace vschema
console error vitess, workflow, vschema, topology, keyspace
GetSchema(cluster = , keyspace = , tablet = ) failed
exception error vtadmin, schema, vtctld, rpc
GetTabletAliasesByCell
exception error topo, vtctld, shard-management
no rpl_semi_sync_replica_status variable in mysql
exception error mysql, semi-sync, replication, replica
VReplication stream has the same workflow name as the…
console error vitess, vreplication, resharding, workflow-migration
BUG: thread with ID: already finished
panic error go, panic, throttler, lifecycle, thread-management
Connection DNS for has changed; old: new
error_code info network, dns, reconnect, address-change
context canceled updating tablet_type for
exception warning topology, context-cancel, tablet-type
direct DDL is disabled
exception error ddl, online-ddl, configuration, mysql
served_type has to be in the serving graph, not
validation error topo, tablet-type, cli-validation
--batch-size conflicts with --uuid-list. Batching does not…
validation error go, schemamanager, configuration, flags
cannot switch traffic for workflow
error_code error vreplication, switch-traffic, workflow, prerequisites
CreateShard(%+v) failed to acquire topoRWPool
exception error vtadmin, topo, lock-acquisition, timeout
GetFuncForType does not support array types
panic error go, viper, config, generics, panic
switch should be exhaustive
panic error sqlparser, ast, visitor, panic, exhaustive-switch
TableGC: error while reading tables: %+v
exception warning mysql, query-error, table-gc, background-loop
: cannot complete workflow in
validation error vtadmin, rbac, authorization, movetables
[BUG] tried to replace 'SQLNode' on 'RootNode'
panic error sqlparser, ast-rewrite, codegen, panic, bug
failed reading tablet
console error vtctl, topo, tablet, dry-run
failed to parse vtgate FQDN template
exception error go, template, consul, fqdn, config
failed to write rendered config
http warning http, io, broken-pipe, response
failure creating directory
error_code error backup, mysqlshell, filesystem, permissions
invalid action for Migrate
validation error vtctl, vreplication, migrate, validation
: cannot cancel schema migration in
validation error rbac, authorization, vtadmin, schema-migration
can't get primary tablet record
exception error topo, shard, stale-metadata
ColumnVindex for table
exception error vitess, vschema, vindex, conflict
health stats is not valid
validation error healthcheck, grpc, version-compatibility
table expression is complex
exception error go, sqlparser, parsing
unknown keyspace type
validation error topo, keyspace, cli-validation
workflow . is incorrectly configured
error_code error wrangler, workflow, topology
err.Error() (GetDetectionAnalysis failure)
http error http-api, vtorc, internal-error
failed to open external topo
console error vitess, workflow, topology, external-cluster, network
found no possible unique key on
exception error schemadiff, vreplication, unique-key, column-mismatch
FullyQualifiedHostname: failed to retrieve the hostname of…
error_code critical network, hostname, dns
mysql cluster type not yet supported
validation error vtctl, topology, unsupported-feature
has an extra table named
exception error schema, consistency-check, mysql, vitess
: keyspace
exception error vtadmin, vtexplain, vschema, topology
can't lock shard: shard name is unspecified
validation error vtorc, shard-lock, invalid-argument
cell param required
http error http-api, vtctld, tablets, cell
could not set message
exception error mysql, vreplication, database
DeleteTablets(%+v) failed to acquire topoRWPool
exception error resource-pool, timeout, concurrency, vtadmin
either source or target shards are missing
validation error vreplication, validation, sharding
ErrRange
: backfill queue size must be non-negative; got
validation error vtadmin, configuration, validation, strconv
internal value get MySQL value length error
error_code error mysql-protocol, serialization, wire-protocol
migration cannot run because prior migration in same…
exception error online-ddl, migration, blocked, prior-failure
unsupported qualifier for column
validation error sqlparser, vreplication, convert-using, column-qualifier
VT03005
VT03005: cannot group on
error_code error vtgate, group-by, aggregation, unsupported-sql
cannot delete shard /
exception error vitess, keyspace, shard, deletion
error creating vtsql connection config
exception critical startup, vtsql, configuration, flag-parsing
ErrStreamClosed
stream closed for sending
error_code warning grpc, streaming, bidi-stream, lifecycle
keyspace is required
http error http-api, vtctld, keyspace, url-validation
keyspace( ) doesn't exist, check if the keyspace is…
validation error vtctl, topo, keyspace, go
source and target columns must be of same length
exception error onlineddl, columns, schema-analysis
stream has not started on tablet
exception error vdiff, vreplication, binlog-position, stream
unable to delete from bucket
exception error gcs, backup-storage, permissions
unsupported pointer type %T
exception error codegen, ast, go, tooling
BUG: cannot add record because it is already covered by a…
panic error go, panic, throttler, time-series, invariant-violation
cannot update vreplication table, affected
exception error vreplication, recovery-position, race-condition, row-missing
CreateShard( , )
error_code error go, topo, permissions
found target SelectExpr which was neither ColName nor…
validation error vdiff, sqlparser, vdiff-plan
invalid format for external source cluster
validation error vtctl, vreplication, movetables, parsing
metadataRead: unhandled data type
panic error mysql, binlog, panics, internal
missing golang digest for distro
exception error docker, golang, versioning, ci
strict index ordering is unsupported
exception error schemadiff, index, ordering
unexpected
exception error vstreamer, planbuilder, literal, filter
cannot create local vtctldclient without a server; call…
validation error vtctld, local-client, initialization, testing
duplicate session variable name
validation error ddl, online-schema-change, validation
GetTabletsByCell( )
error_code error go, topo, cells
invalid state for stream
console error vreplication, status, enum, state
invalid state found for vdiff table
exception error vdiff, state, duplicate-rows
malformatted error, got
exception error golang, go-mod, versioning, tooling
no streams found
error_code error vitess, vreplication, traffic-switch, missing-streams
no vdiff found for id
exception error vdiff, missing-record, mysql, race
one or two tables must be specified
validation error vindex, vschema, lookup-vindex, validation
symbol was not an interface but %T
panic error go, codegen, type-system, reflection
unexpected diff action
exception error schemadiff, ddl, action-mapping
unsupported type: , position
exception error binlog, type-mapping, columns, vstreamer
: no cluster with id
error_code error vtadmin, configuration, cluster-id
can't parse FORMAT_DESCRIPTION_EVENT
exception error binlog, format-description, parsing, version-compatibility
--cells-no-recovery contains cell
validation error vtorc, configuration, topology, cells
failed to process config options
validation error vreplication, config, configuration
Invalid UUID: , expected condensed 32 hexadecimals
validation error schema, naming, uuid, validation
ReloadSchemaShard( / ) failed
exception error vtadmin, schema-reload, shard, tablet-unreachable
tenant column name not defined in multi-tenant spec
validation error vreplication, vschema, multi-tenant
: cannot complete schema migration in
validation error rbac, authorization, vtadmin, schema-migration
can't parse INTVAR_EVENT
exception error binlog, intvar, corruption, parsing
cannot decode SourceUUID
panic critical mysql, replication, uuid, protobuf-decoding, panic
invalid format for <keyspace.workflow>
validation error argument-parsing, vtctl, input-validation
${objError.Message}
exception error s3, aws, delete, permissions
ReloadSchemaKeyspace
exception error vtadmin, schema-reload, tablet-unreachable
same keyrange is present in source and target
exception error resharding, keyrange, validation, topo
schema change failed, ExecuteResult
exception error schemamanager, execution, shards, online-ddl
: cannot delete shards in
validation error rbac, authorization, vtadmin, shard, deletion
: no backup location set via --mysql-shell-backup-location
error_code error backup, mysqlshell, configuration, missing-flag