vitessio/vitess

Documented errors, page 6 of 13. Back to vitessio/vitess

Code / MessageTypeSeverityTags
context was done before filtered replication did catch up…
exception error timeout, replication, context
failed to execute tablet FQDN template for %+v
exception error vtadmin, template, fqdn, configuration
last seen delay should never be negative. tablet
exception error health-check, replication, data-integrity
listener must be a function
panic error event, panic, reflection, listener
only integer literals are supported
validation error vitess, vstreamer, planbuilder, sql-parsing
the and arguments are required for the ChangeTabletType…
validation error vtctl, cli, missing-argument, tablet-type
'all' not supported for
validation error onlineddl, argument-validation, vtctl
can't delete tablet
exception error topo, shard-deletion, tablets, wrangler
could not find vindex column
validation error go, vindex, workflow
did not received expected fields in response %+v on tablet
exception error vdiff, vstream, grpc, protocol
error parsing the json file
exception error ceph, backup, json, configuration
failed to parse backup path
exception error backup-storage, path-traversal, security
invalid IntervalDateExpr syntax
panic error go, panic, sqlparser, ast, enum
Unknown OnlineDDL command
validation error onlineddl, command-dispatch, vtctl
BUG: cannot add record because it does not start at the…
panic error go, panic, throttler, time-series, invariant-violation
CreateKeyspace(%+v) failed to acquire topoRWPool
exception error vtadmin, topo, lock-acquisition, timeout
error updating time
exception warning vreplication, heartbeat, mysql
failed to parse literal string at
error_code error parsing, testing, sqltypes
in-memory row count exceeded allowed limit of
exception error vtgate, memory-limit, sort, resource-exhaustion
no local cells have been created yet
http error topology, cells, vtctld, http-api
uncaught panic: , vtgate
panic critical panic, vtgate, internal-error, recovery
unknown workflow type passed
console error vtctl, vreplication, internal, workflow
unrecognized query
exception error vtadmin, test-double, database
unsupported query construct
error_code error vreplication, vexec, query-planner
cannot delete workflow because you have already switched…
error_code error vitess, movetables, workflow-delete, cutover
GetKeyspaces(cluster = )
exception error vtadmin, vtctld, keyspaces, grpc
GetWorkflows(keyspace = , active_only = ) failed to acquire…
exception warning vtadmin, semaphore, concurrency, timeout
golang version malformatted
exception error golang, api, versioning, network
invalid session variable name
validation warning ddl, validation, sql-injection
nil not allowed
panic error go, stats, panic, nil-argument
only the integer literal 1 is supported
validation error vitess, vstreamer, planbuilder, filter
schema looks incorrect
exception error vitess, schema, ddl
TabletExternallyReparented failed on primary
error_code error vtcombo, tablet, primary, replication
unsupported post copy action type
exception error vreplication, go, compatibility
You've already registered a function
panic error go, panic, stats, initialization
cannot load vschema file
exception error json, vschema, configuration
file not present
exception error ceph, configuration, filesystem, backup-storage
internal error: unexpected rows without fields
exception error messager, binlog, internal-error, protocol
primary-elect tablet
exception error vitess, reparent, failover, force
SBR mode unsupported for streaming
exception error binlog, streaming, sbr, keyrange
[ ] cached columns count[ ] mismatch binglog row [ ]
exception error binlog, schema-mismatch, row-replication
vdiff with UUID not found on tablet
exception error vdiff, missing-record, wrong-tablet
workflow has already been created, state is
error_code error vreplication, workflow, state, double-create
deadline exceeded waiting for mysqld socket file to appear:
exception error go, mysqlctl, mysqld-startup, timeout
empty gtid passed to setPosition
validation error vreplication, gtid, binlog
failed to read instance
exception error vtorc, database, topology-recovery
GetSrvVSchema( )
exception error vtadmin, vtexplain, vschema, vtctld, rpc-failure
interval too small
panic error go, stats, panic, invalid-interval
invalid /throttlerz path
http info http, routing, url, throttler
primary-elect tablet
exception error vitess, reparent, failover, split-brain
CopySchemaShard failed because schemas could not be…
exception error go, schema, verification, rpc
error creating vtsql proxy
exception critical startup, vtsql, connection, vtgate
failed to read shard primary for
exception error vtorc, topology, errant-gtid, shard
GetTablet( ) failed
exception error topology, tablet-alias, preflight, topo-lookup
GetTablet( )
error_code error go, topo, race-condition, tablets
no port variable in mysql
exception error mysql, connection, port, mysqlctl
shard / already has SourceShards, not overwriting them…
exception error topo, resharding, source-shard, restore, safety-guard
vreplication engine is closed
exception error vreplication, lifecycle, shutdown
watch terminated with no error
validation warning vttablet, topology, watch, custom-rules
keyword must be lowercase in table
panic error sqlparser, keyword-table, invariant-violation, panic, init
malformed spec: shard limits should be in order
validation error go, sharding, configuration, input-validation
schemas are different
exception error schema, consistency-check, vitess, mysql
shard / has no primary
exception error topo, shard, replication
slow path for `n` directive for slice of type other than…
panic error go, codegen, tooling, panic, astfmtgen, unsupported-type
checkpoint information not available in db for
exception error vreplication, missing-row, mysql, workflow
no PushBackend registered with name
error_code error go, stats, configuration
rate recalculation was triggered with a zero replication…
panic error go, panic, throttler, zero-value
schemas differ on table
exception error schema, consistency-check, mysql, ddl, vitess
source table not found in vschema
exception error vitess, vschema, vindex, missing-table
unable to create file
exception error filesystem, restore, permissions, disk
vtexplain: unsupported statement type +
exception error vtexplain, sqlparser, unsupported-statement
: cannot delete keyspace in
validation error rbac, authorization, vtadmin, keyspace, deletion
can't set charset for statement
exception error mysql, charset, binlog-replay, version-compat
failed to create vcopier worker
exception error vreplication, vcopier, worker-pool, worker-creation
throttler not found
http info http, throttler, not-found, debug-endpoint
topo shards not in switch command
validation error go, topology, sharding, validation
unable to vdiff for UUID as it was not found on tablet ( )
exception error vdiff, race-condition, missing-record
Unkown decompressor engine
validation error backup, decompression, version-compatibility
bad sql row
exception error vtadmin, test-double, database
error dialing vtgate
error_code error network, grpc, vtgate, vtadmin
invalid choice for enum
validation warning vtadmin, topology, concurrency, timeout
mismatched shards for keyspace
validation error go, topology, sharding, validation
no tables to move
validation error movetables, wrangler, configuration
timed out after waiting for the dba user to have the…
exception error mysql, grants, timeout, mysqlctl
unsupported constraint
exception error vstreamer, binlog, sql, unsupported-feature
VDiff not implemented in vtcombo
exception warning vtcombo, vdiff, unimplemented
can't decode primary replication position
exception error replication, gtid, version-compatibility
DeleteShards(%+v) failed to acquire topoRWPool
exception error resource-pool, timeout, concurrency, vtadmin
ErrNoTablet
for keyspace
exception error vtadmin, topology, tablets, schema
no client certs for connection
validation error mysql, tls, authentication, client-certificate
Not implemented, post_header_length==6
panic error mysql, binlog, panics, unsupported
requested limit is out of range
exception error vtgate, limit, input-validation, sql
running MySQL version
exception error mysql, backup, restore, lts, version-compatibility
shard / has no source shard
exception error filtered-replication, resharding, topo, precondition
unknown metric name
validation error vitess, throttler, validation, grpc
usage: VDiff -- . [ | ]
console error vtctl, vdiff, cli-usage
: uid is already in use
exception error vreplication, shard, resharding, topo
controller could not be initialized for stream %+v on tablet
exception error vdiff, controller, initialization, topology
error received from Stream
exception error grpc, stream, network, binlog-player, vreplication
expected a named type for type argument
panic error go, codegen, generics, type-system