vitessio/vitess
Documented errors, page 3 of 13. Back to vitessio/vitess
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| error getting in | panic | error | go, codegen, vtctldclient, build, reflection |
| json error | console | error | go, json, serialization, vtctl |
| keyspace not found in vschema | exception | error | vtgate, vschema, keyspace, routing |
| unexpected argument type | panic | error | evalengine, panic, type-dispatch, least-greatest, comparison |
| failed to GetCellInfos for cluster | exception | error | vtadmin, vtctld, network, cluster-config |
| obtainQueueLock: empty queue node | exception | warning | zookeeper, topo, locking, race-condition |
| too many vdiffs found | exception | error | vdiff, mysql, duplicate-rows, workflow |
| unexpected error: cannot find diff | exception | error | schemadiff, internal, diff |
VT09016 VT09016 | error_code | error | vitess, planbuilder, foreign-key, unsupported-feature |
| error in selecting vreplication settings | exception | error | mysql, vreplication, database, network |
| insert failed to generate an id | exception | error | vreplication, insert, auto-increment |
| invalid parameter Number from client | validation | error | mysql, prepared-statements, protocol, client-error |
| tablet is no longer healthy: , restarting vstream | exception | error | vreplication, vstream, health-check, mysql |
| unexpected comparison operator | panic | error | evalengine, panic, comparison-operator |
| CopySchemaShard: can't get replication position after… | exception | error | go, replication, tabletmanager, race |
| invalid workflow | error_code | error | vitess, vreplication, workflow, sentinel-error |
| old tablet has shard | exception | error | topo, tablet-registration, keyspace, shard |
| online DDL is disabled | exception | error | ddl, online-ddl, configuration, mysql |
| received signal | console | info | signals, shutdown, grpc, server-lifecycle |
| unable to delete file | exception | error | filesystem, mysqlctl, restore |
| unsupported select expression | validation | error | go, workflow, sql-parsing |
| a conflicting vindex named | exception | error | vitess, vschema, vindex, conflict |
| cannot determine database flavor details for version | exception | error | mysql, version-compatibility, backup |
| creating a table failed. Most likely some tables already… | exception | error | go, schema, mysql, conflict |
| failed to find column name for convert using expression | exception | error | vstreamer, vstream-results, convert-tz, sql-syntax |
| http server stopped | console | warning | http, server-lifecycle, vtadmin |
| mysqld_shutdown hook failed | exception | error | mysql, shutdown, hooks, mysqld, extension-point |
| stream send error | exception | error | streaming, query-execution, callback |
| unexpected character | validation | error | go, json, parsing, syntax-error |
| could not get RoutingRules | validation | error | vreplication, routing-rules, topology |
| database not found | exception | error | vtcombo, keyspace, local-cluster |
| failed to execute vtgate fqdn template for | exception | error | go, vtadmin, consul, template, fqdn |
| invalid base ; must be in [2, 36] | validation | error | parsing, fastparse, integer, invalid-argument |
| mismatched entity type | exception | error | schemadiff, schema-migration, type-mismatch |
| shard / doesn't have a primary set | validation | error | topology, primary, vreplication, workflow |
| the argument is required for the UpdateCellInfo command | validation | error | cli, argument-validation, topology, vtctldclient |
| can't open init-db-sql-file | exception | error | mysql, init, file-io, configuration, path |
| don't know how to advance from | exception | error | vreplication, vcopier, state-machine, internal-bug |
| error reading VReplication settings | exception | error | vreplication, mysql, configuration |
| findWorkflows(keyspaces = , opts = %+v) failed to acquire… | exception | error | resource-pool, timeout, concurrency, workflows, vtadmin |
| no primary in shard record | exception | error | topology, primary-election, shard-record, copy-schema |
| panic(err) — error from partitions.ExecuteToHTML(st.Value) | panic | error | go, panic, template-rendering, debug-status |
| sample has zero variance | validation | error | statistics, ttest, zero-variance |
| got wrong statement id from client | validation | error | mysql, protocol, prepared-statements |
| range should be >= | validation | error | go, json, json-path, parsing, validation |
| remote error | console | error | go, grpc, streaming, vtctl, remote-error |
| : parsing at position | http | error | http, bad-request, parsing, vtadmin |
| cannot decode RelayLogFilePosition | panic | critical | mysql, replication, protobuf-decoding, panic |
| failed to send the ComBinlogDump command | exception | error | mysql, replication, binlog, network |
| gave up waiting for mysqld to stop | exception | error | go, mysqlctl, mysqld-shutdown, timeout |
| unknown vtctl client protocol | validation | error | go, vtctl, client, configuration, factory |
| workflow does not exist | console | error | vreplication, workflow, vtctl |
| invalid hex digit in \u escape | validation | error | json, unicode, escaping, parsing |
| no string value found for ENUM column | exception | error | enum, value-mapping, schema-history, vstreamer |
| all vterrors states are not mapped to mysql errors | panic | critical | mysql, sqlstate, startup-panic, developer-error |
| failed to initialize mysqld | exception | error | mysql, init, startup, sql-script, mysqld |
| GetShardReplication( , , ) failed | exception | error | go, topology, shardreplication, rpc |
| GetTabletsByCell( ) failed | exception | error | go, topology, cell, inconsistency |
| InsertRecoveryDetection: no detection_id returned for alias= | exception | error | vtorc, database, dao |
| rule : clusters list cannot include wildcard and other… | validation | error | rbac, config-validation, vtadmin, authorization |
| unknown enum name for SchemaMigration_Status | validation | error | validation, enum, online-ddl, schema-migration |
| unparsed tail left after parsing int64 from | validation | warning | parsing, int64, trailing-characters |
| unsupported | exception | error | vstreamer, planbuilder, unsupported-sql, vreplication |
| use of closed connection | exception | error | vtadmin, test-double, database |
| err.Error() (invalid variable set value) | http | warning | http-api, vttablet, bad-request, parsing |
| no route variable found with name | http | error | http, routing, vtadmin, request-parsing |
| unexpected: query ended without no results and no error | error_code | error | mysql, protocol, failsafe, server |
| vindexType not found | exception | error | vtgate, vschema, vindex, configuration |
VT03006 VT03006: column count does not match value count with the row | error_code | error | insert-select, column-count, query-planning |
| aborting , primary mitigation is required | exception | warning | vtorc, topology-recovery, stale-analysis |
| can't access file | panic | error | filesystem, zookeeper, panic, permissions |
| can't run init-db-sql-file | exception | error | mysql, initialization, sql-script |
| rule : subjects list cannot include wildcard and other… | validation | error | rbac, config-validation, vtadmin, authorization |
| EmergencyFailoverShard | exception | critical | resource-pool, failover, timeout, incident-response, vtadmin |
| error updating position | exception | error | vreplication, position-update, vreplication-table, mysql |
| failed to successfully refresh all tablets in the | console | error | vitess, traffic-switch, tablet-refresh, source-shard |
| type PRIMARY cannot take backup. if you really need to do… | exception | error | vttablet, backup, primary, safety-check |
| unknown vtctld client protocol | validation | error | go, vtctld, client, configuration, factory |
| err.Error() (EnableRecovery failure) | http | error | http-api, vtorc, recovery |
| failed to execute template | exception | error | go, template, consul, datacenter, execution |
| AbortBackup cannot be called on read-only backup | validation | error | s3, backup, api-misuse, go |
| error reading binlog event | exception | error | mysql, replication, binlog, corruption |
| no default GetFunc for type %T; call Configure with a… | panic | error | go, viper, config, generics, panic |
| the and arguments are required for the Sleep command | validation | error | vtctl, cli, missing-argument, duration |
| unexpected rule in vreplication | validation | error | vitess, vreplication, filter-rules, excluded-table |
| unknown ASTStep | panic | error | codegen, go, sqlparser, ast-path |
| expected a named type for | panic | error | go, codegen, type-system, generics |
| fillStringTemplate failed | exception | error | go, template, schema |
| FindAllShardsInKeyspace | exception | error | rpc, topo, keyspace, vtadmin |
| values for column does not map to keyspace ids | exception | error | vtgate, vindex, lookup, data-consistency |
| can't read init-db-sql-file | exception | error | mysql, init, file-io, read-error, mysqld |
| error parsing template | exception | error | go, template, consul, datacenter |
| no read_only variable in mysql | exception | error | mysql, read-only, mysqlctl, connection |
| unable to construct a LocalController instance because param | validation | error | schemamanager, configuration, local-controller |
| bad command line format for zk config | panic | error | zookeeper, zkctl, config-parsing, command-line |
| cannot load credentials from path template | exception | error | vtadmin, vtctldclient, credentials, configuration |
| GetKeyspaces(cluster = ) failed | exception | error | vtadmin, topology, vtctld, rpc |
| negative stack position | panic | critical | go, panic, compiler, bytecode, internal-invariant |
| no sharded vschema was provided, so you will need to update… | validation | error | vitess, vschema, vindex, traffic-switch |
| action StopReplication requires | validation | error | vtctl, cli, missing-argument, replication |