vitessio/vitess

Documented errors, page 2 of 13. Back to vitessio/vitess

Code / MessageTypeSeverityTags
there are no cells in the topo
exception error topo, vdiff, configuration
unreachable
panic error go, panic, evalengine, comparison, internal-invariant
unsupported
panic error go, panic, evalengine, arithmetic, type-conversion
: , output
exception error mysql, exec, subprocess, mysqld, mysqlctl
a conflicting vindex named
exception error vitess, vschema, vindex, conflict
no shards found in keyspace
error_code error topology, keyspace, vexec, vtctld
panic(err)
panic error go, panic, serialization, evalengine, tuple
unsupported escape
panic error codegen, go, build-time, astfmtgen
preflight_mysqld_shutdown hook failed
exception error mysql, shutdown, hooks, preflight, extension-point
tablet record was taken over by another process: my address…
exception critical topo, tablet-ownership, tablet-management
vreplication streams are not frozen on tablet
validation error go, vreplication, workflow, validation
invalid escape character
validation error json, escaping, parsing
no filtered replication running on tablet
exception error vreplication, replication, migration
can't rebuild serving keyspace while a migration is on…
exception error topo, rebuild-keyspace, resharding, migration
column not found in schema
exception error vitess, schema, column-not-found
invalid signature for UcpTrie: 0x%08x
validation error icu, serialization, regex, binary-data
sample is too small
validation error statistics, ttest, input-validation
GetSchema( )
exception error vtadmin, vtexplain, schema, rpc-failure
tablet type has changed from to , restarting vstream
exception warning vreplication, vstream, tablet-type, failover
EvalResult.coerce with no collation
panic error go, panic, evalengine, collation, coercion
found no possible unique key on
exception error schemadiff, vreplication, unique-key, column-mismatch
GetSchema( , nil, , ) failed
exception error vitess, schema-validation, tablet-rpc
GetSchema( , , , ) failed
exception error go, topology, tabletmanager, schema-copy
streams are mismatched across source shards
console error vitess, vreplication, workflow-migration, shard-consistency
called EvalResult.truncate on non-quoted
panic error go, panic, evalengine, string-handling, coercion
can't get charset to check binlog stream
exception error mysql, binlog, charset, connection
expected ',' or '}' in object, got
validation error go, json, parsing, syntax-error
failed to get post copy actions for the
exception error vreplication, mysql, locking, go
the <keyspace/shard> argument is required for the…
validation error vtctl, cli, missing-argument, keyspace-shard
too big depth for the nested JSON; it exceeds
validation error go, json, recursion, depth-limit, security
unexpected Numeric type
panic error go, panic, compiler, arithmetic, type-system
table not found in schema
validation error vreplication, schema, filter-rules, plan-builder
cannot update immutable column
error_code error vreplication, vexec, query-planner
found an entry from a previous run for migration id
exception error movetables, resharding-journal, vreplication
ReadTopologyInstance(%+v): %+v
validation warning vtorc, topology-discovery, tablet, mysql
bad literal argument
panic error go, codegen, tooling, panic, astfmtgen
first event from binlog
exception error mysql, replication, binlog, corruption
mismatched ShardSession count: originally
exception error go-driver, database-sql, transactions, shard-sessions
failed to read tablet
exception error vtorc, database, topology-recovery
internal error: vplayer is in a transaction on event
exception error vreplication, internal-error, transaction-state, vplayer
table not found in vschema
console error vitess, vschema, vreplication, schema-drift, config-error
vindex is in write-only mode
validation error vindex, lookup-vindex, vschema, migration
BUG: sqlparser emitted unknown type
panic error evalengine, panic, cast, convert, sqlparser
errors loading package
panic error go, codegen, package-loading, build
routing still exists from keyspace
validation error go, routing-rules, vreplication, validation
value
validation error backup, compression, configuration
cannot adapt getter to synchronized viper which is already…
panic error go, panic, config, viper, initialization-order
error unmarshaling query rules
exception error vttablet, topo, query-rules, json
switch command shards not in topo
validation error go, topology, sharding, validation
tablet type change -> is not an allowed transition for…
exception error vitess, tablet, topology, validation
unsupported type %T
panic error go, panic, evalengine, type-coercion
: cannot launch schema migration in
validation error vtadmin, rbac, authorization, schema-migration
cannot execute remote command
console error go, network, grpc, vtctl, rpc
cannot reshard streams with a mix of reference and sharded…
console error vreplication, resharding, reference-tables, validation
enum or set column does not have valid string values: ; the…
exception error enum, set, schema-history, dropped-column, vstreamer
error getting select
validation warning sqlparser, tenant, internal, movetables
error initilaizing vtexplain
exception error vtadmin, vtexplain, vschema, initialization
failed to delete post copy action for the
exception error vreplication, mysql, go
failed to set session foreign_key_checks
exception error vreplication, mysql, foreign-keys, session-variable
no tables in workflow
exception error vreplication, movetables, workflow
overflow
validation error decimal, overflow, parsing, mysql
UnicodeLooseMD5.Map
exception error vtgate, vindex, utf-8, routing
listener closed
console warning listener, mux, server-lifecycle, vtadmin
shard / has a different KeyRange: !=
exception error topo, tablet, keyrange, shard
ValidateVSchema( , , , ) failed
exception error validation, vschema, aggregated-error, wrangler
cannot decode Position
panic error panic, replication, proto, position-decode
error dialing binlog server
exception error network, grpc, dial, binlog-server, vreplication
failed to generate vtgate consul datacenter from template
exception error go, template, consul, discovery, config
no primary in shard record
exception error topology, primary-election, shard-record, copy-schema
panic
panic critical go, panic, vreplication, recovered-panic
query not supported by vexec
error_code error vexec, sql, planner, unsupported-query
ReadFile cannot be called on read-write backup
validation error go, mysqlctl, backup-storage, api-misuse
unable to connect to the database when attempting to kill…
exception warning vreplication, mysql, connection, go
cannot Notify after starting to watch a config
panic error go, viper, config, lifecycle, panic
err.Error() (Fprintf write failure)
http warning http, vtgate, debug-endpoint, write-failure
only count(*) is supported
validation error vreplication, sql, aggregation, vttablet
rule : actions list cannot include wildcard and other…
validation error rbac, config-validation, vtadmin, authorization
schemas differ on table type for table
exception error schema, drift, mysqlctl
action StartReplication requires
validation error vtctl, cli, missing-argument, replication
invalid hook name
validation error validation, hook, path-traversal
some streams already exist in the target shards, please…
validation error resharding, vreplication, wrangler
unable to perform time_zone conversions from
exception error vitess, wrangler, mysql, timezone, environment
unknown schema migration strategy
validation error validation, enum, online-ddl, schema-migration
--batch-size requires 'direct' ddl_strategy
validation error go, schemamanager, configuration, flags
cannot find serving, non-primary tablet in keyspace=
exception error vtadmin, vtexplain, topology, tablet-availability
: cannot switch traffic for workflow in
error_code error rbac, authorization, vtadmin
err.Error() (JSON marshal failure)
http warning vttablet, twopc, json, serialization
not allowed: deny-all security-policy enforced
http error vtadmin, schema, topology, duplicate-data
unable to perform time_zone conversions from
console error vitess, workflow, materialize, timezone, mysql
failed to resolve keyspace wildcard
console error vtctl, topo, keyspace, wildcard
FindAllShardsInKeyspace
exception error resource-pool, timeout, concurrency, vtadmin
in keyspace for
validation error go, vreplication, workflow, topology
did not typecheck cardinality
panic error evalengine, panic, tuple-comparison, typecheck
could not stream health records from tablet
exception error network, streaming, health-check
GetSchema( , nil, , ) ( / ) failed
exception error tablet, rpc, schema, validation
mysqld >= 8.0.21 required to disable the redo log
exception error mysql, version-compatibility, redo-log, backup
%w %q
error_code error backup, restore, compression, xtrabackup
could not parse shard name
validation error vtorc, config, shard-parsing
unregistered Authenticator implementation
exception error vtadmin, rbac, configuration
did not compile?
panic error go, panic, compiler, type-system, arithmetic