prestodb/presto
Documented errors, page 6 of 13. Back to prestodb/presto
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Argument of type from is not supported. | validation | error | unsupported, arguments, validation, verifier |
| Can not read SQL type | exception | error | orc, schema-mismatch, type-validation, corruption |
| createClob | exception | error | jdbc, presto, unsupported-operation, clob |
| Error reading parquet page in column | exception | error | parquet, page-decoding, corrupt-data, io |
MISSING_CATALOG Catalog does not exist | error_code | error | catalog, metadata, missing, semantic |
| StatementClient thread was interrupted | exception | warning | interruption, threading, shutdown |
| Unexpected fragment partitioning | exception | error | presto-on-spark, illegal-argument, unknown-partitioning, rdd-factory |
| updateBinaryStream | exception | error | jdbc, sqlfeaturenotsupportedexception, read-only-resultset, presto |
| Validation failed | exception | error | rcfile, corruption, io |
| Deserialized MapBlock violates invariants: key | validation | error | deserialization, map-block, data-corruption |
HIVE_UNSUPPORTED_ENCRYPTION_OPERATION Creating an encrypted table without partitions is not supported. Use CREATE… | error_code | error | hive, encryption, ctas, not-supported |
| Invalid file size | exception | error | orc, corrupt-file, file-size |
| Truststore is empty - no trusted certificates found | exception | error | presto, ssl, truststore, tls |
| Unsupported task content | exception | error | iceberg, unsupported-operation, delete-files, compatibility |
| Expected TimestampType but got | validation | error | arrow, java, type-mismatch, timestamp, illegal-argument |
HIVE_SERDE_NOT_FOUND Serializer does not exist: | error_code | error | hive, serde, classpath, metadata |
HIVE_WRITER_OPEN_ERROR Error creating RCFile file | error_code | error | hive, rcfile, writer, open, io |
| Invalid token URI: | validation | error | authentication, uri, okhttp, validation |
| Invalid value [ ]. Valid values | exception | error | configuration, table-properties, validation, enum |
| Plugin-configured tracer provider | exception | error | tracing, configuration, plugin, mismatch |
| positionCount is negative | validation | error | |
| Precision not supported | exception | error | timestamp, precision, unsupported-operation |
PROMETHEUS_UNKNOWN_ERROR Error reading metrics | error_code | error | io, network, http, prometheus |
TABLE_ALREADY_EXISTS Table ' ' already exists | error_code | error | presto, table, duplicate, ddl, idempotency |
HUDI_CURSOR_ERROR HUDI_CURSOR_ERROR | error_code | error | presto, hudi, cursor, page-source, wrapped-exception |
| privileges not supported | exception | warning | jdbc, metadata, unsupported-feature, presto |
SUBQUERY_MULTIPLE_ROWS Scalar sub-query has returned multiple rows | error_code | error | subquery, sql, runtime |
| Type is not supported | exception | error | kudu, sink, unsupported-type |
| Unknown type | exception | error | parquet, schema, type-mapping, version-compatibility |
| Unsupported principal type: | validation | error | hive-metastore, principal-type, mapping, illegal-argument |
| Column ' ' does not support 'null' value | exception | error | kafka, encoder, null-value, presto-connector |
PINOT_EXCEPTION Expected pinot to contain | error_code | error | pinot, schema-mismatch, data-fetch, column-count |
| Unsupported frame type: | exception | error | window-function, internal-error, frame |
| Error encoding historicalPlanStatistics value | exception | error | redis, thrift, serialization, hbo |
| ConnectorInsertTableHandle ConnectorInsertTableHandle | validation | error | json, deserialization, parse-error, insert-table-handle |
| Total rows is larger than 2^64 | validation | error | tpch-connector, overflow, illegal-argument |
| updateBoolean | exception | error | jdbc, unsupported-feature, updatable-resultset, sqlfeaturenotsupportedexception |
| Expected AbstractSingleRowBlock | exception | error | presto, row-block, type-mismatch, appendstructure |
| Invalid dataFormat ' ' for column | validation | error | kafka, configuration, enum-parsing |
| Materialized view already exists | exception | error | hive, materialized-view, already-exists, ddl |
| S3 Select request was incomplete as End Event was not… | exception | error | |
| SHOW CREATE only supported for tables and views | exception | error | presto, sql, unsupported-feature, internal |
UNSUPPORTED_ANALYZER_TYPE Unsupported analyzer type: | error_code | error | config, lookup, presto |
| Desktop Browser is not available. Make sure your Java… | exception | error | authentication, desktop, headless, redirect |
PINOT_INSUFFICIENT_SERVER_RESPONSE Only out of servers responded for query | error_code | error | pinot, distributed-query, timeout, partial-response |
| Unknown codec | exception | error | classpath, compression, configuration, rcfile |
| BloomFilters are not compatible for merging. this - | exception | error | orc, bloom-filter, statistics-merge, incompatible-parameters |
| Decoded value out of range for a 16bit number | exception | error | orc, corruption, schema-mismatch, integer-overflow |
HIVE_PARTITION_DROPPED_DURING_QUERY Partition no longer exists | error_code | error | hive, partition, concurrency, metastore |
| Not implemented: PreparedStatement.getParameterMetaData | exception | warning | jdbc, unsupported-feature, metadata |
| Failed to acquire lock | exception | error | hive, metastore, locking, concurrency |
| row identifiers not supported | exception | warning | jdbc, metadata, unsupported-feature, presto |
| Unknown converted type | exception | error | parquet, schema, logical-type, version-compatibility |
| Unsupported column encoding kind: | exception | error | orc, column-encoding, metadata-writer, unsupported-kind |
| Write validation failed: unexpected number of columns in | exception | error | orc, write-validation, statistics, schema |
| Authentication using Kerberos requires SSL to be enabled | validation | critical | jdbc, kerberos, ssl, authentication, security |
| Cannot insert into table | exception | error | presto, security, authorization, insert, write |
| Error setting up SSL: | exception | error | ssl, tls, presto-client, security, configuration |
| Failed to read or decrypt FileStatistics for node | exception | error | orc, dwrf, encryption, file-statistics |
| Unknown AccessMode: | validation | error | presto, access-control, json-config, enum-parsing, validation |
| updateAsciiStream | exception | error | jdbc, sqlfeaturenotsupportedexception, read-only-resultset, presto |
DRUID_SEGMENT_LOAD_ERROR failed to load druid segment | error_code | critical | druid, segment, io, segment-loading |
| getCursorName | exception | error | jdbc, presto, unsupported-operation, cursor |
| Iceberg table updates require at least format version 2 and… | exception | error | |
KAFKA_SCHEMA_ERROR Unable to read data schema at | error_code | error | kafka, avro, schema, io, presto-connector |
| ConnectorTableLayoutHandle ConnectorTableLayoutHandle | validation | error | json, deserialization, parse-error, table-layout-handle |
| updateTimestamp | exception | error | jdbc, sqlfeaturenotsupportedexception, read-only-resultset, presto |
ACCUMULO_TABLE_EXISTS Cannot create internal table when an Accumulo table already exists | error_code | error | presto, resource-groups, configuration, scheduling |
| isExplainTypeValidate method is not supported! | exception | error | |
| KeyStore certificate | exception | error | ssl, certificate-validity, keystore, clock-skew |
| Not implemented: PreparedStatement.setAsciiStream | exception | error | |
SCHEMA_ALREADY_EXISTS Schema ' ' already exists | error_code | error | presto, schema, duplicate, ddl, idempotency |
| Unsupported frame end type: | exception | error | window-function, internal-error, frame |
| e.getMessage() | exception | error | jdbc, presto, batch |
ICEBERG_WRITER_OPEN_ERROR Error creating Parquet file | error_code | error | iceberg, parquet, writer, io-exception, filesystem |
| Invalid ColumnIO received. Expected a GroupColumnIO, but got | exception | error | |
INVALID_SPATIAL_PARTITIONING Expected exactly one row for table | error_code | error | spatial, join, configuration |
| Invalid timestamp from server: | exception | error | jdbc, presto, timestamp-parsing, sql |
| map keys cannot be null | exception | error | illegal-argument, map-block, null-key, hashing |
TABLE_FUNCTION_MISSING_ARGUMENT Missing argument: | error_code | error | sql, table-function, missing-argument, semantic-analysis |
| invalid entry crc-32 | validation | error | zip, crc32, validation, unsigned-integer |
| Table metadata is missing | exception | error | iceberg, metadata, file-not-found, storage |
| updateFloat | exception | error | jdbc, unsupported-feature, updatable-resultset, sqlfeaturenotsupportedexception |
VIEW_PARSE_ERROR Failed parsing stored view | error_code | error | sql, view, parse, syntax |
| Bad type signature | validation | error | presto, type-signature, parsing, illegal-argument |
| getObjectValue is not supported for TIMESTAMP( | exception | error | presto, unsupported-operation, timestamp-precision |
KAFKA_CONSUMER_ERROR Failed to find offset by timestamp | error_code | error | kafka, offsets, timestamps, presto-connector |
| LEARN must run on a single machine | exception | error | |
| min-input-files must be at least 1, got | validation | error | iceberg, validation, procedure-options, argument-parsing |
MUST_BE_AGGREGATION_FUNCTION Filter is only valid for aggregation functions | error_code | error | sql, filter-clause, aggregation, semantic-analysis, presto |
| Unrecognized connection property | validation | error | |
| Value is not null but seconds stream is missing | exception | error | |
| Write validation failed: unexpected date range in | exception | error | |
| app-secret not provided in " + secretFile | validation | critical | config, secret, validation, startup |
| Dictionary is missing for Page | exception | error | parquet, dictionary, decoding, missing-data |
| grouped execution is not supported in presto on spark | exception | error | presto-on-spark, grouped-execution, unsupported-operation, session-property |
| Only a single plugin should set the tracer provider | exception | error | tracing, plugin, configuration, duplicate-registration |
| otherOffset , length are invalid for otherSlice with length | exception | error | presto, block, int128, bounds-check, illegal-argument |
| Request to remote Presto server failed | exception | error | network, http, proxy, connection |
| setURL | exception | warning | jdbc, unsupported-feature, prepared-statement |