prestodb/presto
Documented errors, page 5 of 13. Back to prestodb/presto
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| No wrapper for | exception | error | jdbc, unwrap, wrapper, type-cast |
BIGQUERY_VIEW_DESTINATION_TABLE_CREATION_FAILED Error creating destination table | error_code | error | bigquery, views, destination-table, permissions |
| Invalid credentials | http | warning | ldap, authentication, bind, access-denied |
ROLE_ALREADY_EXIST Role ' ' already exists | error_code | error | presto, role, duplicate, ddl, access-control |
| Unknown cluster Ttl provider manager | exception | critical | configuration, guice, ttl, presto, startup |
| unknown java type | exception | error | presto, hive, unsupported-type, bucketing |
| Cannot allocate slice larger than | exception | error | java, presto, slice-too-large, allocation |
DRUID_METADATA_ERROR Unsupported segment filesystem | error_code | error | druid, metadata, deep-storage, unsupported-filesystem |
| mismatched input ' '. Expecting | exception | error | sql, parser, syntax-error |
MISSING_ROLE Role ' ' does not exist | error_code | error | sql, security, roles, semantic-error |
| arrayOffset is negative | exception | error | presto, shortarrayblock, argument-validation, blocks |
| DatabaseMetaData | exception | error | jdbc, unimplemented, metadata, functions |
| EOF while reading unsigned vint | exception | error | orc, varint, eof, truncated-file |
| Error executing query | exception | error | |
| Failed to initialize SSLContext | exception | error | redis, tls, ssl, jdk |
| Invalid property tpcds.splits-per-node | validation | error | tpcds, configuration, invalid-property |
| KeyStore certificate is not yet valid: | exception | critical | elasticsearch, ssl, certificate-not-yet-valid, clock-skew |
PROMETHEUS_PARSE_ERROR Unable to parse Prometheus response: | error_code | error | |
| ROW comparison not supported for fields with null elements | exception | error | comparison, null, row-type, unsupported |
| rowDeleted | exception | info | jdbc, unsupported-feature, sqlfeaturenotsupportedexception, read-only-resultset |
DRUID_DEEP_STORAGE_ERROR Failed to create page source on | error_code | error | druid, deep-storage, io, segment-read |
HIVE_METASTORE_INITIALIZE_SSL_ERROR Hive metastore SSL initialization error | error_code | critical | ssl, tls, keystore, initialization, hive-metastore |
INVALID_SCHEMA_PROPERTY Invalid location URI: | error_code | error | iceberg, hdfs, invalid-uri, schema-creation |
ORDER_BY_MUST_BE_IN_AGGREGATE For aggregate function with DISTINCT, ORDER BY expressions must appear in… | error_code | error | sql, aggregation, distinct, order-by, presto |
| RowExpression RowExpression | exception | error | json, deserialization, presto-protocol, row-expression |
| Invalid column label: | exception | error | |
| Prepared SQL statement is not a query: | exception | error | |
PROCEDURE_NOT_FOUND Distributed procedure not registered: | error_code | error | presto, call-statement, procedure, connector |
VIEW_IS_RECURSIVE Statement would create a recursive view | error_code | error | sql, view, recursion, semantic-analysis |
BIGQUERY_QUERY_FAILED_UNKNOWN Failed to run the query | error_code | error | bigquery, interrupted, query, google-cloud |
| KeyStore certificate is expired | exception | critical | ssl, keystore, certificate-expired, hive-metastore, tls |
| ConnectorPartitioningHandle | validation | error | |
| Read past end of buffer RLE byte | exception | error | orc, corruption, rle, eof, truncated-file |
| Request has different number of fields than column handles | validation | error | flight, arrow, schema-mismatch, getstream |
| Unable to parse sort field | validation | error | iceberg, ddl, syntax, sort-order |
| Unsupported column type: | exception | error | hive, record-cursor, unsupported-type |
| Unsupported compression for verification: | exception | error | orc, compression, configuration, illegal-argument |
| Batch prepared statement must be executed using… | exception | error | jdbc, batch, prepared-statement |
| DECIMAL scale must be in range [0, precision] | validation | error | presto, type-system, decimal, argument-validation |
| failed to retrieve table metadata from | exception | error | iceberg, metadata, corruption, storage |
| Hive view is not supported | exception | error | hive, view, metastore, unsupported-feature |
| Map keys must not be null | exception | error | illegal-argument, map-block, null-key |
MISSING_SCHEMA Schema ' ' does not exist | error_code | error | presto, schema, metadata, sql |
| Substitution of with from | validation | error | verifier, expression-rewrite, unsupported-type, illegal-argument |
| Type must be a TimestampType for TimeStampMilliTZVector | validation | error | arrow, type-mismatch, timestamp, timezone |
| Unsupported update mode | exception | error | hive, internal, update-mode, illegal-argument |
| Cannot truncate table | exception | error | presto, security, authorization, truncate, ddl |
| Failed to load truststore as both PEM and KeyStore format… | exception | error | presto, ssl, truststore, pem, configuration |
INVALID_COLUMN_MASK Multiple masks for the same column found | error_code | error | presto, access-control, column-masking, security, config |
INVALID_PROCEDURE_ARGUMENTS A GROUPING() operation can only be used with a corresponding GROUPING… | error_code | error | sql, grouping, group-by, semantic-analysis |
| no abstract type RowExpression | exception | error | serialization, type-error, presto-protocol, row-expression, subclass-dispatch |
| Unhandled nullable type: | exception | warning | jdbc, metadata, version-skew |
| Failed to create Broker auth provider | exception | error | pinot, authentication, reflection, compatibility |
| fieldType.getTypeSignature() + " type is not orderable" | exception | error | comparison, unsupported-operation, row-type |
| ids length is less than positionCount | exception | error | block, dictionary, argument-validation, presto |
| insertRow | exception | error | jdbc, presto, unsupported-feature, sqlfeaturenotsupported |
INVALID_RETRY_EXECUTION_STRATEGY Execution strategy not supported: | error_code | error | presto, spark, configuration, invalid-enum |
| Invalid timestamp | error_code | error | presto, timestamp, parsing, datetime |
MISMATCHED_SET_COLUMN_TYPES Mismatch at column | error_code | error | sql, insert, type-mismatch, arity |
| Required configuration 'flight-shim.server' and… | validation | critical | config, startup, missing-property, flight |
| Unexpected partitioning: | exception | error | spark, partitioning, illegal-argument, planner |
| Unsupported compression kind: | exception | error | orc, compression, metadata-writer, unsupported-codec |
| rowInserted | exception | info | jdbc, unsupported-feature, sqlfeaturenotsupportedexception, read-only-resultset |
| SparkConf must be initialized with… | exception | error | java, spark, configuration, initialization |
| Unable to save snapshot | exception | error | verifier, json, jackson, ddl |
UNSUPPORTED_STORAGE_TYPE Configured TempStorage does not support remote access required for distributing… | error_code | error | spark, temp-storage, broadcast-join, configuration |
BIGQUERY_FAILED_TO_EXECUTE_QUERY Failed to compute empty projection | error_code | error | bigquery, split-planning, query-execution |
| catalog must be present if schema is present | validation | error | presto, validation, illegal-argument, security |
| could not close some single stream spillers | exception | error | spill, io, resource-cleanup, presto |
ICEBERG_INVALID_SPEC_ID Given spec id does not exist | error_code | error | iceberg, partition-spec, procedure-argument |
MULTI_CATALOG_WRITE_CONFLICT Multi-catalog writes not supported in a single transaction. Attempt write to… | error_code | error | transaction, presto, multi-catalog |
MUST_BE_WINDOW_FUNCTION Not a window function | error_code | error | sql, window-function, function-kind, semantic-analysis |
| owner cannot be present with runAsInvoker | validation | error | spi, illegal-argument, view-definition, invariant-violation |
| ColumnHandle ColumnHandle | validation | error | json, deserialization, parse-error, column-handle |
BIGQUERY_ERROR_END_OF_AVRO_BUFFER Error determining the end of Avro buffer | error_code | error | bigquery, avro, io, stream |
| Can't handle type: | exception | error | predicate-pushdown, type-mapping, sql-generation, clickhouse |
| imported keys not supported | exception | warning | jdbc, unsupported-feature, metadata, foreign-keys |
| Initial capacity ' ' is negative | exception | error | illegal-argument, block, collections |
INVALID_ANALYZE_PROPERTY Invalid null value in analyze partitions property | error_code | warning | presto, hive, analyze, invalid-property, null-value |
| Invalid uncompressedSize for GZIP input. Expected | exception | error | |
| unsupported column type | validation | error | presto, decoder, unsupported-type, configuration |
| Value is not null but scale stream is not present | exception | error | orc, corruption, decimal, missing-stream, presto |
| cross reference not supported | exception | warning | jdbc, unsupported-feature, metadata, foreign-keys |
| Invalid row block: | exception | error | block, row, type-mismatch, presto |
| lookup is not supported | exception | error | thrift, testing, unsupported-operation, lookup |
| Specified timeZoneId is not supported: | validation | error | jdbc, timezone, configuration, connection |
| Unexpected default trust managers: | exception | error | presto, ssl, trustmanager, jvm |
VIEW_NOT_FOUND View not found, the available view names are | error_code | error | views, metadata, catalog |
| Cannot delete from table | exception | error | presto, security, authorization, delete |
| Invalid position and length in block with positions | validation | error | java, presto, index-out-of-bounds, block-region |
| No value specified for parameter | exception | error | jdbc, parameter-binding, prepared-statement |
PROMETHEUS_TABLES_METRICS_RETRIEVE_ERROR Prometheus did no return metrics list (table names) | error_code | error | prometheus, http, connector, metrics |
| State validation failed | http | error | |
| Truststore must not be null for TLS connections | validation | error | redis, tls, ssl, configuration |
WINDOW_FUNCTION_ORDERBY_LITERAL ORDER BY literals/constants with window function | error_code | error | sql, window-function, order-by, performance, semantic-analysis |
| cannot do sequential write after getFieldBlockBuilder is… | exception | error | presto, block-builder, illegal-state, api-misuse |
| Cannot rename a column in table | exception | error | presto, security, authorization, ddl |
| Response does not contain a JSON value | exception | error | http, json, presto-client, illegal-state, response-parsing |
TRANSACTION_CONFLICT Dropping and then recreating the same table in a transaction is not supported | error_code | error | hive, transaction, conflict, drop-create |
| Unknown object inspector category: | exception | error | hive, serde, object-inspector, unsupported-type |