nats-io/nats-server
Documented errors, page 8 of 10. Back to nats-io/nats-server
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| max_expires must not be negative | validation | error | jetstream, consumer-config, validation, duration |
| missing 'key_file' in TLS configuration | validation | error | tls, config-validation, missing-file |
| claim based accounts can not be updated directly | exception | error | nats-server, jwt-claims, account |
| could not fetch < >: no response | exception | warning | nats-server, http, account-resolver |
| Error decoding sources state | console | error | |
| proxy username and password must both be specified or both… | validation | error | configuration, leafnode, proxy, authentication |
| sort by reason only valid on closed connections | http | error | monitoring, connz, invalid-options |
| unable to add account | validation | error | reload, cluster, account-lookup |
| Unsafe quorum rescue expired, quorum restored to | console | error | |
| unsupported type | exception | error | protobuf, wire-format, encoding |
| Got an error re-encoding append entry | console | error | |
| invalid consumer create response | error_code | error | |
| max_bytes must be set to -1 | error_code | error | jetstream, stream-config, pedantic, validation |
| processHeaderPub Bad or Missing Header Size | validation | error | protocol, parsing, nats |
| subject filter ' ' for the source | exception | error | jetstream, stream-sources, subject, validation |
| bad sampling percentage, should be 1-100 | error_code | error | nats, server, service-latency, validation |
| config reload not supported for cluster port: old= | validation | error | |
| duplicate call to create subscription for service import | exception | error | nats-server, service-import, duplicate-subscription |
| start sequence can not be updated | validation | error | jetstream, consumer, start-sequence, immutable-config |
| sublist: no matches found | error_code | error | |
| could not open event log | panic | critical | windows, syslog, eventlog, panic |
| no processes running | exception | error | |
| processRoutedMsgArgs Bad or Missing Reply Indicator | validation | error | nats-server, protocol, routing, queue-groups |
| remote : cannot be added at the moment, try again | validation | error | reload, leafnodes, race-condition |
| short write to temporary file | exception | critical | filestore, filesystem, io, jetstream, go |
| thw: encoded version not known | validation | error | |
| Message scheduling state is outdated; attempting to recover… | console | error | |
| mqtt | validation | error | mqtt, tls, configuration |
| cluster export deny | validation | error | config, permissions, subjects |
| sealed stream | validation | error | |
| JetStream encryption key may not be used with TPM options | validation | error | jetstream, encryption, tpm, configuration-conflict |
| stream closed | error_code | error | |
| Could not find a starting entry for catchup request | console | error | |
| found existing OCSP status for certificate at | validation | error | |
| invalid null character in | validation | error | mqtt, topic-validation, null-byte, protocol-violation |
| websocket | validation | error | websocket, tls, pinned-certs |
| failed to decode consumer | exception | error | jetstream, stream-restore, json, consumer, schema-validation |
| failed to write CONNECT request | exception | error | network, proxy, write, connect |
| if Will flag is set to 0, Will QoS must be 0 too, got | validation | error | |
| invalid stream update response: missing stream info | exception | error | jetstream, mqtt, protocol, invalid-response, stream-update |
| preload account error for | validation | error | nats-server, jwt, account-claims, configuration |
| stream names do not match | validation | error | |
| cannot find local account | validation | error | |
| expected cluster password to be set | validation | error | |
| cluster name from remote server conflicts | error_code | error | |
| received a second CONNECT packet | validation | error | mqtt, protocol, connect, reconnect |
| system_account in config and operator JWT must be identical | validation | error | nats, jwt, system-account, config-validation |
| unrecognized cipher | validation | error | tls, config-validation, cipher |
| could not create consumer storage directory | exception | critical | jetstream, filesystem, permissions, go |
| eventing shut down | exception | error | nats-server, shutdown-race, account-lookup, eventing |
| enforceMsgPerSubjectLimit took | console | error | |
| expected 'cert_match_by' to be a valid non-empty string | validation | error | configuration, tls, validation, certstore |
| expected Zulu formatted DateTime, but got | validation | error | config, parsing, datetime, timezone |
| nil config on stream restore | validation | error | |
| rollup not permitted | error_code | error | |
| invalid sorting option | http | error | |
| malformed request | validation | error | nats, jwt, operator-claims, validation |
| max_waiting must not be negative | validation | error | |
| OCSP staple from peer not current | validation | error | |
| processHeaderPub Header Size larger then TotalSize | validation | error | protocol, parsing, validation |
| raft: could not create storage directory | exception | critical | raft, storage, filesystem, jetstream |
| setting up internal jetstream subscriptions failed | exception | error | jetstream, subscriptions, internal-api, startup |
| stream description is too long, maximum allowed is | error_code | error | jetstream, stream-config, length-limit, description |
| variable reference for | validation | error | config, variables, interpolation, parsing |
| incomplete cert chain, got | exception | error | tls, ocsp, certificate-chain |
| no certificate found | validation | error | |
| Canceling catchup for | console | error | |
| conflicting options for 'TrustedKeys' and 'TrustedOperators' | validation | error | nats, jwt, config-validation, operator-mode |
| processHeaderPub Bad or Missing Total Size | validation | error | protocol, parsing, overflow |
| expected 'cert_store' to be a valid non-empty string | validation | error | configuration, tls, validation, certstore |
| Snapshot with last index 0 is invalid, cleaning up | console | error | |
| store_dir not set | validation | error | |
| can't listen to the monitor port | exception | error | nats-server, monitoring, network, port-in-use |
| failed to clear deadline | exception | error | |
| failed to parse cert | validation | error | tls, ocsp, x509, certificate-parsing |
| failed to read IPv6 address data | validation | warning | network, io, proxy-protocol |
| max age needs to be >= 100ms | error_code | error | jetstream, stream-config, validation, duration |
| unsupported TLS version | validation | error | tls, config-validation, security |
| failed to parse OCSP response from | validation | error | |
| invalid retention | error_code | error | jetstream, stream-config, retention-policy, enum |
mqttConnAckRCQoS2WillRejected server does not accept QoS2 for Will messages | error_code | error | |
| raft: illegal peer | validation | error | raft, jetstream, cluster |
| compressed buffer is too short | exception | error | compression, checksum, data-corruption |
| non-ok http status on GET request | http | error | |
| user JWT is not a valid scoped user | validation | error | |
| bad OCSP status update for certificate at | validation | error | |
| if Will flag is set to 0, Will Retain flag must be 0 too | validation | error | mqtt, protocol, client-error |
| no issuers found | validation | error | ocsp, tls, certificate-chain, configuration |
| peer missing OCSP Staple | validation | error | |
| unable to load data | exception | critical | tpm, windows, key-loading, blob, go |
| end of range ( ) above maximum ( ) | validation | error | cron, parsing, range-validation |
| generated invalid subject | validation | error | |
| max_msgs_per_subject must be set to -1 | error_code | error | jetstream, stream-config, pedantic, validation |
| sort by stop only valid on closed connections | http | error | |
| duplicate user detected in leafnode authorization | validation | error | leafnode, auth, duplicate-user, config-validation |
| failed to decode escaped character | exception | error | ldap, dn-parsing, hex-decoding |
| failed to read proxy response | exception | error | network, proxy, http, response |
| generated invalid subject | validation | error | |
| message TTL disabled | error_code | error | |
| unsupported minimum TLS version | validation | error | tls, config, protocol-version |