ErrLookup › nats-io/nats-server
nats-io/nats-server
High-Performance server for NATS.io, the cloud and edge native messaging system. · Go · 132 source files
Analyzed at 3a66a489d2 on 2026-09-02. 922 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| service import not authorized | error_code | error | nats, authorization, account-jwt, service-import |
| consumer write error | exception | critical | jetstream, raft, cluster, consumer |
| stored session does not match client ID | validation | error | mqtt, session, nats-server, storage |
| stream missing | exception | warning | jetstream, nats, health-check, clustering |
| for stream ' > | validation | critical | jetstream, raft, leaderless, catchup, cluster |
ErrBadRSAHashAlgorithm unsupported RSA hash algorithm | error_code | error | windows, certificate-store, rsa, hash-algorithm, signing |
| invalid mapping destination: invalid transform | validation | error | subject-mapping, transform, config |
| shutting down | exception | info | jetstream, cluster, shutdown, raft |
| character not supported for MQTT topics | validation | error | mqtt, topic-validation, encoding |
| NCryptOpenStorageProvider returned | error_code | error | windows, tls, cng, keystore |
10111 rollup value invalid | validation | error | jetstream, rollup, headers, validation |
| remote leaf node URL | validation | error | fips, websocket, leafnode, config-validation |
| authorization response had validation errors | validation | error | jwt, auth-callout, validation |
| consumer closed | exception | warning | jetstream, consumer, cluster, leader-election |
| config reload does not support moving to or from an account… | validation | error | nats-server, config-reload, accounts-resolver |
| : invalid signature | validation | error | proxy-protocol, network, signature-validation |
| wrong gateway | error_code | error | nats, gateway, configuration-mismatch |
ErrInvalidArchive archive: invalid archive stream | error_code | error | go, archive, corrupt-data, io |
| import forms a cycle | error_code | error | nats, account-jwt, cycle, service-import, stream-import |
| unsupported PROXY protocol version | validation | warning | proxy-protocol, versioning, defensive-guard |
| processRoutedOriginClusterMsgArgs Parse Error | validation | error | |
| failed to be ready for connections after | exception | error | |
ErrNoPrivateKeyStoreRef unable to obtain private key handle from store | error_code | error | windows, certificate-store, private-key, ncrypt |
| lookup stream for account | exception | error | mqtt, jetstream, stream-lookup, configuration |
| unable to extract property from key | exception | error | windows, certstore, cryptoapi, private-key |
| unable to plug TLS verify connection, config is nil | exception | error | tls, ocsp, config, nats-server |
10071 last sequence mismatch | error_code | error | jetstream, publish, concurrency-conflict, expected-last-sequence |
| error parsing certificate | validation | error | tls, certificate, x509, config |
| server is not running | error_code | error | nats, jetstream, server-lifecycle, shutdown |
| config reload not supported for jetstream storage directory | validation | error | nats-server, config-reload, jetstream |
| failed to parse message sequence | exception | error | jetstream, restore, corruption, backup |
| invalid publish message, variable header exceeds remaining… | validation | error | mqtt, protocol, packet-parsing, nats-server |
| jetstream account not registered | exception | error | jetstream, account-lifecycle, nats-server |
| system account can not be in default_js_domain | validation | error | jetstream, configuration, system-account |
| publish deny | validation | error | config, permissions, validation, nats |
| could not decode avl dmap | exception | critical | jetstream, filestore, corruption, deserialization |
| unsupported consumer | exception | error | jetstream, cluster, version-compatibility, consumer |
| create retained messages stream for account | exception | error | jetstream, mqtt, stream-creation, nats-server |
| leaf nodes and gateways (both being defined) require a… | validation | error | leafnode, gateway, system-account, config-validation |
ErrBadSigningAlgorithm unsupported signing algorithm | error_code | error | windows, certificate-store, signing, type-mismatch |
ErrStoreRSASigningError unable to obtain RSA signature from store | error_code | error | windows, certificate-store, rsa, ncrypt, signing |
| not trusted | exception | error | nats, jwt, operator-claims, security |
ErrIncompleteEntry archive: entry not fully written | error_code | error | go, archive, writer, protocol-violation |
| OCSP peer verification for client connections requires TLS… | exception | error | tls, mtls, ocsp, config, nats-server |
| unable to register client OCSP verification | exception | error | tls, ocsp, config, nats-server, startup |
| attempted to connect to wrong port | error_code | error | nats, leafnode, wrong-port, configuration |
| expected consumer, found | validation | error | jetstream, stream-restore, archive-format, consumer |
| expected state.json first | validation | error | jetstream, stream-restore, archive-format |
| subject has exceeded number of tokens limit | error_code | error | nats, subject, subscription, configuration |
| encountered panic without a token | error_code | error | config, panic, recovery |
| JetStream message size exceeds limits for | validation | warning | jetstream, publish, message-size, limits |
| mqtt authentication token not compatible with presence of… | validation | error | mqtt, config, authentication |
| error closing compression writer | exception | error | io, compression, filestore |
| invalid mapping destination: wildcard index out of range | validation | error | jetstream, subject-transform, config-validation |
10069 change to limits violates consumers | error_code | error | jetstream, stream, consumer, limits, api-error |
| stream assignment error | exception | error | jetstream, clustering, health-check, stream-assignment |
| default_js_domain contains account name | validation | error | jetstream, configuration, domain, nats-server |
| failed to activate stream | exception | error | jetstream, stream-restore, activation, storage |
| account jwt not found | exception | error | nats, jwt, resolver, configuration |
| account missing | error_code | error | nats, account, nil-check, service-export |
| operators do not allow authorization callouts to be… | validation | error | configuration, operator-mode, jwt, auth-callout |
| gsl: invalid subject | exception | error | nats, subject, validation, sublist |
| max_ack_pending must be set to -1 | validation | error | jetstream, consumer-config, validation, nats |
| attempted to connect to route port | error_code | error | nats, configuration, wrong-port, client |
| failed to compress block | exception | error | filestore, compression, jetstream, go |
| invalid MQTT session | validation | error | mqtt, session, connection-state |
| invalid ocsp ca configuration | validation | error | ocsp, tls, configuration, certificate-bundle |
| unable to connect | exception | error | mqtt, authentication, jetstream, connection-setup |
| attempted to connect to gateway port | error_code | error | nats, gateway, port-misconfiguration, connection |
| connection rejected since minimum version required is | exception | error | nats, leafnode, version, protocol-error |
| Error processing trusted operator keys | exception | error | |
| the first packet should be a CONNECT | validation | error | mqtt, protocol-violation, connection-setup |
| auth callout violation: auth callout response is not for… | exception | error | auth, jwt, callout, security, nats |
| failed to read PROXY protocol header | error_code | error | proxy-protocol, network, io, truncated-header |
ErrStoreECDSASigningError unable to obtain ECDSA signature from store | error_code | error | windows, certificate-store, ecdsa, ncrypt, signing |
| store is not set up to for delete | validation | error | jwt, store, configuration |
| duplicates window can not be larger then server limit of | error_code | error | jetstream, stream-config, account-limits, nats |
| OCSP storage directory is not a directory | validation | error | |
| can not marshal | exception | error | go, json, serialization, nats-streaming |
| system limit reached | exception | error | jetstream, cluster, limits, ha-assets, configuration |
| unsupported route compression mode | validation | error | |
| error adding stream | exception | error | jetstream, stream-restore, stream-creation |
| error resolving system account | exception | critical | nats-server, system-account, resolver, startup |
| max_request_batch must be set if it's JetStream limits are… | validation | error | jetstream, consumer, config-validation, pull-consumer |
| operators require an account resolver to be configured | validation | error | nats, jwt, config-validation, operator-mode |
| system account not setup | error_code | error | nats, system-account, configuration, jetstream |
| change to limits violates consumers | validation | error | jetstream, stream-config, consumers, limits |
| duplicate server name | exception | error | nats, cluster, server-name, configuration |
| minimum version required | exception | error | nats, leafnode, version, compatibility |
| queue is not a valid queue | validation | error | nats, config-validation, subject |
| invalid mapping destination: unknown function | validation | error | subject-mapping, transform, config |
| JetStream cluster requires cluster name | exception | error | jetstream, nats, configuration, clustering |
| default sentinel must be a bearer token | validation | error | config, authentication, jwt, bearer-token |
| %v | error_code | error | config, panic, type-mismatch |
| : v1 line too long | validation | error | proxy-protocol, network, tcp, nats |
| failed to read v2 header | error_code | error | proxy-protocol, network, io, truncated-header |
| topic cannot be empty | validation | error | mqtt, protocol-validation, publish-packet |
| proxy is configured but remote URL | validation | error | configuration, leafnode, proxy, tls, websocket |
| unexpected content (account= ) | exception | error | |
| fileStore requires file storage type in config | validation | error | jetstream, storage-config, filestore, go |