nats-io/nats-server
Documented errors, page 3 of 10. Back to nats-io/nats-server
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| consumer name can not contain '.', '*', '>', '\', '/' | validation | error | jetstream, consumer, naming, config-validation |
| create QoS2 outgoing PUBREL stream for account | exception | error | mqtt, jetstream, qos2, stream-creation |
| processRoutedOriginClusterMsgArgs Bad or Missing Header Size | validation | error | |
| timeout after : request type on (reply= ) | exception | error | jetstream, mqtt, timeout, api-request |
| unable to start session | exception | error | tpm, windows, auth-session, go |
| cluster | validation | error | |
| compression mode requires at least one RTT threshold | validation | error | |
| duplicate window cannot be bigger than max age | error_code | error | jetstream, stream-config, pedantic, validation, deduplication |
| error opening config file | validation | error | config, file-io, startup, nats-server |
| errors.New(strings.Join(errs, "\n")) | exception | error | jetstream, consumer-state, pending, validation |
| invalid mapping destination: function argument is invalid… | validation | error | jetstream, subject-transform, config-validation |
| unable to bind PCRs to auth policy | exception | error | tpm, windows, pcr, policy, go |
| when client ID is empty, clean session flag must be set to 1 | validation | error | mqtt, protocol, session, client-error |
| account resolver missing | error_code | error | nats, server, account-resolver, configuration |
JS_ERR_GENERIC account name can not contain path separators | validation | error | jetstream, validation, path-traversal, nats-server |
| sanity check failed | exception | error | corruption, recovery, sanity-check, filestore |
| websocket: invalid header | validation | error | websocket, headers, config-validation |
| consumer node missing | exception | warning | jetstream, nats, raft, consumers |
| create QoS2 incoming messages stream for account | exception | error | mqtt, jetstream, qos2, stream-creation |
| error parsing url [ ] | validation | error | config, url, parsing, credentials |
| incomplete type, value pair | exception | error | jetstream, consumer-state, validation |
JS_STREAM_ROLLUP_FAILED rollup not permitted | error_code | error | jetstream, rollup, stream-config, permissions |
| MQTT clients over websocket must connect to the Websocket… | validation | error | mqtt, websocket, network, wrong-port |
| user JWT issuer is not known | validation | error | auth-callout, jwt, signing-key |
| websocket requires TLS configuration | validation | error | websocket, tls, config, startup |
| auth callout signing key is unknown | exception | error | auth, jwt, callout, signing-keys, security, nats |
| auth callout violation: auth callout response is not for… | exception | error | auth, jwt, callout, security, nats |
| Could not parse snapshot peerstate correctly | console | error | |
| gateway name cannot contain spaces | error_code | error | nats, gateway, config-validation, naming |
| populating per-subject info for block | exception | error | jetstream, filestore, per-subject-index, stream-recovery |
| : config has no values or is empty | validation | warning | config, warning, empty-file |
| : invalid version 0x%02x | validation | error | proxy-protocol, network, binary-protocol |
| config reload not supported for jetstream max memory and… | validation | error | |
| config reload not supported for | validation | error | nats-server, config-reload, leafnodes |
ErrExtractingRSAPublicKey unable to extract RSA public key from store | error_code | error | windows, certificate-store, rsa, public-key, ncrypt |
| invalid fixed header flags | validation | error | mqtt, protocol-violation, malformed-packet |
JS_INVALID_JSON consumer group not specified | error_code | error | jetstream, validation, json, consumer-group |
| unknown PROXY protocol command: 0x%02x | validation | error | proxy-protocol, protocol-violation, network |
| could not access event log | panic | critical | windows, syslog, eventlog, panic |
| Could not add shadow import subscription for account | exception | error | |
| counter stream cannot use discard new | error_code | error | jetstream, stream-config, counter, nats |
| metadata incomplete | exception | error | jetstream, filestore, compression, corruption |
| processHeaderPub Parse Error | validation | error | nats, protocol, hpub, headers |
| bad pending entry, sequence | validation | error | jetstream, consumer-state, filestore, pending, validation |
| default sentinel requires operators and accounts | validation | error | config, authentication, jwt, operator-mode |
| error reading compression reader | error_code | error | compression, io, cache, corruption |
| user JWT is not valid | validation | error | auth-callout, jwt, scoped-signer |
10094 consumer delivery policy is deliver last per subject, but FilterSubject is not… | error_code | error | jetstream, consumer, config-validation, api-error |
| fetching jwt failed due to shutdown | exception | error | monitoring, http, validation, connz |
| invalid mapping destination: not using all of the token… | validation | error | subject-mapping, transform, wildcards |
| unknown version | validation | error | nats-server, tls, configuration, version |
| sequence numbers for cache load did not match | exception | error | filestore, cache, sequence, jetstream, go |
| subject of existing and new jwt do not match | validation | error | jwt, claims, store |
| stream import not authorized | error_code | error | nats, server, authorization, stream-import |
| unknown trace type | validation | error | |
| config reload not supported for jetstream dynamic max… | validation | error | nats-server, config-reload, jetstream |
| total weight needs to be <= 100 | validation | error | nats-server, config-validation, weighted-mapping |
| wrong issuer for auth callout response on account | exception | error | auth-callout, jwt, issuer |
| not enough nonce bytes read | exception | error | crypto, nonce, entropy, filestore |
| attempted to connect to leaf node port | error_code | error | nats, configuration, wrong-port, leafnode |
| config reload not supported for | validation | error | nats-server, config-reload, gateways |
ErrWriteTooLong archive: write exceeds declared entry size | error_code | error | go, archive, writer, size-mismatch |
| expected message sequence | exception | error | |
| failed to create mapping transform for stream import… | exception | error | nats-server, stream-imports, subject-transform, configuration |
| failed to load block from disk | exception | error | io, corruption, truncation, filestore |
| got corrupted escaped character | exception | error | jetstream, validation, consumer-config |
| invalid domain name: derived | validation | error | jetstream, configuration, domain, subject-validation |
| Request from follower for entry at index | console | error | |
10005 preferred server is already leader | error_code | error | jetstream, clustering, raft, placement, nats-server |
ErrNoActiveEntry archive: no active entry | error_code | error | go, archive, writer, api-misuse |
| failed to truncate msg block | exception | error | jetstream, filestore, stream-truncate, file-handle |
| QoS1 in-flight window is full | validation | error | mqtt, jetstream, backpressure, inflight-window, qos1 |
| reserved account | error_code | warning | nats, account, reserved-name |
ErrBadCryptoStoreProvider unable to open certificate store or store not available | error_code | critical | windows, certificates, certstore, crypto, configuration |
| invalid remaining length | validation | error | mqtt, protocol-violation, malformed-packet |
| mqtt requires server name to be explicitly set | validation | error | mqtt, configuration, server-name, cluster |
| processRoutedOriginClusterMsgArgs Bad or Missing Size | validation | error | |
| stream subject transform from | exception | error | jetstream, stream, subject-transform, validation |
| unable to find certificate in store | exception | error | windows, certstore, certificate-not-found, tls |
| account validation failed | error_code | error | nats, server, jwt, account-validation |
| accounting inconsistent | exception | warning | filestore, index, accounting, consistency, go |
| config reload not supported for decreasing jetstream max… | validation | error | nats-server, config-reload, jetstream |
| couldn't load consumer | exception | error | |
| processRemoteUnsub | validation | error | nats-server, protocol, unsub, leaf-nodes |
| unable to regenerate SRK from the TPM | validation | error | |
10157 origin stream has direct get set, mirror has it disabled | validation | error | jetstream, mirror, allow-direct, pedantic |
| duplicates window can not be larger then max age | error_code | error | jetstream, stream-config, validation, nats |
| failed to add consumer | exception | error | |
| failed to connect to proxy | exception | error | network, proxy, dial, connectivity |
| invalid websocket connection | exception | error | |
| subject transform from | exception | error | jetstream, stream-sources, subject-transform, validation |
| unable to get subject transform for source | validation | error | jetstream, subject-transform, stream-sources |
10155 %w %s | validation | error | jetstream, stream-config, subject-transform, validation |
| could not create storage streams directory | exception | critical | jetstream, filesystem, permissions, nats-server |
| create retained messages consumer for account | exception | error | jetstream, mqtt, consumer, ephemeral-consumer |
| Partial cache: offset slot index | console | error | |
| snapshot check detected | exception | critical | jetstream, filestore, snapshot, data-integrity |
ErrNegativeEntrySize archive: negative entry size | error_code | error | archive, io, validation, go |
| inactive_threshold must be set if it's configured in stream… | validation | error | jetstream, consumer-config, stream-limits, inactive-threshold |
| invalid type name: %+v | exception | error | ldap, x509, certificate, dn, oid |