lima-vm/lima

Documented errors, page 5 of 5. Back to lima-vm/lima

Code / MessageTypeSeverityTags
field `additionalDisks
validation error lima, config-validation, disk
unsupported log-format: %#q
validation error cli, logging, flags
caching-only mode requires the cache directory to be…
exception error downloader, cache, configuration, missing-option
invalid parameter %#q, expected NAME=VALUE
validation error cli, template, parameters, argument-parsing, lima
unexpected video display %#q
validation error display, video, vz-driver, config-validation
`limactl network delete` currently always requires `--force`
console error network, cli, destructive-command
path %#q is not an absolute path
validation error config, validation, paths, networks-yaml
driver is running but host agent is not
console error lima, driver, orphaned-process, pid-files
failed to attach disk
exception error guestpatch, macos, disk-attach, dmg
field `mounts[ ].mountPoint` must not be a system path such…
validation error lima, config-validation, mounts, guest-filesystem
field `mountType` must be %#q or %#q for QEMU driver on…
validation error qemu, mount, macos, validation
field `mountType` must be %#q or %#q for VZ driver , got %#q
validation error config-validation, mount, vz
field `provision[ ].format` can only be set when mode is %#q
validation error lima, config-validation, provision, mode-mismatch
invalid integer value
exception error plist, integer, parsing, strconv
invalid parameter %#q, expected `static=` followed by a…
validation error cli, port-forward, argument-parsing, lima
could not detect a text editor binary, try setting $EDITOR
exception error editor, environment, interactive
failed to read instance state for instance %#q because no…
exception error wsl2, missing-distro, setup
failed to read ssh public key %#q
console error ssh, file-io, permissions
field `user.shell` must be an absolute path, got %#q
validation error lima, shell, path-validation
failed to attach ASIF image %#q
exception error macos, diskutil, attach, asif
failed to read raw digest file
exception error downloader, cache, file-io, permissions
invalid ssh local port
validation error ssh, port, config, validation
invalid value for number of cpus, must be >= 0
validation error cli, cpu, validation, lima
failed to unregister the autostart entry for instance %#q
console error autostart, systemd, permissions
field `user.shell` must be one of
validation error lima, windows-guest, shell, config-validation
expected haCmd.Stderr to be *os.File, got %T
exception error internal-invariant, hostagent, unix
failed to create .ssh directory for user %#q
exception error filesystem, ssh, macos, guestagent
failed to remove the autostart entry for instance %#q
exception error autostart, filesystem, permissions
failed to stop usernet %#q
error_code error network, usernet, daemon-stop, process-kill
option --yq only works with --format json or yaml
validation error cli, flags, yq, lima
failed to open sudoers file %#q
exception error sudoers, filesystem, permissions, macos
failed to stop VM after installation
error_code error vz, vm-lifecycle, macos-guest, install
field ` .hostSocket` must be less than UNIX_PATH_MAX=…
validation error lima, port-forwarding, unix-socket, path-length
images[ ].kernel has unexpected architecture %#q, must be…
validation error lima, images, kernel, arch-mismatch
no RequestStop function available
exception error autostart, api-misuse, configuration
disk %#q already exists (%#q)
console error disk, duplicate, limactl
field `mountType` must be %#q or %#q for QEMU driver on
validation error qemu, mount, validation, platform
field `mounts[ ].mountPoint` is the reserved internal home…
validation error lima, config-validation, mounts
failed to run `wsl.exe --terminate
exception error wsl2, windows, wsl-exe, vm-stop
failed to write to sudoers file %#q for user %#q
exception error sudoers, filesystem, macos, guestagent
field `mounts[ ].location` refers to an inaccessible path…
validation error lima, filesystem, permissions, mounts
rsync is required for `--sync` but not found
console error cli, limactl, rsync, missing-binary, sync
sysctl: unimplemented on Windows
exception error windows, sysctl, unimplemented, portability
field ` .guestSocket` can only be mapped to a single port…
validation error lima, port-forwarding, unix-socket, config-validation
failed to open ASIF device %#q
exception error macos, permissions, device-open, asif
scp not found on host
exception error scp, openssh, host-environment, dependency-missing
failed to force stop VM after installation
error_code error vz, vm-lifecycle, macos-guest, install
field `mountType` must be %#q for QEMU driver on Windows…
validation error qemu, mount, windows, validation
network mode %#q does not support specifying interface
console error network, cli, flag-conflict
: archVariant mismatch (expected , got )
exception warning images, arch-variant, arm64
disk format %#q not supported, use `qcow2` or `raw` instead
console error disk, validation, cli
failed to run `wsl --list --verbose`, err
exception error wsl2, state-detection, wsl-cli
local files are not cached
validation error go, api-misuse, cache, validation
unsupported protocol
exception error guestagent, netlink, sockets, linux
field ` .hostSocket` can only be mapped from a single port…
validation error lima, port-forwarding, unix-socket, config-validation
expected the format of %#q to be one of
validation error disk-image, vz-driver, unsupported-format
failed to stat raw tmp file
exception error downloader, file-io, stat, cache
unsupported image type for
validation error wsl2, squashfs, image-format
--condition=boot is only supported on macOS
console error macos, linux, windows, cli-flags, platform-support
failed to scan kubectl event stream
exception error guestagent, bufio, stream, kubernetes
`limactl start --foreground` is not supported on Windows
exception error windows, unsupported, hostagent
path %#q contains whitespace
validation error config, validation, paths, networks-yaml
cannot start DNS server
exception error dns, network, resolver, bind
failed to unmount %#q
exception error macos, umount, filesystem, subprocess
invalid group %#q
validation error config, validation, networks-yaml, sudoers
failed to find a free port, try setting `ssh.localPort`…
exception error ssh, port, network, port-exhaustion
field `mountType` must be %#q for WSL2 driver, got %#q
validation error wsl2, validation, mounttype, config
field UID must not be 0
validation error validation, uid, cidata
inode not found in filesystem B-tree
exception error apfs, inode, not-found, b-tree, chown
field `tpm` is not supported on WSL2 driver
validation error wsl2, config-validation, tpm
invalid interface %#q for network %#q
validation error config, validation, networks-yaml, bridged
option --list-fields conflicts with option --filter
validation error cli, flags, lima
option --list-fields conflicts with option --format
validation error cli, flags, lima
option --list-fields conflicts with option --yq
validation error cli, flags, yq, lima
field `probe[ ].script` must start with a '#!' line
validation error config-validation, probe, shebang, shell
option --quiet can only be used with '--format table'
validation error cli, flags, lima
message %#q is not a valid template
console error lima, go-templates, config
VZ driver requires macOS 13 or higher to run
validation error version-requirement, vz, macos
field `mounts[ ].location` refers to an unexpandable path…
validation error lima, config-validation, path-expansion, mounts
failed to run `wsl.exe --unregister
exception error wsl2, unregister, instance-deletion
invalid socks port
console error cli, tunnel, port, socks
failed to detach ASIF image %#q
exception warning macos, hdiutil, detach, asif
unexpected arguments
console error cli, macos, sudoers, argument-validation
invalid network name %#q
validation error config, validation, networks-yaml, naming
option --json conflicts with option --format
validation error cli, flags, lima
field `arch` must be one of
validation error lima, arch-field, config-validation
field ` .guestSocket` must be an absolute path, but is %#q
validation error lima, port-forwarding, unix-socket, config-validation
failed to resize ASIF image %#q
exception error macos, diskutil, resize, asif
invalid mode %#q for network %#q
validation error config, validation, networks-yaml, mode
field `mounts[ ].mountPoint` must not start with `~
validation error lima, config-validation, mounts, path
field ` .guestIPMustBeZero` can only be true when field `…
validation error config-validation, port-forward, lima-yaml
images[ ].initrd has unexpected architecture %#q, must be…
validation error lima, images, initrd, arch-mismatch
field `mounts[ ].location` must be an absolute path, got %#q
validation error lima, config-validation, mounts, path
field ` .guestPortRange[1]` must be greater than or equal…
validation error lima, port-forwarding, config-validation
field ` .hostPortRange[1]` must be greater than or equal to…
validation error lima, port-forwarding, config-validation
field `probe[ ].file.digest` support is not yet implemented
validation error config-validation, probe, unsupported-feature
unknown format: %#q
exception error ssh, invalid-argument, enum
field `images` must be set
validation critical lima, images, config-validation
field `cpus` must be set
validation error lima, cpus, config-validation
field `tpm` is not supported in krunkit driver
validation error krunkit, config-validation, tpm