ErrLookup › lima-vm/lima

lima-vm/lima

Linux virtual machines, with a focus on running containers · Go · 302 source files

Analyzed at dd909d0973 on 2026-09-01. 500 documented errors.

Code / MessageTypeSeverityTags
base disk (%#q) child must not have a different filename…
validation error qemu, disk-image, qcow2, security, validation
can check only a single sudoers file
console error cli, macos, sudoers, argument-validation
failed to check if the autostart entry for instance %#q is…
console error autostart, systemd, cli, limactl-edit
configuration is nil
validation error wsl2, validation, nil-config
unimplemented by the krunkit driver
error_code warning krunkit, macos, driver, unimplemented, snapshots
failed to write password file for user %#q
exception error filesystem, macos, guestagent, cloud-init
failed to marshal as JSON: %+v
panic error json, templates, panic, serialization
field `provision[ ].mode` cannot set…
validation error lima, limayaml, validation, provision
base disk (%#q) child must not have children of its own
validation error qemu, disk-image, qcow2, backing-chain, validation
template %#q not found
validation error templates, file-not-found, configuration, cli
unable to load instance
console error cli, instances, filesystem
field `provision[ ].permissions` must be an octal number
validation error lima, config-validation, provision, permissions
field ` .proto` must be %#q, %#q, or %#q
validation error lima, config-validation, port-forwarding, yaml
cannot use `--sync` when the instance has host mounts…
validation error cli, limactl, mounts, sync
failed to determine the host directory to sync
console error cli, limactl, filesystem, sync, path-resolution
looking up %#q in directory
exception error apfs, path-resolution, filesystem
failed to create driver instance
exception error snapshot, driver, instance, configuration
base disk (%#q) must not have multiple children: %+v
validation error qemu, disk-image, vmdk, security, validation
failed to close raw tmp file
exception error go, filesystem, cache, io
failed to marshal instance %#q
console error cli, json, internal
`firmware.images` configuration is not supported for VZ…
validation error macos, vz, config-validation, firmware
omap entry for OID not found
exception error apfs, omap, oid-resolution
failed to read driver directory %#q
exception warning filesystem, drivers, permissions, plugin-discovery
field `provision[ ].playbook can only be set when mode is…
validation error lima, config-validation, provision, ansible, mode-mismatch
failed to create virtio sound device configuration
error_code error audio, vz, macos, virtualization-framework
resolving filesystem root tree OID
exception error apfs, disk-image, filesystem-internals
failed to unregister instance %#q from start at login
console error autostart, limactl, filesystem
finding APFS partition
exception error apfs, gpt, disk-image, partition-table
failed to load disk %#q
exception error krunkit, disks, macos, start
failed to validate the instance YAML after filling defaults
validation error validation, yaml, snapshot, config
failed to run %#q on %#q: %#q
exception error windows, fsutil, exec, cygpath
chown inode (%#q)
exception error apfs, disk-image, ownership, write-failure
networks.yaml ' ' configuration is only supported on macOS…
error_code error network, vz-driver, macos, platform-support
failed to rsync to the guest
console error rsync, ssh, vm, file-sync
field `provision[ ].expression` must not be empty when mode…
validation error lima, config-validation, provision, yq
ssh option %#q contains a line break
validation error ssh, input-validation, config-injection
c.Paths.SocketVMNet is empty
panic critical network, daemon, panic, config, go
failed to marshal as YAML: %+v
panic error yaml, templates, panic, serialization
the YAML is invalid, attempted to save the buffer as %#q…
validation error yaml, validation, filesystem, cli
can't determine instance name from template locator %#q
console error cli, template, instance-name
failed to apply filter %#q
console error cli, yq, filter
failed to inspect instance %#q
exception error cli, instance-store, limactl
reading container superblock
exception critical apfs, disk-image, corruption
failed to wait for less command
console error pager, cli, terminal
field `tpm` is not supported on VZ driver
validation error config-validation, tpm, vz
unsupported shell %#q for Windows guest, must be one of
validation error cli, limactl, windows, shell, configuration
failed to create temporary directory
console error temp-directory, filesystem, tui
currently Windows guest is only supported on [%#q, %#q]…
validation error lima, windows-guest, vmtype, config-validation
failed to get macOS product version
error_code error macos, vz-driver, rosetta
field ` .reverse` must be %t
validation error lima, config-validation, port-forwarding, yaml
failed to connect to %#q
console error lima, hostagent, unix-socket, broken-instance
HcsCreateOperation
exception critical windows, hcs, syscall, virtualization
host agent process has exited
exception critical process, hostagent, vm-startup
filesystem B-tree node checksum failed
exception critical apfs, b-tree, checksum, corruption, disk
repository / has no default branch
exception error github-api, http, network
%#q . See ` --help`. Usage
console error cli, arguments, cobra
redirect %#q is not a `github
validation error validation, github, redirect
fsutil: Windows path conversion is not supported on this…
exception error fsutil, windows, platform-support
nested virtualization is not supported on %T
error_code error vz-driver, nested-virtualization, type-mismatch
the YAML is invalid, saved the buffer as %#q
validation error yaml, config-validation, limactl
daemon for %#q network failed to start after attempts
error_code error network, socket-vmnet, daemon-startup, retry-exhausted, macos
failed to run : ; stderr=%#q
exception error kubernetes, kubectl, guestagent, process
failed to unmarshal service object
exception error guestagent, json, schema, kubernetes
failed to unprotect instance %#q
exception error cli, filesystem, permissions, limactl
expected B-tree node type (2 or 3), got %#x
exception error apfs, btree, validation
cannot safely prune while instance %#q is being used
console error prune, instance, race-condition
failed to create driver client
exception error rpc, external-driver, socket, client
%v
exception info download, error-aggregation, sentinel-error
unknown tunnel type: %#q
console error cli, tunnel, flags
reading container omap at
exception critical apfs, disk-image, io-error
expected the depth of the host working directory (%#q) to…
console error cli, limactl, rsync, path-depth, sync
limactl is running under rosetta, please reinstall lima…
console error cli, macos, rosetta, architecture
daemon for %#q network
error_code error network, socket-vmnet, pid-file, daemon-startup, macos
instance %#q seems running (hint: remove %#q if the…
exception error pid-file, already-running, startup
invalid network spec %+v
validation error krunkit, network, config-validation, macos
no socket_vmnet networks defined
exception error krunkit, network, macos, edge-case
failed to build network arguments
exception error krunkit, network, macos, config
cache did not contain %#q
exception error cache, download, containerd, nerdctl
failed to get boot scripts
exception error boot-scripts, driver, iso-generation
redirect %#q must not include a branch/tag/sha (from %#q)
validation error validation, github, redirect
external driver process exited before creating socket file
exception error external-driver, process-exit, socket, startup
could not find firmware for %#q
exception error qemu, firmware, edk2, aarch64
unknown header
console error snapshot, output-parsing, cli
field ` .guestPort` must be 0 when field ` .guestSocket` is…
validation error config-validation, port-forward, lima-yaml
invalid value for static parameter: %#q
validation error cli, port-forward, argument-parsing, lima
resolving path %#q
exception error apfs, disk-image, path-resolution
failed to run wslpath command
exception error wsl2, windows, wslpath, provisioning
omap node checksum failed
exception critical apfs, checksum, corruption
invalid permissions %#q for path %#q
validation error cloud-init, macos, permissions, configuration
: (result: )
exception critical windows, hcs, hypervisor, hresult
did not receive an event with the `running` status
exception error hostagent, timeout, vm-startup
external driver process exited before creating socket file
exception error external-driver, process-crash, socket, startup
invalid port forward format %#q, expected HOST:GUEST or…
validation error port-forward, cli, argument-parsing, validation
pidfile %#q already exists
exception error cli, filesystem, pidfile, network
read APFS superblock at offset
exception error apfs, gpt, io, truncated-image
exiting, status=%+v (hint: see %#q)
exception error hostagent, lifecycle, vm-startup
failed to get rsync version
console error cli, limactl, rsync, version-check, sync
invalid date value
exception error plist, date, parsing, rfc3339
invalid digest algorithm %#q
validation error go, validation, digest, path-traversal
failed to marshal instance config
exception error json, serialization, external-driver